Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Brightness doesn't change on openSUSE 13.1, Nvidia quadro.

  1. #1

    Default Brightness doesn't change on openSUSE 13.1, Nvidia quadro.

    Hi all,
    I come from years and years of Ubuntu, and I installed openSUSE 13.1 about a month ago.
    I really like it and I want to use it as my main distribution, but I can't find a solution for the backlight which does't change.

    - On Ubuntu backlight variation is working, both with keys and settings slider.
    - I'm using an HP elitebook 8560w, Nvidia Quadro 2000m.

    Problem:
    I can't change the brightness level neither with keys or settings slider.
    Also when I try to change the values of /
    Code:
    sys/class/backlight/acpi_video0/brightness
    the backlight doesn't change.
    I also tried some of the boot options you can find over internet, but again no success.

    Interesting thing:
    If I set the brightness during the bios boot phase, openSUSE mantains that value. If I close the LCD panel and let the PC go to sleep, it will wake up at maximum brightness value.

    It's about a month I try to figure out a solution, can you please help me in some ways?

    thank you,
    Silvio

  2. #2
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: Brightness doesn't change on openSUSE 13.1, Nvidia quadro.

    Use:
    Code:
    cat /sys/class/backlight/acpi_video0/
    This will show you what controls the brightness i.e. intel, nvidia.


    To enable brightness:

    Add the following entry to the end of the GRUB_CMDLINE_LINUX variable in the /etc/default/grub file.
    Code:
    acpi_backlight=vendor acpi_osi=linux
    Run as root:
    Code:
    grub2-mkconfig -o /boot/grub2/grub.cfg
    Restart your laptop to review the brightness.
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  3. #3
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: Brightness doesn't change on openSUSE 13.1, Nvidia quadro.

    Install the Nvidia drivers provided by the Yast Control Center. Choose Software Repositories.
    • Click on the Add button -->Select Community Repositories
    • Click on the Next button
    • From the list select nVidia Graphics Drivers
    • Start Yast Software Management and the G03 drivers


    You also try using xbacklight. If you do not have it installed use zypper to install:
    Code:
    zypper in xbacklight

    xbacklight --help

    usage: xbacklight [options]
    where options are:
    • -display <display> or -d <display>
    • -help
    • -set <percentage> or = <percentage>
    • -inc <percentage> or + <percentage>
    • -dec <percentage> or - <percentage>
    • -get
    • -time <fade time in milliseconds>
    • -steps <number of steps in fade>


    To increase:
    Code:
    xbacklight -inc 10
    To decrease:
    Code:
    xbacklight -dec 10
    If the problem still exists despite the grub entries and xbacklight there could be an ACPI bug with HP Elitebook 8560w and the present kernel.
    Try the kernel 3.12x by adding this repository and updating the kernel:

    http://download.opensuse.org/repositories/Kernel:/stable/standard/

    Restart your laptop after updating the kernel.
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  4. #4

    Default Re: Brightness doesn't change on openSUSE 13.1, Nvidia quadro.

    Thank you very much for the help, I first included the parameters in the grub configuration file, and something happended, the brightness partially worked (a dimming of about +/- 10%).
    So I tried installing the nvidia drivers, and now brightness controls are completely gone: no slider in settings and no control with keys.

    Should I go with the kernel upgrade?

    thank you, Silvio

  5. #5

    Default Re: Brightness doesn't change on openSUSE 13.1, Nvidia quadro.

    I just tried to remove the grub options and now I have brightness controls again, unfortunately they're not working.

    It's funny that changing the slider or using fn keys I can see the values of
    Code:
    /sys/class/backlight/acpi_video0/actual_brightness
    change, but with no effect.

  6. #6

    Default Re: Brightness doesn't change on openSUSE 13.1, Nvidia quadro.

    Ok I tried to update the kernel, and got an "oh no, something went wrong" screen. I solverd uninstalling and reinstalling the nvidia drivers.

    Unfortunately, I still can't control the brightness.
    Even in this case, if I add the suggested parameters to the grub configuration file, the PC boots with no backlight interface (no slider in settings, no fn keys, no files in /sys/class/backlight).

    Any idea for solving this? I'm trying all my best but I'm kinda like a noob...

  7. #7

    Default Re: Brightness doesn't change on openSUSE 13.1, Nvidia quadro.

    I just noticed that the backlight service is active but disabled:



    If I try to enable the service, I get this error:



  8. #8
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: Brightness doesn't change on openSUSE 13.1, Nvidia quadro.

    The "oh no, something went wrong" message was do to the fact that the nVidia driver rpms provided for openSUSE. They are only compiled for the stock kernel and future updates provided for openSUSE 13.1.

    Did you in install install the nVidia drivers provided by the Community Repositories in Yast or did you download and install the driver from the nVidia site?
    Which driver version are you using? Are you using x86_64?

    I would like you to install the following packages in Yast in case you may need to install the nVidia driver from the nVidia website..

    Please select and install the following files from the Yast2 Package search field.
    Code:
    gcc make patch kernel source kernel-syms
    Tip:
    When searching for the kernel source in the search field, type "kernel-s" (without the quotes) to find kernel source and kernel-syms packages. They will pull in additional files for installation.

    In the meantime we'll see how the stock kernel will perform with the code below.
    To enable the the brightness for the nVidia card add the following code to /etc/X11/xorg.conf.d/50-device.conf
    Code:
    Section "Device"
      Identifier "Default Device"
      Driver "nvidia"
      VendorName "NVIDIA Corporation"
      Option  "RegistryDwords" "EnableBrightnessControl=1"
    EndSection
    Shutdown and restart your laptop. Check out the brightness by ensuring that the command in the two screenshots has been enabled and started.
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  9. #9

    Default Re: Brightness doesn't change on openSUSE 13.1, Nvidia quadro.

    Thank you very much Romanator, unfortunately the backlight control still doesn't work.

    I'm trying every combination but the problem still persist, here my actual configuration:

    - kernel 3.12
    - nvidia drivers (issues solved, thank you)
    - device added in /etc/X11/xorg.conf.d/50-device.conf
    - no additional parameters in GRUB (if I add the suggested options the backlight controls completely disappear)
    - process system-backlight@acpi_video0 is active but disabled, no way to enable it (I don't know if there are other ways, actually...)
    - xbacklight gives me no output with --get or --set

  10. #10
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: Brightness doesn't change on openSUSE 13.1, Nvidia quadro.

    Looks like this problem exists all over the Internet with the HP 8460p laptop with every Linux distro.

    It appears that previous patches for the hp-wmi have broken the brightness keys mapped in the kernel for a number of HP laptops.
    I would sign up with Bugzilla and submit a bug report marked "critical" for "brightness keys broken to control brightness with Nvidia Quadro 2000m" in the Linux kernel.

    https://bugzilla.novell.com/index.cgi
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •