Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: No advanced OpenGL desktop effects in KDE after upgrading to OpenSuse 13.1 (Intel HD 4000).

  1. #1

    Default No advanced OpenGL desktop effects in KDE after upgrading to OpenSuse 13.1 (Intel HD 4000).

    I've just upgraded to 13.1 and my Intel HD 4000 graphics card doesn't work as it should. When I go to (KDE) System Settings > Desktop Effects > Advanced, there is Xrender as a default option and when I try to change to OpenGL 1.2/2.0/3.1, a message appears at the top of the window saying that some desktop effects could not be activated (like blur, cube, wobby windows etc). After system restart it returns to Xrender.

    OpenGL does work on my system:

    Code:
    $ glxinfo | grep OpenGL
    OpenGL vendor string: VMware, Inc.
    OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 256 bits)
    OpenGL version string: 2.1 Mesa 9.2.3
    OpenGL shading language version string: 1.30
    OpenGL extensions:
    Also proper graphics drivers should be installed. I checked in Yast and it seems that I'm using i915 module.

    The only special thing about my laptop is that it has Nvidia Optimus. But everything worked flawlessly in 12.3 out of the box. After installing Bumblebee even switching cards.

  2. #2

    Default Re: No advanced OpenGL desktop effects in KDE after upgrading to OpenSuse 13.1 (Intel HD 4000).

    Quote Originally Posted by tobice View Post
    OpenGL does work on my system:

    Code:
    $ glxinfo | grep OpenGL
    OpenGL vendor string: VMware, Inc.
    OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 256 bits)
    OpenGL version string: 2.1 Mesa 9.2.3
    OpenGL shading language version string: 1.30
    OpenGL extensions:
    llvmpipe is the software renderer. That means 3D hardware support _is not_ working.
    And that's the reason why you can't turn on OpenGL in KDE's desktop effects settings.

    What's the output of:
    Code:
    glxinfo | grep render
    Please post your /var/log/Xorg.0.log, do you have all updates installed? (there were some problems with the shipped intel driver)

  3. #3

    Default Re: No advanced OpenGL desktop effects in KDE after upgrading to OpenSuse 13.1 (Intel HD 4000).

    Code:
    $ glxinfo |grep render
    direct rendering: Yes
    OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 256 bits)
        GL_NV_conditional_render, GL_NV_fog_distance, GL_NV_light_max_exponent,
    My Xorg.0.log.

    I think the relevant part is this:

    Code:
    [     5.332] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
        HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
        HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
        HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
        HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200
    [     5.332] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [     5.332] (II) FBDEV: driver for framebuffer: fbdev
    [     5.332] (II) VESA: driver for VESA chipsets: vesa
    [     5.332] (++) using VT number 7
    
    [     5.332] (EE) [drm] KMS not enabled
    [     5.332] (EE) [drm] KMS not enabled
    [     5.334] (WW) Falling back to old probe method for modesetting
    [     5.334] (II) Loading sub module "fbdevhw"
    [     5.334] (II) LoadModule: "fbdevhw"
    [     5.334] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
    [     5.335] (II) Module fbdevhw: vendor="X.Org Foundation"
    [     5.335]     compiled for 1.14.3.901, module version = 0.0.2
    [     5.335]     ABI class: X.Org Video Driver, version 14.1
    [     5.335] (**) FBDEV(1): claimed PCI slot 0@0:2:0
    [     5.335] (II) FBDEV(1): using default device
    [     5.335] (WW) Falling back to old probe method for vesa
    [     5.335] (EE) Screen 0 deleted because of no matching config section.
    [     5.335] (II) UnloadModule: "modesetting"
    [     5.335] (II) FBDEV(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
    Btw. I have also a problem with screen brightness. My /sys/class/backlight folder is completely empty. Some people fixed it by updating their graphics driver. Is it possible that these two problems are related?

  4. #4

    Default Re: No advanced OpenGL desktop effects in KDE after upgrading to OpenSuse 13.1 (Intel HD 4000).

    Well, you're using the fbdev driver, not intel. I somehow suspected this...

    Quote Originally Posted by tobice View Post
    My Xorg.0.log.

    I think the relevant part is this:
    No, the relevant part is this already:
    Code:
     [     5.225] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.11.6-4-desktop root=UUID=3a2e9db0-933d-4bd2-9a57-3c8c6ba9f1e4 resume=/dev/md125p7 splash=silent quiet showopts "acpi_osi=!Windows 2012" rootfstype=ext4 pcie_aspm=force drm.vblankoffdelay=1 i915.semaphores=1 nmi_watchdog=0 nomodeset
    "nomodeset" effectively disables the use of the intel driver, as that _requires_ KMS.
    You should remove that from your kernel command line (use YaST->System->Boot Loader->Boot Loader Options).
    And maybe you could try to remove those other options as well, but I'm not sure about that.

    Btw. I have also a problem with screen brightness. My /sys/class/backlight folder is completely empty. Some people fixed it by updating their graphics driver. Is it possible that these two problems are related?
    Yes, most likely.
    The fbdev driver doesn't support that at all AFAIK.

  5. #5

    Default Re: No advanced OpenGL desktop effects in KDE after upgrading to OpenSuse 13.1 (Intel HD 4000).

    Well that's the problem because my laptop won't boot without this option. That's why I put it there in the first place. I just get black screen, few seconds of disc activity and then nothing, it's dead.

  6. #6

    Default Re: No advanced OpenGL desktop effects in KDE after upgrading to OpenSuse 13.1 (Intel HD 4000).

    Quote Originally Posted by tobice View Post
    Well that's the problem because my laptop won't boot without this option. That's why I put it there in the first place. I just get black screen, few seconds of disc activity and then nothing, it's dead.
    Well, then you cannot use the intel driver, and no hardware OpenGL therefore, sorry.

    Have you installed all updates? Especially xf86-video-intel-l-2.99.906?

    Does it hang on boot already, or only when X is started?

  7. #7

    Default Re: No advanced OpenGL desktop effects in KDE after upgrading to OpenSuse 13.1 (Intel HD 4000).

    Code:
    $ zypper if xf86-video-intel
    Loading repository data...
    Reading installed packages...
    
    
    Information for package xf86-video-intel:
    -----------------------------------------
    Repository: openSUSE-13.1-Update
    Name: xf86-video-intel
    Version: 2.99.906-12.1
    Well that's bad. But how is it possible that it worked in 12.3 without any problems? Is there any unstable newer version of the driver that I could try?

  8. #8

    Default Re: No advanced OpenGL desktop effects in KDE after upgrading to OpenSuse 13.1 (Intel HD 4000).

    Quote Originally Posted by tobice View Post
    Is there any unstable newer version of the driver that I could try?
    Yes, there is.
    But the question still remains: when does it hang?
    If it hangs before X is loaded, there's no sense in trying to upgrade X or the X driver.
    In that case a newer kernel might help though.

    Also, what about those other boot options? ( "acpi_osi=!Windows 2012" rootfstype=ext4 pcie_aspm=force drm.vblankoffdelay=1 i915.semaphores=1 nmi_watchdog=0 )
    Did you add them on 13.1 because it didn't work, or did you already have them on 12.3?
    Maybe removing them would help? (or maybe just removing some of them?)

  9. #9

    Default Re: No advanced OpenGL desktop effects in KDE after upgrading to OpenSuse 13.1 (Intel HD 4000).

    Sorry I forgot to answer the question. It's hard to tell where it actually hangs because after grub menu disappears I see nothing but a black screen. The disk is doing something according to the flashing indicator but it stops after a while. It does not freeze completely (I can still turn caps lock on/off) but I can't get any output on the screen.

    Those extra options came from 12.3 and are supposed to save some battery life. I tried to remove them (directly in grub) but the result was the same.

  10. #10

    Default Re: No advanced OpenGL desktop effects in KDE after upgrading to OpenSuse 13.1 (Intel HD 4000).

    Quote Originally Posted by tobice View Post
    Sorry I forgot to answer the question. It's hard to tell where it actually hangs because after grub menu disappears I see nothing but a black screen. The disk is doing something according to the flashing indicator but it stops after a while. It does not freeze completely (I can still turn caps lock on/off) but I can't get any output on the screen.
    Try to turn off plymouth (the flash screen) by adding "plymouth.enable=0" to the boot options.

    But if you don't even see the boot splash, then your problem does not lie with X or its intel driver. Disabling plymouth might even help in this case though.

    You could try a newer kernel as already mentioned.
    Here's 3.11.10:
    http://download.opensuse.org/reposit...13.1/standard/
    Here's 3.12.7:
    http://download.opensuse.org/reposit...able/standard/

    Both should be stable.

    Your problem could be caused by a switched off backlight.
    Try adding this to the boot options:
    Code:
    acpi_osi=Linux acpi_backlight=vendor
    or
    Code:
    acpi_osi=Linux acpi_backlight=legacy
    (taken from: https://wiki.archlinux.org/index.php/Backlight#ACPI )
    You have to remove "acpi_osi=!Windows 2012" then of course.

    And maybe you should also specify your exact laptop model.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •