Results 1 to 4 of 4

Thread: Unable to change Grub boot order

  1. #1

    Default Unable to change Grub boot order

    Hey all, I just installed 13.1 on a second hard drive in my computer (Windows 7 on the first drive). While doing the install I kept my eye open for an option to boot to Windows as the default but I never saw one. Everything installed fine, and both operating systems work great, but I need the default OS to be Windows 7. Here's my /etc/default/grub contents:

    Code:
    GRUB_DISTRIBUTOR="openSUSE 13.1"
    GRUB_DEFAULT="Windows 7 (loader) (on /dev/sda1)"
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=8
    GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/disk/by-id/ata-ST31000524AS_6VPH0WHW-part1 splash=silent quiet showopts"
    GRUB_CMDLINE_LINUX_RECOVERY="showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe"
    GRUB_CMDLINE_LINUX=""
    GRUB_TERMINAL=gfxterm
    GRUB_GFXMODE=auto
    GRUB_DISABLE_OS_PROBER=false
    GRUB_THEME=/boot/grub2/themes/openSUSE/theme.txt
    GRUB_BACKGROUND=/boot/grub2/themes/openSUSE/background.png
    I pulled the Windows line out of grub.cfg:

    Code:
    menuentry 'Windows 7 (loader) (on /dev/sda1)' --class windows
    and made sure to run grub2-mkconfig when I finished but the default boot option remains OpenSUSE. Am I missing something obvious here?

    Thanks,

    Joe B

  2. #2

    Default Re: Unable to change Grub boot order

    Quote Originally Posted by jbruyet View Post
    and made sure to run grub2-mkconfig when I finished but the default boot option remains OpenSUSE. Am I missing something obvious here?
    AFAIK you could also specify the number of the entry.

    But I would just use YaST->System->Boot Loader->Boot Loader Options to set the default entry.
    That should do "the right thing" (tm)...

  3. #3

    Default Re: Unable to change Grub boot order

    Hi wolfi323, yeah I was just heading back in here to say that I found it in YAST. That's crazy because I'm 99.968% sure I checked YAST a couple of times and only saw the default OpenSUSE entry in there. You had the right answer -- YAST did the trick.

    Thanks,

    Joe B

  4. #4

    Default Re: Unable to change Grub boot order

    Quote Originally Posted by jbruyet View Post
    and made sure to run grub2-mkconfig when I finished but the default boot option remains OpenSUSE. Am I missing something obvious here?
    what command did you run i.e. did you just print to stdout or actually write to file?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •