Results 1 to 9 of 9

Thread: Can't find apache module in repository

  1. #1

    Default Can't find apache module in repository

    Hello,

    I have downloaded also a non official repository but i can't find the module -imagemap- in the list given by packet list of yast.

    Thanks

    GM

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Can't find apache module in repository

    Quote Originally Posted by GabrieleMartino View Post
    Hello,

    I have downloaded also a non official repository but i can't find the module -imagemap- in the list given by packet list of yast.

    Thanks

    GM
    If you don't tell us, we won't know which openSUSE version, which repo you added ( or did you actually download an entire repository ). The more info you provide, the better we can help you.
    Please post output (between CODE tags, the # in the editor) of
    Code:
    zypper lr -d
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Can't find apache module in repository

    Quote Originally Posted by Knurpht View Post
    If you don't tell us, we won't know which openSUSE version, which repo you added ( or did you actually download an entire repository ). The more info you provide, the better we can help you.
    Please post output (between CODE tags, the # in the editor) of
    Code:
    zypper lr -d

    Ok, now works fine, i update package apache2 from the repository of version 13.1. I resetting the apache2 config of before (default-server and httpd) and works fine.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Can't find apache module in repository

    Quote Originally Posted by GabrieleMartino View Post
    Ok, now works fine, i update package apache2 from the repository of version 13.1. I resetting the apache2 config of before (default-server and httpd) and works fine.
    Thanks for letting us know.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Can't find apache module in repository

    Using OpenSuse 13.1 I've switched repos a couple times and am still missing IMAGEMAP.

    I started using Apache2 from the standard update/upgrade repos. Then I switched to the apache repos (standard and modules) Installed apache again. Did a refresh of the repos and tried again. Still no singe of IMAGEMAP.

    Not sure what to try next.

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Can't find apache module in repository

    Interesting, I'm looking at exactly this same issue right now (mod imagemap not loaded).
    So, just letting you know you're not the only one looking for solution (I'm not out of options yet).

    At the moment, besides the regular OSS repo, I've also added the Apache modules repo
    BTW - IMO this thread probably should be in the Apps forum, not the Networking Forum. And, the only Forum thread on this missing imagemap module isn't sufficiently informative, the OP in that thread merely updated his system and that seemed to fix his problem.

    TSU

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Can't find apache module in repository

    Current status of my investigation:

    Looks like mod_imagemap was likely part of apache 2.2x so could be why the OP was able to simply update and it worked.

    But, is not so clear (yet) for apache 2.4 (current)
    It seems to me that mod_imagemap likely should have been part of the standard apache2 build.
    - Still investigating whether is included but not enabled but doesn't look promising at the moment. Doing a search on "apache2" at software.opensuse.org (list sub-packages) lists many mods but not mod_imagemap
    - I expect downgrading Apache2 from 2.4 either to an earlier minor version or more likely to 2.2 should probably provide mod_imagemap.

    I've also tried some generic rpms on the Internet (version 2.4.x which may or may not be consistent with an apache version), but none work.

    HTH and still looking but not looking good for 2.4.

    Maybe time to submit a bug...

    TSU

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Can't find apache module in repository

    After more investigation, unless I'm missing something, there is no solution currently for mod_imagemap with the current version of Apache2 (2.4). It's definitely missing from the list of base mods which are included by default with Apache2 (2.4) and cannot be found as a separate package.

    Have submitted a bug report
    https://bugzilla.novell.com/show_bug.cgi?id=866366

    I don't know if downgrading Apache is a solution at the moment for openSUSE 13.1, so far I haven't found it a possibility for 13.1.

    Personally, I may resort to building a 12.3 VM to run an earlier version of Apache.

    Good Luck,
    TSU

  9. #9
    Join Date
    Jun 2008
    Location
    South-West France
    Posts
    1,307

    Default Re: Can't find apache module in repository

    I have reopened Bug 866366 for 13.2
    Thanks for helping. JCD
    __________
    server leap 15.0 -- ASUS g75vw KDE leap 15.2 -- ASUS G731GV KDE leap 15.2 -- acer aspire s13 win 10 home -- HP Omen win 10 home - scan EPSON V500 - Brother HL2250DN - Samsung CLP-325W

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •