Results 1 to 7 of 7

Thread: Apparent Dolphin issue with samba folder creation

  1. #1
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Apparent Dolphin issue with samba folder creation

    I have openSUSE 13.1, KDE 4.12.9 installed. I noticed while navigating a remote samba share (that I have R/W access to) that I could no longer create a folder via

    File > Create New > Folder

    It is greyed out. However, I can create a folder if I press F10 (which brings up a dialogue box with 'Create new folder in:...'). I can also do the same using konqueror, so just a minor regression....

    I also note that this is discussed here recently

    https://bugs.kde.org/show_bug.cgi?id=330015

    and I have submitted a bug report

    https://bugs.kde.org/show_bug.cgi?id=297734

    Anyone else experiencing the same?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: Apparent Dolphin issue with samba folder creation

    Sorry, made a mistake with the links. It should have been

    I also note that this is discussed here recently

    https://forum.kde.org/viewtopic.php?f=18&t=118918

    and I have submitted a bug report

    https://bugs.kde.org/show_bug.cgi?id=330015

  3. #3
    Join Date
    Oct 2013
    Location
    Chesapeake, VA
    Posts
    15

    Default Re: Apparent Dolphin issue with samba folder creation

    I'm able to create new folders with Dolphin in my two smb shares.

    Code:
    $ dolphin --version
    Qt: 4.8.5
    KDE Development Platform: 4.11.3
    Dolphin: 4.11.3
    My Samba section of my /etc/fstab:
    Code:
    ## Samba Shares
    //192.168.1.13/Shares  /mnt/Shares  cifs  guest,comment=systemd.automount,uid=1000,iocharset=utf8                                    0 0
    //192.168.1.13/Homes   /mnt/Homes   cifs  credentials=/home/pat/.smbcredentials,comment=systemd.automount,iocharset=utf8,sec=ntlm    0 0
    and finally, my /etc/samba/smb.conf on my server:
    Code:
    #####===== Share Definitions =====#####
    [Homes]
       comment = Home Directories
       browseable = no
       read only = no
       create mask = 0700
       directory mask = 0700
       valid users = %S
    
    [Shares]
        path = /home/share
        browseable = yes
        read only = no
        guest ok = yes
        create mask = 0755
        directory mask = 0755
        force user = nobody
        force group = nogroup
    "Man is the lowest-cost, 150-pound, nonlinear, all-purpose computer system which can be mass-produced by unskilled labor." ~NASA, 1965
    "I drank WHAT!?!?" ~Socrates

  4. #4

    Default Re: Apparent Dolphin issue with samba folder creation

    Quote Originally Posted by deano_ferrari View Post
    I have openSUSE 13.1, KDE 4.12.9 installed. I noticed while navigating a remote samba share (that I have R/W access to) that I could no longer create a folder via

    File > Create New > Folder

    It is greyed out. However, I can create a folder if I press F10 (which brings up a dialogue box with 'Create new folder in:...'). I can also do the same using konqueror, so just a minor regression....

    I also note that this is discussed here recently

    https://bugs.kde.org/show_bug.cgi?id=330015

    and I have submitted a bug report

    https://bugs.kde.org/show_bug.cgi?id=297734

    Anyone else experiencing the same?
    On a share where I have write permissions, this works fine here with KDE 4.12.1.
    If I don't have write permissions, File->Create New is greyed out as intended.

    So I would say, either this has been fixed in 4.12.1 (I skipped 4.12.0 so can't say how that behaved), or there's a problem with kio_smb or dolphin that it doesn't correctly determine the permissions in your case.

    BTW, where did you get KDE 4.12.9 from?

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: Apparent Dolphin issue with samba folder creation

    Quote Originally Posted by wolfi323 View Post
    On a share where I have write permissions, this works fine here with KDE 4.12.1.
    If I don't have write permissions, File->Create New is greyed out as intended.

    So I would say, either this has been fixed in 4.12.1 (I skipped 4.12.0 so can't say how that behaved), or there's a problem with kio_smb or dolphin that it doesn't correctly determine the permissions in your case.

    BTW, where did you get KDE 4.12.9 from?
    Slippery fingers 4.12.0

    I have write permissions and have isolated the issue to Dolphin.

    It's currently being duscussed here as well

    https://bugs.kde.org/show_bug.cgi?id=330001

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: Apparent Dolphin issue with samba folder creation

    For others experiencing this issue with Dolphin (KDE 4.12.0, 4.12.1), a patch has now been released as described here

    https://bugs.kde.org/show_bug.cgi?id=330001
    https://bugs.kde.org/show_bug.cgi?id=330015

    Git commit 4865303004e1eba6e73342960bac614171323588 by Frank Reininghaus.
    Committed on 30/01/2014 at 21:10.
    Pushed by freininghaus into branch 'KDE/4.12'.

    Always enable the "Create New..." menu if the URL is writable

    This commit works around the problem that KDirLister may not provide a "rootItem" for some kioslaves by setting up a KFileItem with the view
    URL and using this to find out if the URL is writable.
    Related: bug 330015
    REVIEW: 115405
    FIXED-IN: 4.12.2

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: Apparent Dolphin issue with samba folder creation

    Now confirmed working again with the update to KDE 4.12.2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •