Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Flash Player Video lags behind audio (ThinkPad A31p)

  1. #1

    Default Flash Player Video lags behind audio (ThinkPad A31p)

    Well, I'm into my new system on an old laptop. I've enabled Flash Player and things are functioning but the video lags behind the audio output pretty seriously. Curious if there is any adjustment available for this condition that I can make and help resolve this issue.

    13.1 KDE box w/ 32-bit

  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default Re: Flash Player Video lags behind audio (ThinkPad A31p)

    Quote Originally Posted by chuckenheimer View Post
    Well, I'm into my new system on an old laptop. I've enabled Flash Player and things are functioning but the video lags behind the audio output pretty seriously. Curious if there is any adjustment available for this condition that I can make and help resolve this issue.

    13.1 KDE box w/ 32-bit
    is it only flash video? what about video played in a media player? Is that fine?

    Have you tried video on youtube with different resolutions? Could be your laptop just isn't powerful enough to handle HD flash content???

    thinkwiki says these laptops came standard with 256mb of ram. You would need to increase that for a start to have any kind of decent experience.
    Fairly old ATI graphics adapter that may not be very well supported in linux (I don't know but is something that might need to be looked into).

  3. #3

    Default Re: Flash Player Video lags behind audio (ThinkPad A31p)

    Quote Originally Posted by farcusnz View Post
    is it only flash video? what about video played in a media player? Is that fine?

    Have you tried video on youtube with different resolutions? Could be your laptop just isn't powerful enough to handle HD flash content???

    thinkwiki says these laptops came standard with 256mb of ram. You would need to increase that for a start to have any kind of decent experience.
    Fairly old ATI graphics adapter that may not be very well supported in linux (I don't know but is something that might need to be looked into).
    Yes, Flash video but others play fine on YouTube. VLC with other media is OK.

    I just tried to play another vid and it slowed my system to a crawl but I was able to stop it, the system was responding slowly. Really weird.

    Went back to it and the buffering was completed and fully loaded when I was able to play it without incident. Arrgh. I reported the slow loading to the website I was on, so maybe I'll hear something. But I tried the same vid on my Win7 box and it played fine. So I'm sure it's a condition that is limited to my new Linux configuration.

    I think with 2GB RAM that I am OK there. I'm of the opinion that it has to do something with the buffering for sure. I am able to play the same video over and over without any difficulties once it has first loaded. I did notice that it was choppy when only 50-75% had loaded but once it reached the full 100% it was as I say fine.

    Thanks for the assistance.

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default Re: Flash Player Video lags behind audio (ThinkPad A31p)

    Quote Originally Posted by chuckenheimer View Post
    Yes, Flash video but others play fine on YouTube. VLC with other media is OK.

    I just tried to play another vid and it slowed my system to a crawl but I was able to stop it, the system was responding slowly. Really weird.

    Went back to it and the buffering was completed and fully loaded when I was able to play it without incident. Arrgh. I reported the slow loading to the website I was on, so maybe I'll hear something. But I tried the same vid on my Win7 box and it played fine. So I'm sure it's a condition that is limited to my new Linux configuration.

    I think with 2GB RAM that I am OK there. I'm of the opinion that it has to do something with the buffering for sure. I am able to play the same video over and over without any difficulties once it has first loaded. I did notice that it was choppy when only 50-75% had loaded but once it reached the full 100% it was as I say fine.

    Thanks for the assistance.
    tbh I think it is probably just a limitation of your system specs. A 13 year old spec computer with ATI agp vid / 64mb vid ram is going to struggle.
    KDE is fairly power hungry. You might have more luck with a lighter DE like XFCE or LXDE

    Youtube usually auto detects the resolution your computer can handle and gives you that feed - so if you are struggling with flash content on other sites then I think you just don't have enough grunt. Try switching to a 720p video in youtube and see if it is still OK.

    You could also try disabling hardware acceleration in flash to see if that helps.

    I have an old thinkpad (slightly oder than your but a little higher spec) that struggles with openSUSE. (although last time I checked was with openSUSE 11.3) :-)

  5. #5

    Default Re: Flash Player Video lags behind audio (ThinkPad A31p)

    Quote Originally Posted by farcusnz View Post
    tbh I think it is probably just a limitation of your system specs. A 13 year old spec computer with ATI agp vid / 64mb vid ram is going to struggle.
    KDE is fairly power hungry. You might have more luck with a lighter DE like XFCE or LXDE

    Youtube usually auto detects the resolution your computer can handle and gives you that feed - so if you are struggling with flash content on other sites then I think you just don't have enough grunt. Try switching to a 720p video in youtube and see if it is still OK.

    You could also try disabling hardware acceleration in flash to see if that helps.

    I have an old thinkpad (slightly oder than your but a little higher spec) that struggles with openSUSE. (although last time I checked was with openSUSE 11.3) :-)
    Yes, seems that hardware acceleration being ON is the present culprit. I'm going to try the Vimeo website just now to see but I think I've found the more serious problem and its resolution.

    BTW, my A31p is the 2653-R9U which is about as high spec as one could get back in 2003 when I purchased mine that summer. Right now I'm looking for some replacement speakers because my left one just went on the blink after all these years. I'm a high maintenance guy on less used equipment which makes for longevity and I just can't pinch a buck hard enough to lose this my first laptop. It's serving me very well at the time and I think that's what it was designed to do. And, I just love the keyboard on it. One of the best and the LCD is the higher grade piece, too.

  6. #6
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default Re: Flash Player Video lags behind audio (ThinkPad A31p)

    Quote Originally Posted by chuckenheimer View Post
    Yes, seems that hardware acceleration being ON is the present culprit. I'm going to try the Vimeo website just now to see but I think I've found the more serious problem and its resolution.
    I wouldn't worry too much about performance on Vimeo
    Many modern computers struggle with their implementation of the flash media player.

    You might also try Chromium and the pepper-flash plugin from packman and see if that behaves any better (much newer version of flash)

    aside from that - video driver might also be worth checking out to make sure you are using the correct ati driver - if even there is one available for your card.

  7. #7

    Default Re: Flash Player Video lags behind audio (ThinkPad A31p)

    Quote Originally Posted by farcusnz View Post
    I wouldn't worry too much about performance on Vimeo
    Many modern computers struggle with their implementation of the flash media player.

    You might also try Chromium and the pepper-flash plugin from packman and see if that behaves any better (much newer version of flash)

    aside from that - video driver might also be worth checking out to make sure you are using the correct ati driver - if even there is one available for your card.
    Vimeo is behaving better with the hardware acceleration turned OFF now. That's what their tech support suggested, too, as a resolution. Guess they maybe get that a lot.

    I'll put Chromium on the box soon and get back with the results.

    Video Driver: Kinfo suggests it's a Tungsten Graphic, Inc. (??) and gets the hardware correct. Not sure how to go about check for an alternate driver though.

    So, I'm happier with the video performance but now I'm looking at having to replace my speakers in this laptop. For some reason they seem "blown" when I didn't notice that on the Windows XP installation. Weird again. I've got some on order and am looking now for an instructional video to help with the disassembly. That's another task that I don't look forward to being that I'm a little older and less full of vim and vigor as I used to be. We'll see how that goes in another thread. Thanks for your kind assistance!

  8. #8
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default Re: Flash Player Video lags behind audio (ThinkPad A31p)

    Quote Originally Posted by chuckenheimer View Post
    Vimeo is behaving better with the hardware acceleration turned OFF now. That's what their tech support suggested, too, as a resolution. Guess they maybe get that a lot.

    I'll put Chromium on the box soon and get back with the results.

    Video Driver: Kinfo suggests it's a Tungsten Graphic, Inc. (??) and gets the hardware correct. Not sure how to go about check for an alternate driver though.

    So, I'm happier with the video performance but now I'm looking at having to replace my speakers in this laptop. For some reason they seem "blown" when I didn't notice that on the Windows XP installation. Weird again. I've got some on order and am looking now for an instructional video to help with the disassembly. That's another task that I don't look forward to being that I'm a little older and less full of vim and vigor as I used to be. We'll see how that goes in another thread. Thanks for your kind assistance!
    are you sure the speakers are broken?
    Being an old computer it may just have problems with Pulse audio.
    Try switching Pulse Audio off.

    Yast > Sound > Other > Pulse Audio Config

    and uncheck enable pulse audio support

  9. #9

    Default Re: Flash Player Video lags behind audio (ThinkPad A31p)

    Quote Originally Posted by farcusnz View Post
    are you sure the speakers are broken?
    Being an old computer it may just have problems with Pulse audio.
    Try switching Pulse Audio off.

    Yast > Sound > Other > Pulse Audio Config

    and uncheck enable pulse audio support
    OK, got that unchecked but still see the PCM Master volume control along with the primary Master and both affect my sound. I'm setting the primary at 100% and have to lower the PCM to 80% to prevent the speakers from being overdriven to distortion. Why is the PCM Master still there and affecting the sound if it is disabled? I've rebooted, too.

  10. #10

    Default Re: Flash Player Video lags behind audio (ThinkPad A31p)

    I would not expect much from such an old setup, in any case PCM is sort of like the master audio in certain setups and it really depends on your audio card.
    As for flash, yeah its a pain in the butt as flash in linux is not supported anymore by adobe (stupid morons) so most flash issues (for now) will be solved by installing google chrome/chromium.
    Luckily flash will die soon and be replaced by html5.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •