Results 1 to 4 of 4

Thread: Reboot fails after upgrade to 13.1

  1. #1

    Default Reboot fails after upgrade to 13.1

    I commented on this before, but it faded away. The problem persists and I am considering
    filing a bug. I rather get your advise first, now that I sort of isolated the problem.

    The reboot command
    Code:
    /sbin/shutdown -r now
    fails to complete.
    After quickly getting to the end of the process, plymouth shows the final screen and one cannot toggle to console mode with <esc>. The image is frozen. A standard shutdown (substituting -r with -h ) works correctly (final screen -> poweroff within the second).
    Of course, this did not happen before upgrading from 12.2 to 13.1 (done with zypper dup).
    Here are the journal files:
    shutdown: http://paste.opensuse.org/96162033
    reboot http://paste.opensuse.org/38095711
    I interrupted the reboot process after having waited 17 minutes.
    Comparing the files near the end one might like to suspect the mei module or watchdog.
    I'd rather rule out watchdog, since I waited 17 minutes before interrupting the reboot.
    As for mei, I blacklisted the mei module, and performed the reboot again. The journal is:
    reboot-mei http://paste.opensuse.org/60068300
    The mei line dissappeared, as expected, but the reboot hanged and never finished, as before. I interrupted it after 17 minutes.


    My questions are:
    (a) Can anybody find the culprit from the journal files?
    (b) If not, should I file this as a kernel bug or a systemd bug?
    Thanks,

  2. #2

    Default Re: Reboot fails after upgrade to 13.1

    Maybe this will help?
    http://freedesktop.org/wiki/Software...ging/#index2h1

    Do you have acpid installed?
    If yes, uninstall it (I think it was still installed by default on 12.2). Most of its functionality has been taken over by systemd and there might be conflicts if it is still installed.

    You could also try to disable plymouth to rule that out as cause (but I guess it's not at fault anyway if a standard shutdown works).
    Just add "plymouth.enable=0" to the boot options.

    Could you maybe try a 13.1 LiveCD and see if it works there?

  3. #3

    Default Re: Reboot fails after upgrade to 13.1

    Quote Originally Posted by wolfi323 View Post
    Maybe this will help?
    http://freedesktop.org/wiki/Software...ging/#index2h1

    Do you have acpid installed?
    If yes, uninstall it (I think it was still installed by default on 12.2). Most of its functionality has been taken over by systemd and there might be conflicts if it is still installed.

    You could also try to disable plymouth to rule that out as cause (but I guess it's not at fault anyway if a standard shutdown works).
    Just add "plymouth.enable=0" to the boot options.

    Could you maybe try a 13.1 LiveCD and see if it works there?
    Hi. I forgot to tell that acpid was not the issue.
    I uninstalled acpid and disabled both plymouth and mei, but the problem persists:
    Reboot hangs, while shutdown performs properly, in a few seconds. Here is
    the journal for the reboot session that I aborted after about half an hour.
    http://paste.opensuse.org/72219219

    By the way: I can't try the liveCD.
    Finally: I disabled acpid men you say that
    Most of its functionality has been taken over by systemd
    Most? This means *not all* ? What functionality is still depending on acpid? How are fans and battery levels managed now?
    Thanks,

  4. #4

    Default Re: Reboot fails after upgrade to 13.1

    Quote Originally Posted by mnatiello View Post
    Most? This means *not all* ? What functionality is still depending on acpid?
    I don't know.
    I wrote "most" because I am not sure whether every single feature of acpid has a replacement.
    I'm not even sure what features acpid actually has.

    How are fans and battery levels managed now?
    Shouldn't this be done by the kernel?

    AFAIK acpid's main purpose was to call scripts/programs on certain ACPI events (triggered by the kernel).
    And if both acpid and systemd do that there can be problems of course, depending on the configuration.

    And I do remember people complaining about long shutdown times (caused by acpid) after upgrading to 12.3, which you skipped.
    That's why I suggested to remove it. It's no longer installed by default anyway.

    Other than that, I have no idea, sorry.
    Maybe try a newer kernel?

    Or maybe adding something like acpi_osi="Linux" to the boot options would help?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •