Results 1 to 7 of 7

Thread: Samba not running now but it was...

  1. #1

    Default Samba not running now but it was...

    I had been using samba for a while on 13.1. After putting on maintenance it no longer is. Looked at YAST's System Services (runlevel) and Services Manager and no mention of nmb or smb being defined. So went into Software Manager and yes SAMBA is installed. So after maintenance how can I see if they are running? Or what is the procedure these days to start, stop, or restart them?

  2. #2
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Samba not running now but it was...

    On 1/13/2014 8:36 PM, svetter88 wrote:
    >
    > I had been using samba for a while on 13.1. After putting on
    > maintenance it no longer is. Looked at YAST's System Services
    > (runlevel) and Services Manager and no mention of nmb or smb being
    > defined. So went into Software Manager and yes SAMBA is installed. So
    > after maintenance how can I see if they are running? Or what is the
    > procedure these days to start, stop, or restart them?
    >
    >

    svetter88;

    To see the status of smbd and nmbd use:

    Code:
    systemctl status smb
    systemctl status nmb
    You can start the services with:
    Code:
    systemctl start smb
    systemctl start nmb
    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  3. #3
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Samba not running now but it was...

    On 1/13/2014 8:55 PM, PV wrote:
    > On 1/13/2014 8:36 PM, svetter88 wrote:
    >>
    >> I had been using samba for a while on 13.1. After putting on
    >> maintenance it no longer is. Looked at YAST's System Services
    >> (runlevel) and Services Manager and no mention of nmb or smb being
    >> defined. So went into Software Manager and yes SAMBA is installed. So
    >> after maintenance how can I see if they are running? Or what is the
    >> procedure these days to start, stop, or restart them?
    >>
    >>

    > svetter88;
    >
    > To see the status of smbd and nmbd use:
    >
    >
    Code:
    > systemctl status smb
    > systemctl status nmb
    >
    >
    > You can start the services with:
    >
    Code:
    > systemctl start smb
    > systemctl start nmb
    >

    OOPS:

    Should be "smb.service" and "nmb.service". Although the shorter form works. At least on openSUSE 12.3 the short form works.

    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  4. #4

    Default Re: Samba not running now but it was...

    Odd that they were not started automatically. But anyway I got nmb started.

    As for smb I get the following when trying to start it:
    smb.service - Samba SMB Daemon
    Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled)
    Active: active (running) since Wed 2014-01-15 00:53:19 EST; 24s ago
    Process: 17617 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=0/SUCCESS)
    Main PID: 17618 (smbd)
    CGroup: /system.slice/smb.service
    ├─17618 /usr/sbin/smbd
    └─17622 /usr/sbin/smbd

    Jan 15 00:53:19 scott1 systemd[1]: Starting Samba SMB Daemon...
    Jan 15 00:53:19 scott1 smbd[17617]: [2014/01/15 00:53:19.884290, 0] ../source3/param/loadparm.c:3155(lp_do_parameter)
    Jan 15 00:53:19 scott1 smbd[17617]: Ignoring unknown parameter "share modes"
    Jan 15 00:53:19 scott1 smbd[17617]: [2014/01/15 00:53:19.884836, 0] ../source3/smbd/server.c:1278(main)
    Jan 15 00:53:19 scott1 smbd[17617]: standard input is not a socket, assuming -D option
    Jan 15 00:53:19 scott1 systemd[1]: Started Samba SMB Daemon.
    Jan 15 00:53:20 scott1 smbd[17618]: [2014/01/15 00:53:20.000452, 0] ../source3/lib/util_sock.c:446(open_socket_in)
    Jan 15 00:53:20 scott1 smbd[17618]: open_socket_in(): setsockopt: SO_REUSEPORT = true on port 445 failed with error = Protocol not available
    Hint: Some lines were ellipsized, use -l to show in full.


    What gives?

  5. #5

    Default Re: Samba not running now but it was...

    Quote Originally Posted by svetter88 View Post
    As for smb I get the following when trying to start it:
    smb.service - Samba SMB Daemon
    Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled)
    Active: active (running) since Wed 2014-01-15 00:53:19 EST; 24s ago
    Process: 17617 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=0/SUCCESS)
    Main PID: 17618 (smbd)
    CGroup: /system.slice/smb.service
    ├─17618 /usr/sbin/smbd
    └─17622 /usr/sbin/smbd
    Well, it started successfully, didn't it?

    The rest are just warnings that point to a wrong/old configuration.
    (the "assuming -D option" warning should get fixed with the next Samba update IIANM)

  6. #6

    Default Re: Samba not running now but it was...

    After having to restart I went to start the nmb and the results I get are:
    nmb.service - Samba NMB Daemon
    Loaded: loaded (/usr/lib/systemd/system/nmb.service; enabled)
    Active: failed (Result: resources) since Wed 2014-01-15 11:36:16 EST; 22s ago
    Process: 5056 ExecStart=/usr/sbin/nmbd $NMBDOPTIONS (code=exited, status=0/SUCCESS)

    Jan 15 11:36:16 scott1 systemd[1]: Starting Samba NMB Daemon...
    Jan 15 11:36:16 scott1 systemd[1]: PID file /run/samba/nmbd.pid not readable (yet?) after start.
    Jan 15 11:36:16 scott1 systemd[1]: nmb.service never wrote its PID file. Failing.
    Jan 15 11:36:16 scott1 systemd[1]: Failed to start Samba NMB Daemon.
    Jan 15 11:36:16 scott1 systemd[1]: Unit nmb.service entered failed state.


    Get the same thing for the smb. So how do I get the pid from quit erasing itself after a restart or how can I create the pid?

    Thanks for your help!

  7. #7

    Default Re: Samba not running now but it was...

    Quote Originally Posted by svetter88 View Post
    Get the same thing for the smb. So how do I get the pid from quit erasing itself after a restart or how can I create the pid?
    Well, that's https://bugzilla.novell.com/show_bug.cgi?id=856651 (there already have been a few threads about that).

    To fix it either create the directory /run/samba/ manually (has to be done on each boot, see "man tmpfiles.d" for how to do that), or run "sudo /usr/sbin/logprof" and allow smb and nmb to create it.
    Or disable Apparmor (in YaST->Security and Users->Apparmor Configuration f.e.).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •