Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Firefox 26 and Chrome 31 starting problem

  1. #1

    Default Firefox 26 and Chrome 31 starting problem

    Since this morning (after applying some updates suggested by apper) I am not able to launch Firefox (26.0-4.2) and google-chrome-stable (31.0.1650.63.1).
    Starting Firefox gives:
    Code:
    :~>firefox 
    
    (process:1962): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
    
    
    (process:1970): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
    Segmentation fault
    dencho@desp:~> 
    (crashreporter:1976): Pango-WARNING **: /usr/lib/pango/1.8.0/modules/pango-basic-fc.so: wrong ELF class: ELFCLASS32
    Chrome simply anounce:
    Code:
     ~> google-chromeSegmentation fault
    The distribution is Opensuse Tumbleweed 64-bit; list of repositories is:
    Code:
     ~> zypper lr#  | Alias                            | Name                             | Enabled | Refresh
    ---+----------------------------------+----------------------------------+---------+--------
     1 | Education/OpenSuse_Tumbleweed    | Education/OpenSuse Tumbleweed    | Yes     | Yes    
     2 | KDE_Tumbleweed_Extra             | KDE Tumbleweed extra             | Yes     | Yes    
     3 | LibreOffice-Tumbleweed           | LibreOffice-Tumbleweed           | Yes     | Yes    
     4 | MinGW                            | MinGW-Tumbleweed                 | Yes     | Yes    
     5 | Packman-Thumbleweed              | Packman-Thumbleweed              | Yes     | Yes    
     6 | Tumbleweed-standard              | Tumbleweed-standard              | Yes     | Yes    
     7 | google-chrome                    | google-chrome                    | Yes     | Yes    
     8 | multimedia:libs                  | multimedia:libs                  | Yes     | Yes    
     9 | openSUSE_Current_OSS             | openSUSE Current OSS             | Yes     | Yes    
    10 | openSUSE_Current_non-OSS         | openSUSE Current non-OSS         | Yes     | Yes    
    11 | openSUSE_Current_updates         | openSUSE Current-updates         | Yes     | Yes    
    12 | openSuse_non-oss_current_updates | openSuse non-oss current-updates | Yes     | Yes    ]
    Here is a list of updates installed today:
    Code:
    2014-01-13 08:54:31|install|kernel-debug-devel|3.12.7-6.1.g2424219|x86_64|root@desp|Tumbleweed-standard|305de4c39a90bfb1f279d09e1cbf3f4b37d69dc550a7cd2deea67d997de8e299|2014-01-13 08:55:29|install|kernel-source|3.12.7-6.1.g2424219|noarch|root@desp|Tumbleweed-standard|42a29e5c7f080b2b35194eb37565dc45e26edefeaa082bb2c4b727890bf37da9|
    2014-01-13 08:55:36|install|gitk|1.8.5.2-6.7|x86_64|root@desp|Tumbleweed-standard|a47888b6adf16bd97477b173286006dca61ae7a7cbd3269c0b8e3eebc1886214|
    2014-01-13 08:55:37|install|git-web|1.8.5.2-6.7|x86_64|root@desp|Tumbleweed-standard|f2a62a5c3f96ca4e9931df3440561139cb3483f7273d8d351bb44f3608f8daf3|
    2014-01-13 08:55:37|install|git-svn|1.8.5.2-6.7|x86_64|root@desp|Tumbleweed-standard|246f599b437dab2c2ac9cd06dd89493bb28bce5f9b9a9f4c10faf7227c2ff47d|
    2014-01-13 08:55:38|install|git-gui|1.8.5.2-6.7|x86_64|root@desp|Tumbleweed-standard|934fe9b04dcc4f7f7d68841530eb969bdbf3d37e1eca96e50288498c8421328c|
    2014-01-13 08:55:38|install|git-email|1.8.5.2-6.7|x86_64|root@desp|Tumbleweed-standard|d5d436b4869e20378b7de1fd989f6fe452066bf44e5ea647d7b00e9cceba5685|
    2014-01-13 08:55:39|install|git-cvs|1.8.5.2-6.7|x86_64|root@desp|Tumbleweed-standard|bdb077c44bee0484d8a0bde7352fe448368feb56f0587e07ed7fbcc1f9e0281a|
    2014-01-13 08:56:00|install|git|1.8.5.2-6.7|x86_64|root@desp|Tumbleweed-standard|5ebaaae4b1c57930a646592e96ea57e964a6e7802927ab8cad859b8a916cf64f|
    2014-01-13 08:56:04|install|kernel-syms|3.12.7-6.1.g2424219|x86_64|root@desp|Tumbleweed-standard|7e655b65db9059c64778237ecc8991b10b8509eadcb1be3a6103465b3ceb1582|
    2014-01-13 08:56:09|install|libgstapp-0_10-0-32bit|0.10.36-74.29|x86_64|root@desp|multimedia:libs|94cf783991a69c1d28a5e2aa441923c9f744f014dba0b5b7224e1e9705e43c7d|
    2014-01-13 08:56:10|install|libgstinterfaces-0_10-0-32bit|0.10.36-74.29|x86_64|root@desp|multimedia:libs|32d7192c2c81986d3713cbfc81f37bce7e8a46a2a4c61f6ec19677b284f32711|
    2014-01-13 08:56:16|install|alsa-tools|1.0.27-65.21|x86_64|root@desp|multimedia:libs|0b68c6f3520431fc9e26fa7a53f8d4a8384b9c3cee60049f0ee2b5e699edc93e|
    2014-01-13 08:56:16|install|alsa-tools-gui|1.0.27-65.21|x86_64|root@desp|multimedia:libs|a49f93ccf32b863b8d9462e21a2a4866aa8ec9f9de3e0739d8824dedba76c5bd|
    2014-01-13 08:56:17|install|libgpod4|0.8.3-50.6|x86_64|root@desp|multimedia:libs|5f556c5a9083d3d60afc10efd6e0741b57ff2651349008a332c57ecaa12f9f4b|
    2014-01-13 08:56:18|install|libgstapp-0_10-0|0.10.36-74.29|x86_64|root@desp|multimedia:libs|0de8eb1a72583b98b4333aa40eb4f1ad1ce4ae2d1edbc5390e90fb82b1ace0e2|
    2014-01-13 08:56:19|install|libgstpbutils-1_0-0|1.2.2-35.3|x86_64|root@desp|multimedia:libs|a49573221c644e6e383d18d435cd9db0c664e99d1c6ac4cdf3ced84022724854|
    2014-01-13 08:56:19|install|libmusicbrainz3-6|3.0.3-40.16|x86_64|root@desp|multimedia:libs|51c0550718f541089949309d1961234c71b2208ce090240807e4a296d75cac21|
    2014-01-13 08:56:20|install|libsamplerate0|0.1.8-36.12|x86_64|root@desp|multimedia:libs|a263d551204cd025ecc50e9e6a81f2c62e926e62ed046558e9a2db8506a5895b|
    2014-01-13 08:56:23|install|pstoedit|3.61-28.19|x86_64|root@desp|multimedia:libs|8c3a3dc9bece0b87a7a6098b4afea2ed85e6852f26a67401232562dfbafaca01|
    2014-01-13 08:56:23|install|libgpod-tools|0.8.3-50.6|x86_64|root@desp|multimedia:libs|d1763ac05c719158b7d79c4ed9dc9b2742527761eac12607eb718c5a64b42f54|
    2014-01-13 08:56:24|install|libgstinterfaces-0_10-0|0.10.36-74.29|x86_64|root@desp|multimedia:libs|be2fcb298ad63bedc48812808d37c8381221ed547ba604a62d713112d0b4ccde|
    2014-01-13 08:56:25|install|libgstvideo-1_0-0|1.2.2-35.3|x86_64|root@desp|multimedia:libs|64f70985c9ebc8d6ecfbb8b81aa5123a329100b936879c391fe25616e911805b|
    2014-01-13 08:56:27|install|gstreamer-0_10-plugins-base|0.10.36-74.29|x86_64|root@desp|multimedia:libs|faf8eba9b1069b691bffa1ebc1729f2edff2c8ca4278760b6be70e7fd2b9ab36|
    2014-01-13 08:56:28|install|libgstaudio-1_0-0|1.2.2-35.3|x86_64|root@desp|multimedia:libs|153a8137bb929d322054b53467118aed82e2c3cb3b9aa0cb45e6c3772fae8e63|
    2014-01-13 08:56:29|install|gstreamer-0_10-plugin-gnomevfs|0.10.36-74.29|x86_64|root@desp|multimedia:libs|3b3690bb116cdb4d9fd73ae8174c03bb80c627d01297c8e009ee3050d544373e|
    2014-01-13 08:56:31|install|gstreamer-plugins-base|1.2.2-35.3|x86_64|root@desp|multimedia:libs|91fc77377ed793b3b60203c15b203c7c5a314c7332584bae7c20bb3a6b6afab5|
    2014-01-13 08:56:32|install|libgsttag-1_0-0|1.2.2-35.3|x86_64|root@desp|multimedia:libs|80270ccbd71354f7113c3a43ccca55824ca9be6dbb0a06f80a711570d66edffb|
    2014-01-13 08:56:34|install|libgstapp-1_0-0|1.2.2-35.3|x86_64|root@desp|multimedia:libs|38d1df89f2d8364a6c585d78cb2807240a68e54aaa2c0cb089f9c4828b5264b8|
    2014-01-13 08:56:36|install|libgstriff-1_0-0|1.2.2-35.3|x86_64|root@desp|multimedia:libs|dc356e541fe28b1d950fbcdb8d7fe71d32a9a36902af148dba9fa5b349f5c58f|
    2014-01-13 08:56:37|install|gstreamer-plugins-base-lang|1.2.2-35.3|noarch|root@desp|multimedia:libs|1fb82865709177d8dc2ee48d47051b4c9d0a752268c1ca8838c90f473078a37a|
    2014-01-13 08:56:44|install|libgphoto2-6|2.5.2.1-2.10.1|x86_64||openSUSE_Current_updates|bc6cd3d3dc34930a616cb7bab4ff1ee7c73682bd4ce3114b300326ea2fb909f5|
    2014-01-13 08:56:45|install|libgphoto2-6-32bit|2.5.2.1-2.10.1|x86_64||openSUSE_Current_updates|852965943a33b8512e8d8b9a416443c454b5e4754e7c529393c1496c1e85e568|
    2014-01-13 08:56:46|install|libgphoto2-devel|2.5.2.1-2.10.1|x86_64||openSUSE_Current_updates|d58c2396c4fe481f94ea56eeea3c5f973aeb3a595f5a259082188d41900f9130|
    2014-01-13 08:56:51|install|ktorrent|4.3.1-6.20|x86_64|root@desp|KDE_Tumbleweed_Extra|db059d467e0db7f27c61f0d7a87aa9a509b7af0b2728c8fda92c8d63297808b1|
    2014-01-13 08:56:53|install|libopencv2_4|2.4.7-18.13|x86_64|root@desp|KDE_Tumbleweed_Extra|2a490ca255397d8a5f9df5e88227ad42401edda56c57ea341cc9866faedaa368|
    2014-01-13 08:56:54|install|ktorrent-lang|4.3.1-6.20|noarch|root@desp|KDE_Tumbleweed_Extra|1e1b158d99594afca8c18a185fc3e12c1d2e07574ef2463ad61df922d427fb8b|
    2014-01-13 08:57:04|install|amarok|2.8.0-19.24|x86_64|root@desp|Packman-Thumbleweed|ac1aab8c1e10611d5558bc0527bf4fe3ef7aaaf091c22a28958bcb81b6841b8e|
    2014-01-13 08:57:05|install|libvlccore7|2.1.2-187.1|x86_64|root@desp|Packman-Thumbleweed|963462347035211d1f77341e93fa05513756646764d6a73e8e804e5b087cf089|
    2014-01-13 08:57:07|install|gstreamer-0_10-plugins-ffmpeg|0.10.13-2000.15|x86_64|root@desp|Packman-Thumbleweed|c5c62fc41bdaeb976fad2be7a9965d49d840bb146b5af86d8cd9563eaa1d7f41|
    2014-01-13 08:57:10|install|gstreamer-0_10-plugins-good|0.10.31-16.10|x86_64|root@desp|Packman-Thumbleweed|9ec4a6b52d07357ac4d2ee5a49f934de90ae4d8a923ec10971291e19e5094840|
    2014-01-13 08:57:11|install|handbrake-gtk|0.9.9-3.14|x86_64|root@desp|Packman-Thumbleweed|7e7fb398025ef14d7f62d857d5db7d350b931edd669ae7be4974fb89097c261f|
    2014-01-13 08:57:13|install|gstreamer-plugins-libav|1.2.1-2.4|x86_64|root@desp|Packman-Thumbleweed|6f8781db18a6078e9aa93ae0e660268e27e88a1970d733c2bcf9b8c9518f9303|
    2014-01-13 08:57:19|install|amarok-lang|2.8.0-19.24|noarch|root@desp|Packman-Thumbleweed|c5c00470c97856389947a67463b196d38c6cca45c14b8b4a3573a7579b88e1a2|
    2014-01-13 08:57:20|install|libvlc5|2.1.2-187.1|x86_64|root@desp|Packman-Thumbleweed|3554ad3a3b5042273b0870ad5d447da39a2b5e8a2d5163ec84d6a0eb03f8a375|
    2014-01-13 08:57:20|install|gstreamer-0_10-plugins-good-lang|0.10.31-16.10|noarch|root@desp|Packman-Thumbleweed|0e572b119477b58c119e8037e2a381bd77e909a12f3facabf3f271e20fd36db0|
    2014-01-13 08:57:20|install|gstreamer-0_10-plugin-esd|0.10.31-16.10|x86_64|root@desp|Packman-Thumbleweed|a213c0cc29a9613ee5bc1cf7878302e5c4bce35d5092bbb291f44905aac1cbed|
    2014-01-13 08:57:21|install|gstreamer-0_10-plugins-good-extra|0.10.31-16.10|x86_64|root@desp|Packman-Thumbleweed|efc6559665c2ac5d0bee2d16c42cc228f564f8e52786b47663f8803e88579cdc|
    2014-01-13 08:57:34|install|vlc-noX|2.1.2-187.1|x86_64|root@desp|Packman-Thumbleweed|4bd7579cb3574e3812c97777ad6ad0822fbcd4776d54fff15640ff8b321cf286|
    2014-01-13 08:57:34|install|vlc-gnome|2.1.2-187.1|x86_64|root@desp|Packman-Thumbleweed|5abfb79cf68fa4227bd2e17e3513d11d4c245a17a850cb77a34c8c1bc2cef577|
    2014-01-13 08:57:34|install|vlc-codecs|2.1.2-187.1|x86_64|root@desp|Packman-Thumbleweed|4bdb5baea21c9ccf3ff55c926b6b8dd92c8fcb35596d3468272b6d0a8ee66329|
    2014-01-13 08:57:35|install|vlc-qt|2.1.2-187.1|x86_64|root@desp|Packman-Thumbleweed|528119ec26f9572a8191aa50fa638293cef59822029689e6b5266d94f79a02f2|
    2014-01-13 08:57:36|install|vlc|2.1.2-187.1|x86_64|root@desp|Packman-Thumbleweed|7e1921764fa27a22c8ca07504d388dee9ba3dbdcaaa906b7cac9063c00fbe682|
    I would appreciate any idea how to fix the problem with browsers.

  2. #2

    Default Re: Firefox 26 and Chrome 31 starting problem

    Quote Originally Posted by densp View Post
    Starting Firefox gives:
    Code:
    :~>firefox 
    ...
    (crashreporter:1976): Pango-WARNING **: /usr/lib/pango/1.8.0/modules/pango-basic-fc.so: wrong ELF class: ELFCLASS32
    Do you have libpango-1_0 installed and is it the 64bit version?
    Code:
    rpm -qi libpango-1_0
    As a sidenote, you shouldn't use Apper to update your Tumbleweed system as that doesn't do "vendor change", i.e. it won't switch your system packages to the Tumbleweed versions. The only supported method is to call "zypper dup".
    If you do want to use Apper, you should at least enable "solver.allowVendorChange" in /etc/zypp/zypp.conf, this should make Apper behave more like "zypper dup".

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,156

    Default Re: Firefox 26 and Chrome 31 starting problem

    And it is off course much better to ask in the Tumbleweed forum if you use Tumbleweed. I hve no doubt Tumbleweed gurus will lure there and only part of them here.
    Henk van Velden

  4. #4
    baskitcaise NNTP User

    Default Re: Firefox 26 and Chrome 31 starting problem

    densp wrote:

    >
    > Since this morning (after applying some updates suggested by apper) I am
    > not able to launch Firefox (26.0-4.2) and google-chrome-stable
    > (31.0.1650.63.1).
    > Starting Firefox gives:
    >
    > Code:
    > --------------------
    > :~>firefox
    >
    > (process:1962): GLib-CRITICAL **: g_slice_set_config: assertion
    > 'sys_page_size == 0' failed
    >
    >
    > (process:1970): GLib-CRITICAL **: g_slice_set_config: assertion
    > 'sys_page_size == 0' failed Segmentation fault
    > dencho@desp:~>
    > (crashreporter:1976): Pango-WARNING **:
    > /usr/lib/pango/1.8.0/modules/pango-basic-fc.so: wrong ELF class:
    > ELFCLASS32


    > I would appreciate any idea how to fix the problem with browsers.
    >
    >


    Not sure if you got this fixed yet?

    But I had a very very similar problem this morning, after a lot of hair
    pulling and going through the error/crash report from firefox it appears to
    have stemmed from me using the gtk version of qtcurve for qtk apps ( system
    settings>application appearance>qtcurve )

    This also affected konqueror and any other browser in KDE, yet konqueror
    worked ok in xfce but firefox, reconq still crashed and burned.

    Not sure yet if there is a fix or not as I have only just got in and got
    things working.

    HTH

    --
    Mark (AKA baskitcaise)
    Nullus in verba
    Caveat emptor
    Nil illigitimi carborundum

  5. #5
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,266

    Default Re: Firefox 26 and Chrome 31 starting problem

    Quote Originally Posted by baskitcaise View Post
    ... after a lot of hair
    pulling and going through the error/crash report from firefox it appears to
    have stemmed from me using the gtk version of qtcurve for qtk apps ...
    Greatly appreciated! ... I've not very much hair left to pull out. Same problem as the OP, started after this mornings updates.

    Also affected Thunderbird, Filezilla, and Gimp.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191016) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  6. #6

    Default Re: Firefox 26 and Chrome 31 starting problem

    Thanks Baskitcaise. It was indeed GTK2 theme, that causes the problem preventing Firefox and Chrome from starting. Changed the GTK2 theme to oxygen-gtk, and Firefox and Chrome work again . Konqueror on KDE worked for me with qtcurve as a GTK2 theme, but I didn't test it for possible complains with qtcurve.

  7. #7

    Default AW: Re: Firefox 26 and Chrome 31 starting problem

    Quote Originally Posted by densp View Post
    Konqueror on KDE worked for me with qtcurve as a GTK2 theme, but I didn't test it for possible complains with qtcurve.
    Of course. Konqueror is a KDE application and does not use any GTK2 theme.
    It is possible to set your KDE style to "Gtk+ Style", but I think it uses the GTK3 theme then (I'm not sure though, it could be the GTK2 theme as well).

  8. #8

    Default Re: Firefox 26 and Chrome 31 starting problem

    On Tue, 14 Jan 2014 07:16:02 GMT densp wrote:

    > *Thanks Baskitcaise*. It was indeed GTK2 theme, that causes the
    > problem preventing Firefox and Chrome from starting. Changed the GTK2
    > theme to oxygen-gtk, and Firefox and Chrome work again . Konqueror
    > on KDE worked for me with qtcurve as a GTK2 theme, but I didn't test
    > it for possible complains with qtcurve.


    The problem is qtcurve-1.8.17-fix_run_command.patch which should "Fix
    bug starting up GTK2+ applications" but still again easytag don't start
    with this version and the problem with firefox is not fine.

    Here i have more problems after this update and so i have to compile
    qtcurve without this patch plus compile plasmoid-quickaccess and
    plasmoid-smooth-tasks2 to have the same as before. Before doing this i
    can't log into the KDE Desktop.


  9. #9
    baskitcaise NNTP User

    Default Re: Firefox 26 and Chrome 31 starting problem

    wolfi323 wrote:

    >
    > densp;2615910 Wrote:
    >> Konqueror on KDE worked for me with qtcurve as a GTK2 theme, but I
    >> didn't test it for possible complains with qtcurve.

    > Of course. Konqueror is a KDE application and does not use any GTK2
    > theme.
    > It is possible to set your KDE style to "Gtk+ Style", but I think it
    > uses the GTK3 theme then (I'm not sure though, it could be the GTK2
    > theme as well).
    >
    >


    Yep, it puzzled me a bit as to why konqeror would crash, it would open a
    page but if it tried to open another in a tab or from a link it just died
    (???)

    I did not attempt to look into that though as my changing of the gtk theme
    seemed to fix all, I was in a bit of a rush at the time.

    All seems fine now using a different theme, will await maybe another fix.

    Anyway glad I could help in some way :-)

    --
    Mark
    Nullus in verba
    Caveat emptor
    Nil illigitimi carborundum

  10. #10
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,266

    Default Re: Firefox 26 and Chrome 31 starting problem

    Update of QTcurve packages today (2014/Jan/15) has now fixed this, at least for me.

    Version 1.8.17 Build 17.1 - Implement a better runCommand fixing firefox issues.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191016) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •