Results 1 to 7 of 7

Thread: Not bootable LUKS encrypted system after upgrade to 13.1

  1. #1

    Default Not bootable LUKS encrypted system after upgrade to 13.1

    I have fully encrypted root filesystem (whole /) with LUKS. Recently i upgraded my PC to 13.1 (current kernel version is 3.11.6) and it isn't bootable anymore. During boot, boot logo disappears as it should, and LUKS password prompt appears. But i can't enter password because it is blocked by message
    Code:
    Waiting for /dev/disk/by-id/ata-ST31000524AS_9VPCQQY2-part2 to appear.......
    After a few minutes timeout system is unable to find HDD and enters rescue mode.

    After entering in the rescue mode i checked /dev/disk dir but it isn't exists...

    BTW old intird for kernel 3.7.10 from Opensuse 12.3 works ok, detects /dev/disk/by-id/ata-ST31000524AS_9VPCQQY2-part2 ok, even after recreating of initrd with mkinitrd script.

  2. #2
    Join Date
    Sep 2012
    Posts
    7,101

    Default Re: Not bootable LUKS encrypted system after upgrade to 13.1

    Quote Originally Posted by cmyker View Post
    But i can't enter password because it is blocked by message
    Did you try to enter password anyway? Are you using plymouth?

  3. #3

    Default Re: Not bootable LUKS encrypted system after upgrade to 13.1

    Quote Originally Posted by arvidjaar View Post
    Did you try to enter password anyway? Are you using plymouth?
    I tried. But i see password characters between loading dots as i type:

    Code:
     Waiting for /dev/disk/by-id/ata-ST31000524AS_9VPCQQY2-part2 to appear...........my..pas..wo...rd
    I seems that mkinitrd scripts turn off plymouth for some reason:

    Code:
                    if luks_check_ply; then
                            plymouth display-message --text "Enter your passphrase, only US keyboard layout is supported"
                    else
                            echo "*** Note: only US keyboard layout is supported."
                            echo "*** Please ensure that the password is typed correctly."
                    fi
    Text only prompt above is displayed during boot

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Not bootable LUKS encrypted system after upgrade to 13.1

    On 2014-01-13 15:56, cmyker wrote:
    > I seems that mkinitrd scripts turn off plymouth for some reason:


    There is a boot option you can use to disable plymouth:
    "plymouth.enable=0". Try it.

    I remove the entire package on all my installs.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  5. #5

    Default Re: Not bootable LUKS encrypted system after upgrade to 13.1

    Quote Originally Posted by robin_listas View Post
    On 2014-01-13 15:56, cmyker wrote:
    > I seems that mkinitrd scripts turn off plymouth for some reason:


    There is a boot option you can use to disable plymouth:
    "plymouth.enable=0". Try it.

    I remove the entire package on all my installs.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)
    Unfortunately nothing changed, kernel is still unable to detect hdd and i can't enter LUKS password

  6. #6
    Join Date
    Sep 2012
    Posts
    7,101

    Default Re: Not bootable LUKS encrypted system after upgrade to 13.1

    Quote Originally Posted by cmyker View Post
    Text only prompt above is displayed during boot
    I'm afraid I did not understand which one of two prompts appear. Could you clarify?

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,676
    Blog Entries
    3

    Default Re: Not bootable LUKS encrypted system after upgrade to 13.1

    Quote Originally Posted by cmyker View Post
    BTW old intird for kernel 3.7.10 from Opensuse 12.3 works ok, detects /dev/disk/by-id/ata-ST31000524AS_9VPCQQY2-part2 ok, even after recreating of initrd with mkinitrd script.
    That should make it easier to fix. At least you can get in.

    I usually don't install plymouth. I think the first boot after install was a bit confusing. But I typed in the encryption key anyway, and it worked.

    On another install, where I used a live image so did have plymouth, I was using only encrypted "/home" and encrypted swap. Again, the prompt for key was a bit confusing, but entering it did work.

    Once I had the system up and running, I removed plymouth (on the system where it was installed). I put "initrd" in the option field of "/etc/crypttab". And then I ran "mkinitrd". That way the prompting for encryption key is done from the "initrd".

    My only current "problem" is in a Tumbleweed system, using an encrypted LVM. On booting, I get a zillion lines of "LVM not found" before I am prompted for the key. With 12.3, I used to get a bunch of lines "no media present", probably from a flash memory card reader. I suppose the 13.1 messages replace those.

    Since you can get in, you might try setting "initrd" in the options field of any needed entries in "/etc/crypttab", and setting "noauto" in the options field of an unneeded entries. Then rebuild the "initrd" and see if it helps.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •