Results 1 to 4 of 4

Thread: KMail2: Vollständige Suche funktioniert nicht

  1. #1
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    3,678

    Default KMail2: Vollständige Suche funktioniert nicht

    Ich habe eine Neuinstallation von openSUSE 13.1 durchgeführt. Die Migration zu KMail2 lief ohne Probleme ab. Die Ordnersuche oberhalb der Nachrichtenliste funktioniert anscheinend einwandfrei. Anders bei der vollständigen Suche: Es wird gar nichts gefunden oder wenn etwas angezeigt wird, dann oft doppelt. Die Meldung lautet zB: 5 Einträge gefunden. Im Fenster tauchen aber 10 Einträge auf, wobei ein jeder Eintrag doppelt abgelistet wird. Im Akonadilog steht:
    Code:
    karl@erlangen:~> sort -u ./.local/share/akonadi/akonadiserver.error
    
    ItemRetrieverException :  Unable to retrieve item from resource: <html>Ungültigen Eintrag erhalten</html> 
    Nepomuk Query Server not available
    Was muss ich tun, um eine korrekt funktionierende Suche zu erhalten?

  2. #2
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    3,678

    Default Re: KMail2: Vollständige Suche funktioniert nicht

    Nach einiger Suche fand ich noch folgende Meldungen:
    Code:
    karl@erlangen:~> cat ./.local/share/akonadi/db_data/mysql.err
    
    140113 17:58:43 InnoDB: The InnoDB memory heap is disabled
    140113 17:58:43 InnoDB: Mutexes and rw_locks use GCC atomic builtins
    140113 17:58:43 InnoDB: Compressed tables use zlib 1.2.8
    140113 17:58:43 InnoDB: Using Linux native AIO
    140113 17:58:43 InnoDB: Initializing buffer pool, size = 80.0M
    140113 17:58:43 InnoDB: Completed initialization of buffer pool
    140113 17:58:43 InnoDB: highest supported file format is Barracuda.
    140113 17:58:44  InnoDB: Waiting for the background threads to start
    140113 17:58:45 Percona XtraDB (http://www.percona.com) 5.5.33-MariaDB-31.1 started; log sequence number 286913460
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'events_waits_current' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'events_waits_history' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'events_waits_history_long' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'setup_consumers' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'setup_instruments' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'setup_timers' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'performance_timers' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'threads' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_thread_by_event_name' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_instance' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'events_waits_summary_global_by_event_name' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'file_summary_by_event_name' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'file_summary_by_instance' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'mutex_instances' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'rwlock_instances' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'cond_instances' has the wrong structure
    140113 17:58:45 [ERROR] Native table 'performance_schema'.'file_instances' has the wrong structure
    140113 17:58:45 [Note] /usr/sbin/mysqld: ready for connections.
    Version: '5.5.33-MariaDB'  socket: '/tmp/akonadi-karl.wRXz7f/mysql.socket'  port: 0  openSUSE package

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,926
    Blog Entries
    14

    Default Re: KMail2: Vollständige Suche funktioniert nicht

    Schau erst mal nach ob in "Systemeinstellungen" beim Arbeitsoberflachsuchen auch Emailindizirung eingeschaltet ist. Denn noch dauert es eine Weile bis alles völlig indiziert ist.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    3,678

    Default Re: KMail2: Vollständige Suche funktioniert nicht

    Die Email-Indizierung ist aktiviert. Die Meldung lautet "Indizierung abgeschlossen. (100%)". Ich habe sie schon mehrmals ausgesetzt und wieder aktiviert. Jedesmal lief sie ohne weitere Fehlermeldungen zu erzeugen ziemlich lange. Die Suchergebnisse hat das nicht verbessert. Als einzige Nebenwirkung werdem einiger Emails als neu gekennzeichnet.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •