Results 1 to 8 of 8

Thread: Segmentation faults in Midnight Commander

  1. #1
    Join Date
    Nov 2009
    Location
    Netherlands
    Posts
    74

    Default Segmentation faults in Midnight Commander

    Hallo allemaal,


    weet niet zeker of ik dit in het goede forum gepost heb, maar ik had de volgende vraag....


    Hebben meer mensen last van segmentation faults (oftewel geheugen toewijzings problemen zo te zeggen) in 'mc', sinds de laatste update?

    Ik heb ze nou om de haverklap!

    Mijn desktop: AMD APU A6-5400K, met 16GB DDR3-1600, waarvan 2GB gebruikt word voor het grafische deel.

    Dus geheugen tekort kan het niet zijn.


    Groetjes

    Marjon

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,822

    Default Re: Segmentation faults in Midnight Commander

    Om te weten of anderen het ook hebben zouden ze dat misschien willen proberen. En wel met dezelfde software die jij gebruikt. Je zult dus minstens moeten vertellen welke versie van openSUSE je gebruikt.
    Henk van Velden

  3. #3
    Join Date
    Nov 2009
    Location
    Netherlands
    Posts
    74

    Default Re: Segmentation faults in Midnight Commander

    Hallo Henk, dank voor je reaktie!


    Sorry dat ik wat laat antwoord, 't is nogal druk op moment.

    Ik had mn PC opnieuw geinstalleerd met OpenSuSE 13.1, alles up to date.

    Midnight Comm. is versie: 4.8.10

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Segmentation faults in Midnight Commander

    Quote Originally Posted by Marjon View Post
    Hallo Henk, dank voor je reaktie!


    Sorry dat ik wat laat antwoord, 't is nogal druk op moment.

    Ik had mn PC opnieuw geinstalleerd met OpenSuSE 13.1, alles up to date.

    Midnight Comm. is versie: 4.8.10
    Ha Marjon,

    Net even mc geïnstalleerd, start zonder problemen op, ik kan mappen browsen Nz.
    Welke desktop hebben we 't over?
    Meldt de segfault ook nog iets meer dan alleen het feit dat er een segfault is?
    Misschien dingen te vinden in ~/.xsession-errors-:0 , /var/log/Xorg.0.log of /var/log/messages ?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Nov 2009
    Location
    Netherlands
    Posts
    74

    Default Re: Segmentation faults in Midnight Commander

    Quote Originally Posted by Knurpht View Post
    Ha Marjon,

    Net even mc geïnstalleerd, start zonder problemen op, ik kan mappen browsen Nz.
    Welke desktop hebben we 't over?
    Meldt de segfault ook nog iets meer dan alleen het feit dat er een segfault is?
    Misschien dingen te vinden in ~/.xsession-errors-:0 , /var/log/Xorg.0.log of /var/log/messages ?
    Heb niks kunnen vinden....

    Normaal file browsing en zo gaat allemaal wel goed. Maar wanneer ik grotere files kopieer, bv een 5GB file, en zkr bij multiple file copy, dan knalt mc dr om de haverklap uit. Miss moet ik dr ook even bij vertellen, dat ik nogal veel met NFS doe. Maar of ik nou naar een NFS mount kopieer of lokaal, t maakt niet veel uit.

    Heb het ook op mn andere PC's waar ik 13.1 op heb geinstalleerd. Kan me dus niet indenken dat het aan de pc ligt. Op alle PC's draait KDE & LXDE. Maar ook onder TTY heb ik t probleem.

    PC heeft ook geheugen zat! De ene heeft A10 APU met 8GB waarvan 1GB shared, en de andere is een A6 met 16GB, waarvan 1GB shared. Dat shared mem kan dynamisch, maar daar gaat Linux (in het algemeen) niet lekker meee om, dus alle shared mem is fixed op 1GB.

    Alvast dank voor jullie reakties.

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Segmentation faults in Midnight Commander

    Je zou nog 's een andere versie kunnen proberen via http://software.opensuse.org/package/mc, maar 't lijkt een bug. En lastig dat er niets in de logs te vinden is
    Geeft
    Code:
    dmesg | tail -20
    ook niets als je net een segfault geforceerd hebt?

    Wat ik ook nog wel 's wi ldoen als ik een crash kan forceren, is meteen erna een
    Code:
    ls -ltr /var/log
    . De onderste bestanden zijn dan 't laatst benaderd, en daar doe ik dan een
    Code:
    tail -20
    op.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Nov 2009
    Location
    Netherlands
    Posts
    74

    Default Re: Segmentation faults in Midnight Commander

    De bug is er nog steeds......


    t probleem doet zich voor, wanneer je files 'moved' (met F6) van de ene plek nd andere plek.

    Wanneer de files eerst gekopieerd worden, en daarna gewist, (dus eerst met F5 en daarna met F8), is dr geen enkel probleem.
    En t is zo, dat t probleem niet elke keer opdoemt wanneer je F6 gebruikt. De ene keer is dr niks ad hand, en de andere keer knalt mc eruit met een segment error.

    Heeft nou echt niemand anders dit probleem????? Kan het me niet indenken.

    Zelfs na herhalijke nieuwe installaties van suse, bleef het probleem bestaan, bij ELKE nieuw-install.

    Het kan gewoon niet dat ik de enigste ben.

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Segmentation faults in Midnight Commander

    Quote Originally Posted by Marjon View Post
    De bug is er nog steeds......


    t probleem doet zich voor, wanneer je files 'moved' (met F6) van de ene plek nd andere plek.

    Wanneer de files eerst gekopieerd worden, en daarna gewist, (dus eerst met F5 en daarna met F8), is dr geen enkel probleem.
    En t is zo, dat t probleem niet elke keer opdoemt wanneer je F6 gebruikt. De ene keer is dr niks ad hand, en de andere keer knalt mc eruit met een segment error.

    Heeft nou echt niemand anders dit probleem????? Kan het me niet indenken.

    Zelfs na herhalijke nieuwe installaties van suse, bleef het probleem bestaan, bij ELKE nieuw-install.

    Het kan gewoon niet dat ik de enigste ben.
    Da's dan duidelijk: bug(s).

    Ik denk niet dat jij de enige bent die de bug ervaart, wel dat jij één van de weinigen bent die MC gebruikt. Zelf ben ik van vóór MC, gewend om in een terminal nog steeds de basis commando's, evt. scripts, te gebruiken, maar ik denk dat de meeste mensen tegenwoordig vanaf een desktop filemanager werken.
    Heb je recente bugreports gevolgd?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •