Results 1 to 7 of 7

Thread: New VirtualBox-4.3 has broken dependency

  1. #1
    Join Date
    Apr 2012
    Location
    Philippines
    Posts
    218

    Default New VirtualBox-4.3 has broken dependency

    I am trying to install the new VirtualBox-4.3 on my new opensuse 13.1 distro on my laptop.

    I get the following error:
    Code:
    # zypper in VirtualBox-4.3
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    
    Problem: nothing provides libvpx.so.0()(64bit) needed by VirtualBox-4.3-4.3.6_91406_openSUSE114-1.x86_64
     Solution 1: do not install VirtualBox-4.3-4.3.6_91406_openSUSE114-1.x86_64
     Solution 2: break VirtualBox-4.3-4.3.6_91406_openSUSE114-1.x86_64 by ignoring some of its dependencies
    
    
    Choose from above solutions by number or cancel [1/2/c] (c):
    I don't think this has anything to do with it being opensuse 13.1, because I had the same problem in 12.3, but I didn't have time to troubleshoot it. I was hoping the libvpx.so.0 would have been somewhere in the repos, but it ain't.

    I always like to run the Virtual Box that comes from oracle rather than the packaged versions in the opensuse repos, as I have heard it gives greater flexibility. Anyone have any idea how to find this needed dependency and so install the latest version of virtual box?

    Thanks
    George

    G.O.
    Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 12.3 | KDE 4.10 | AMD Athlon X3 | 64 | 4GB
    Laptop: 13.1 | KDE 4.10 | Core i7-2620M | 64 | 8GB
    Last edited by malcolmlewis; 07-Aug-2017 at 13:45.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,825
    Blog Entries
    15

    Default Re: New VirtualBox-4.3 has broken dependency

    Hi
    That's because 13.1 has libvpx1, maybe you need to contact Oracle and advise them to update the package?

    I would imagine the openSUSE version is built against libvpx1 for both 13.1 and 12.3, libvpx0 was in 12.2.

    Ahh your installing a version built for openSUSE 11.4......
    Last edited by malcolmlewis; 11-Jan-2014 at 23:06.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,825
    Blog Entries
    15

    Default Re: New VirtualBox-4.3 has broken dependency

    There is a 12.3 version in their download area;
    http://download.virtualbox.org/virtu...3-1.x86_64.rpm
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4
    grglsn NNTP User

    Default Re: New VirtualBox-4.3 has broken dependency

    On 01/12/2014 02:16 PM, malcolmlewis wrote:
    >
    > There is a 12.3 version in their download area;
    > http://tinyurl.com/oedc5sk
    >
    >

    Thanks! That did the trick!

    --
    G.O.
    Box #1: 12.3 | KDE 4.11 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 12.3 | KDE 4.11 | AMD Athlon X3 | 64 | 4GB
    Laptop: 13.1 | KDE 4.11 | Core i7-2620M | 64 | 8GB

  5. #5
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: New VirtualBox-4.3 has broken dependency

    I am using the following repository to install VirtualBox:
    http://download.opensuse.org/reposit...able_standard/

    Information for package virtualbox:
    -----------------------------------
    Repository: Virtualbox
    Name: virtualbox
    Version: 4.3.28-152.8
    Arch: x86_64
    Vendor: obs://build.opensuse.org/Virtualization
    Installed: Yes
    Status: out-of-date (version 4.3.28-148.3 installed)

    Can no longer update because of libvpx, and my openSUSE 13.2 has installed libvpx1 instead.

  6. #6

    Default Re: New VirtualBox-4.3 has broken dependency

    Well, that thread originally was about the virtualbox package from virtualbox.org, and the problem was caused by trying to install the 11.4 version on 12.3/13.1.

    Quote Originally Posted by DJViking View Post
    I am using the following repository to install VirtualBox:
    http://download.opensuse.org/reposit...able_standard/
    That repo builds against Factory (because Kernel:stable builds against Factory), which already has libvpx2 (only).
    You could install libvpx2 on 13.2 from the multimedia:libs repo:
    http://software.opensuse.org/search?...&p=1&q=libvpx2

    Other workarounds that spring to mind:
    - Install virtualbox from http://virtualbox.org instead (they even offer an openSUSE repo), but this will require you to recompile the kernel module after each kernel update (run "/etc/init.d/vboxdrv setup"). If you do this, remove all openSUSE virtualbox packages first.
    - Use the 13.2 repo:
    http://download.opensuse.org/reposit.../openSUSE_13.2
    This will only work with the 3.16.x Kernel included in 13.2 though. As you seem to use the one from Kernel:stable, you'd either need to switch back to 3.16.7, or install the package virtualbox-host-source, this contains the kernel module source code and allows you to compile it for any kernel.

  7. #7

    Default Re: New VirtualBox-4.3 has broken dependency

    In case people find this via Google or something:
    This is an old thread, and it is closed.
    Your problem is likely not related to the things discussed here.

    And if you do want to use VirtualBox, please consider installing the package included in the distribution.
    That one should work, and it will be updated automatically too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •