Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: kaffeine start up bug, suse 13.1-kde

  1. #1

    Default kaffeine start up bug, suse 13.1-kde

    When I double click on an FLV video, the window opens, but the video doesn't play. It takes closing the window and clicking again. I do this many times over to get the video to start. Can someone help me?

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,399
    Blog Entries
    1

    Default Re: kaffeine start up bug, suse 13.1-kde

    Quote Originally Posted by lord_valarian View Post
    When I double click on an FLV video, the window opens, but the video doesn't play. It takes closing the window and clicking again. I do this many times over to get the video to start. Can someone help me?

    Thanks
    Start kaffeine from a terminal, and post the errors reported. Maybe you don't have the necessary codecs installed yet?

  3. #3

    Default Re: kaffeine start up bug, suse 13.1-kde

    Quote Originally Posted by deano_ferrari View Post
    Start kaffeine from a terminal, and post the errors reported. Maybe you don't have the necessary codecs installed yet?
    As I understand it, it works when starting Kaffeine a second time, so the codecs must be installed correctly.

    Somebody else had a similar problem here in the german forum a while ago.
    There it was caused by VAAPI. Installing the package vdpau-video helped.
    If you speak german, here is the thread:
    http://forums.opensuse.org/showthrea...odprobe-nötig

    So try to install this if you are using an nvidia card with the proprietary nvidia driver.

    Or try to set Kaffeine to use a different video output device by editing ~/.kde4/share/apps/kaffeine/xine-config (you can try this no matter which graphics card you have)
    Code:
    video.driver:vdpau
    or if you don't use nvidia, try:
    Code:
    video.driver:xshm

  4. #4

    Default kaffeine start up bug, suse 13.1-kde

    [ ] = action taken



    Code:
    >kaffeine hero.flv
    Object::connect: No such signal org::freedesktop::UPower:DeviceAdded(QDBusObjectPath)
    Object::connect: No such signal org::freedesktop::UPower:DeviceRemoved(QDBusObjectPath)
    alex@linux-nsfx:~/Videos> libva info: VA-API version 0.34.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/nouveau_drv_video.so
    libva info: va_openDriver() returns -1
    [control-c break]

    Code:
    > kaffeine hero.flv
    > kaffeine hero.flv
    [Close open window]

    Code:
    >kaffeine hero.flv
    Object::connect: No such signal org::freedesktop::UPower:DeviceAdded(QDBusObjectPath)
    Object::connect: No such signal org::freedesktop::UPower:DeviceRemoved(QDBusObjectPath)
    alex@linux-nsfx:~/Videos> xv_set_property: property=0, value=0
    xv_set_property: property=0, value=0
    [video plays]

  5. #5

    Default AW: kaffeine start up bug, suse 13.1-kde

    Quote Originally Posted by lord_valarian View Post
    Code:
    >kaffeine hero.flv
    Object::connect: No such signal org::freedesktop::UPower:DeviceAdded(QDBusObjectPath)
    Object::connect: No such signal org::freedesktop::UPower:DeviceRemoved(QDBusObjectPath)
    alex@linux-nsfx:~/Videos> libva info: VA-API version 0.34.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/nouveau_drv_video.so
    libva info: va_openDriver() returns -1
    So this is definitely a problem with VAAPI as I suspected, see my previous post.

    Do you have libvdpau_nouveau installed? If not install it, maybe vdpau would work better. (You may have to set the video driver to "vdpau" to use it, but that should be preferred anyway I think).
    I don't know if vdpau-video would work with the nouveau driver, I think that's nvidia specific.

    Setting the video driver to "xshm" should work in any case, but would provide no hardware acceleration. "xv" might work as well, which does use 2d hardware acceleration, but no hardware decoding.

    What graphics card do you have, btw?
    Maybe you would be better off by just installing the nvidia driver?

  6. #6

    Default Re: AW: kaffeine start up bug, suse 13.1-kde

    Quote Originally Posted by wolfi323 View Post
    So this is definitely a problem with VAAPI as I suspected, see my previous post.

    Do you have libvdpau_nouveau installed? If not install it, maybe vdpau would work better. (You may have to set the video driver to "vdpau" to use it, but that should be preferred anyway I think).
    I don't know if vdpau-video would work with the nouveau driver, I think that's nvidia specific.

    Setting the video driver to "xshm" should work in any case, but would provide no hardware acceleration. "xv" might work as well, which does use 2d hardware acceleration, but no hardware decoding.

    What graphics card do you have, btw?
    Maybe you would be better off by just installing the nvidia driver?
    I installed the nvidia drivers. nvidia 560gt 2 gig

    Same error

    libvdpaul installed

    libvdpau_nouveau installed that.

    Same error.

    You may have to set the video driver to "vdpau" to use it
    How? Yast?

  7. #7

    Default Re: AW: kaffeine start up bug, suse 13.1-kde

    Quote Originally Posted by lord_valarian View Post
    How? Yast?
    No.
    ~/.kde4/share/apps/kaffeine/xine-config as I wrote before.

    But how did you install the nvidia driver?
    And does it work?
    Please install the package "Mesa-demo-x" and post the output of:
    Code:
    glxinfo | grep render
    And you still didn't say which graphics card you have. Please do so.

    PS: As you are using the nvidia driver now, please also install vdpau-video from Packman, that should help in that case.

  8. #8

    Default kaffeine start up bug, suse 13.1-kde

    lv>I installed the nvidia drivers. ----video card: evga nvidia 560gt 2 gig ------------

    The nvidia drivers work fine. The error happens with or without nvidia drivers installed. I found the error after installing the multi-media drivers.

    Do you have libvdpau_nouveau installed?
    libvdpaul installed
    libvdpau_nouveau installed

    I used the 'one-click install' for multi-media support and nvidia drivers.


    ~/.kde4/share/apps/kaffeine/xine-config

    Clicking plays the video. Then I close it. Then click a different video, no play. Close window. That file is overridden and video driver is set back to 'auto'. I used file manager super user mode - kwrite then save.

    >glxinfo | grep render
    [no output]
    PS: As you are using the nvidia driver now, please also install vdpau-video from Packman, that should help in that case.
    Installed that.

  9. #9

    Default Re: kaffeine start up bug, suse 13.1-kde

    Quote Originally Posted by lord_valarian View Post
    libvdpau_nouveau installed
    That's not needed if you use the nvidia driver, but it shouldn't harm.

    ~/.kde4/share/apps/kaffeine/xine-config

    Clicking plays the video. Then I close it. Then click a different video, no play. Close window. That file is overridden and video driver is set back to 'auto'. I used file manager super user mode - kwrite then save.
    Don't! Open it as normal user. That is a user configuration.

    Most likely you edited the xine-config for root, which has of course no effect for your user.

    And try setting the video device to "vdpau" (or "xv" if that doesn't work, or "xshm").

    >glxinfo | grep render
    [no output]
    You have to install "Mesa-demo-x" for that.

  10. #10
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,013

    Default Re: kaffeine start up bug, suse 13.1-kde

    Hi, I get the following message:
    Code:
    karl@erlangen:~> kaffeine Bilder/2013//2013-12-23/p1010399.mov
    
    Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QDBusObjectPath)
    Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QDBusObjectPath)
    libva info: VA-API version 0.34.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/dri/r600_drv_video.so
    libva info: va_openDriver() returns -1
    Nothing is displayed by Kaffeine. Do you have any idea?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •