Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: FN buttom problem

  1. #1

    Default FN buttom problem

    Hi, I use OpenSuse 13.1 my machine is Acer Aspire 5750G, I have problem - my FN buttons don`t work for brightness, but for sound is working perfect and show me to desktop level of sound when I use it, but for brightness is now working, and Nums or capslock work but not show me

  2. #2
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: FN buttom problem

    Quote Originally Posted by qbasix View Post
    Hi, I use OpenSuse 13.1 my machine is Acer Aspire 5750G, I have problem - my FN buttons don`t work for brightness, but for sound is working perfect and show me to desktop level of sound when I use it, but for brightness is now working, and Nums or capslock work but not show me
    Add this line to /etc/default/grub:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor"
    After saving file changes, run as "su -" grub2-mkconfig -o /boot/grub2/grub.cfg

    Restart your laptop and check the brightness keys.

    You can also try:
    Code:
    xbacklight +10% and xbacklight -10%
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  3. #3
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: FN buttom problem

    Follow Up

    If that doesn't work try replacing the previous entry with the following:
    Code:
    acpi_osi=Linux
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  4. #4
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: FN buttom problem

    Alternate Option

    Another option is to add the entries to /etc/default/grub in between the quotes:
    Code:
    GRUB_CMDLINE_LINUX=""
    Instead of:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT=""
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  5. #5

    Default Re: FN buttom problem

    Quote Originally Posted by Romanator View Post
    Alternate Option

    Another option is to add the entries to /etc/default/grub in between the quotes:
    Code:
    GRUB_CMDLINE_LINUX=""
    Instead of:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT=""
    but I have double boot system ( Windows 7 and openSUSE)
    is this a problem ? And after this will be lost my Windows 7 boot ???

    I add this:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor"
    but no effect

  6. #6
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: FN buttom problem

    Quote Originally Posted by qbasix View Post
    but I have double boot system ( Windows 7 and openSUSE)
    is this a problem ? And after this will be lost my Windows 7 boot ???

    I add this:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor"
    but no effect
    Try adding adding this line:
    Code:
    acpi_osi=Linux
    So it looks like:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor acpi_osi=Linux"
    Always remember whenever you alter a file with grub2. You must run the following command:
    Code:
    grub2-mkconfig -o /boot/grub2/grub.cfg
    Restart your laptop. Then install the "xbacklight" package using the command:
    Code:
    sudo zypper in xbacklight
    xbacklight allows you to control your backlight. Start with the commands:

    This command should increase the brightness:
    Code:
    xbacklight +10%
    This should decrease the brightness:
    Code:
    xbacklight -10%
    BTW Are you running KDE4 or GNOME?

    Good Luck!
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  7. #7

    Default Re: FN buttom problem

    Thank you very much my friend, it`s work now , but now when PC start show me Windows 7 and GNU/Linux ( before was OpenSUSE now name is GNU/Linux)
    and when i chose GNU/Linux start show many lines of codes, and then start the OpenSuse.
    And when I use xbacklight +10% or -10% on desctop show me level of brightness, but when use FN buttom don`t show me. (This is not a big problem )
    And BTW I use KDE4.

  8. #8
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: FN buttom problem

    Thank you very much my friend, it`s work now , but now when PC start show me Windows 7 and GNU/Linux ( before was OpenSUSE now name is GNU/Linux)
    and when i chose GNU/Linux start show many lines of codes, and then start the OpenSUSE.
    • Start up Yast2 Boot Loader -->Click on Boot_loader Options button
    • Change the name In the Distributor field
    • Click on the OK buttons to confirm the changes

    Note: The Yast2 Boot Loader will run grub2-mkconfig automatically after clicking on the OK buttons. So it's not necessary to run the command again in "konsole" or "xterm".
    And when I use xbacklight +10% or -10% on desktop show me level of brightness, but when use FN button don`t show me. (This is not a big problem )
    And BTW I use KDE4.
    1. Navigate to Configure Desktop-->System Settings-->Shortcuts and Gestures-->Custom Shortcuts
    2. Select Edit-->New-->Global Shortcut-->Command/URL
    3. Assign a name i.e. Increase brightness
    4. Select the Comment tab and type in Increase Brightness
    5. Select the Trigger tab and assign your keyboard shortcut
    6. Select the Action tab and copy the command from konsole to Command/URL section
    7. Click on the Apply button to confirm the changes.

    That's it. You may have to restart your laptop. Please work on it.


    FYI If you have and are using your graphics card with Bumblebee nVidia Optimus support:


    Navigate to and edit /etc/X11/xorg.conf.d/50-device.conf and add the following:
    Code:
    Section "Device"
        Identifier "Device0"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        Option "RegistryDwords" "EnableBrightnessControl=1"
    EndSection
    Save your changes and shutdown and restart your laptop.
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  9. #9

    Default Re: FN buttom problem

    Quote Originally Posted by Romanator View Post
    • Start up Yast2 Boot Loader -->Click on Boot_loader Options button
    • Change the name In the Distributor field
    • Click on the OK buttons to confirm the changes

    Note: The Yast2 Boot Loader will run grub2-mkconfig automatically after clicking on the OK buttons. So it's not necessary to run the command again in "konsole" or "xterm".


    1. Navigate to Configure Desktop-->System Settings-->Shortcuts and Gestures-->Custom Shortcuts
    2. Select Edit-->New-->Global Shortcut-->Command/URL
    3. Assign a name i.e. Increase brightness
    4. Select the Comment tab and type in Increase Brightness
    5. Select the Trigger tab and assign your keyboard shortcut
    6. Select the Action tab and copy the command from konsole to Command/URL section
    7. Click on the Apply button to confirm the changes.

    That's it. You may have to restart your laptop. Please work on it.


    FYI If you have and are using your graphics card with Bumblebee nVidia Optimus support:


    Navigate to and edit /etc/X11/xorg.conf.d/50-device.conf and add the following:
    Code:
    Section "Device"
        Identifier "Device0"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        Option "RegistryDwords" "EnableBrightnessControl=1"
    EndSection
    Save your changes and shutdown and restart your laptop.
    After I make this

    Code:
    FYI If you have and are using your graphics card with Bumblebee nVidia Optimus support:
    
    Navigate to and edit /etc/X11/xorg.conf.d/50-device.conf and add the following:
    
    Code:
    Section "Device"
        Identifier "Device0"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        Option "RegistryDwords" "EnableBrightnessControl=1"
    EndSection
    Save your changes and shutdown and restart your laptop.
    my OpenSUSE now start in "terminal mode" have not desctop have not KDE how can reapir this ?

  10. #10
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: FN buttom problem

    My OpenSUSE now starts in "terminal mode" have no desktop I have no KDE4. How can I repair this ?
    Looks like there is a syntax error somewhere or perhaps it's competing with the bumblebee.conf file. Most likely it's the latter.

    Problem when getting stuck in console



    When you boot, boot to runlevel 3 or init 3 first, and then runlevel 5, and before completing runlevel 5 login screen,
    go back to a console screen as root or "su -" (without the quotes) and issue the commands:

    rcxdm stop

    then type:

    rcxdm start


    Complete your login screen and you should be able to use the desktop.

    If it switches back to "console or terminal mode" again, try editing the file again /etc/X11/xorg.d/50-device.conf and change it to the following:
    Code:
    #Section "Device"
    #   Identifier "Device[0]"
    #   Driver "nvidia"
    #   VendorName "NVIDIA Corporation"
    #   Option "RegistryDwords" "EnableBrightnessControl=1"
    #EndSection
    The pound sign comments out the entry.


    How To Edit the File with The VIM Editor

    Restart your laptop. From the Grub2 menu and select the Advanced entry. Press the <enter> key once to view and select Recovery Mode with the arrow key.
    Press the "e" key (for edit). Use the up and the left arrow key to navigate to the line that includes "nomodeset x11failsafe".

    At the end of the line (after the last word) add a space with the <space> bar and type press the number " 3 " key once and then press the " F10 " key (without the quotes).
    This will boot to runlevel 3 or "init3" in console mode. Now, you can use the "vim editor" with command "vim" (without the quotes) to uncomment.

    Below is an example of what you may see while in edit mode in Grub2:
    Code:
    menuentry 'openSUSE 13.1, with Linux 3.11.6-4-desktop (recovery mode)' --class 'opensuse-13-1' --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.11.6-4-desktop-recovery-4da26394-58bd-454b-b8f2-f12da3dfe983' {
            load_video
            set gfxpayload=keep
            insmod gzio
            insmod part_msdos
            insmod ext2
            set root='hd0,msdos1'
            if [ x$feature_platform_search_hint = xy ]; then
              search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint='hd0,msdos1'  4da26394-58bd-454b-b8f2-f12da3dfe983
            else
              search --no-floppy --fs-uuid --set=root 4da26394-58bd-454b-b8f2-f12da3dfe983
            fi
            echo    'Loading Linux 3.11.6-4-desktop ...'
            linux    /boot/vmlinuz-3.11.6-4-desktop root=UUID=4da26394-58bd-454b-b8f2-f12da3dfe983  showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 
            nomodeset  x11failsafe 3
            echo    'Loading initial ramdisk ...'
            initrd    /boot/initrd-3.11.6-4-desktop
    While in the vim editor use the arrow key to navigate. Press the " i " key for inserting the # key. Once you've finished., press the <escape> key once. It will add a colon " : ".
    Then type "wq" and will appear as :wq. Which stands for write and quit.

    Finally, type:
    Code:
    shutdown -r now
    This will reboot your system and the problem will be resolved.
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •