Results 1 to 2 of 2

Thread: Yast gui does not use system colors

  1. #1

    Default Yast gui does not use system colors

    I use openSUSE in a low light environment, and have configured KDE for a soft green text on dark background. It is easy on the eyes. When I start Yast it is like pointing a bright light into my (dark adjusted) eyes. Ouch! I tried using Yast -> system -> /etc/sysconfig-editor -> System -> Yast2 -> GUI ->
    Y2NCURSES_COLOR_THEME
    inverted
    but this is apparently only for ncurses, and not qt or gtk.

    All the applications inherit the system colors - except Yast. Why can't Yast gui use the system color settings?

    I am using openSUSE 13.1 64-bit intel.

  2. #2

    Default Re: Yast gui does not use system colors

    Quote Originally Posted by AnisaAmpatuan View Post
    All the applications inherit the system colors - except Yast. Why can't Yast gui use the system color settings?
    The Qt version of YaST uses themes and the standard theme uses its own colors. You could switch from yast2-theme-openSUSE-Oxygen to yast2-theme-openSUSE-Crystal and YaST should use the system's colors instead. (just install the latter package)

    Or turn off theming completely by setting the environment variable $Y2STYLE to an empty value.
    To do this globally, add the following line to /etc/environment, f.e.:
    Code:
    Y2STYLE=
    But note that YaST runs as root, so it uses root's color settings.
    Change them with systemsettings run as root:
    Code:
    kdesu systemsettings
    Or you could also create another theme, see here f.e.:
    http://lizards.opensuse.org/2008/12/...esheet-editor/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •