Results 1 to 4 of 4

Thread: OpenSUSE equivalent of Debian's update-grub?

  1. #1

    Default OpenSUSE equivalent of Debian's update-grub?

    Hello all. (Brand-new OpenSUSE user here.)

    I've just installed OpenSUSE 13.1 on an older Dell PowerEdge 840 and all is well except that with the normal boot, an off-color splash screen of the lizard/vine appears and then the screen goes black and the computer goes into power-saving mode. I then have to re-boot.

    If I press escape during the boot (or boot in recovery mode), it boots properly. The messages scrolling by all have green "OK" labels.

    I strongly suspect the issue is the video driver (for ATI on this system).

    I have tried the instructions here: http://en.opensuse.org/SDB:Radeon -- and the test "gears" program does run correctly, although the terminal gives the following error: "libGL error: failed to load driver: radeon".

    A Debian admin agrees that it's a video driver issue (saying the ATI ES1000 video chip on the system is old and does not support the 3D graphics used in start-up) and suggested adding the parameter "video=1024x768@60" to the GRUB_CMDLINE_LINUX_DEFAULT option in /etc/default/grub and then running the command "update-grub" in the terminal.

    However, "update-grub" generates an invalid-command error in OpenSUSE (although it apparently works in Debian).

    Does anyone know the equivalent in OpenSUSE? Or is there a better approach to resolving this driver issue?

    Thank you!

  2. #2

    Default Re: OpenSUSE equivalent of Debian's update-grub?

    Quote Originally Posted by futureofnews View Post
    A Debian admin agrees that it's a video driver issue (saying the ATI ES1000 video chip on the system is old and does not support the 3D graphics used in start-up) and suggested adding the parameter "video=1024x768@60" to the GRUB_CMDLINE_LINUX_DEFAULT option in /etc/default/grub and then running the command "update-grub" in the terminal.

    However, "update-grub" generates an invalid-command error in OpenSUSE (although it apparently works in Debian).

    Does anyone know the equivalent in OpenSUSE? Or is there a better approach to resolving this driver issue?
    On openSUSE you would need to run "grub2-mkconfig", there should even be a comment at the top of /etc/default/grub that tells you this.
    Or use YaST->System->Boot Loader->Boot Loader Options to change it, you can even select the graphics mode there without having to type in "video=1024x768@60" manually.

    According to your description, plymouth (the boot splash) could be causing your problem though. You can disable it by adding "plymouth.enable=0" to the "Optional Kernel Parameter" line (see above).
    Or just uninstall the package "plymouth" and all the dependencies.

  3. #3

    Default Re: OpenSUSE equivalent of Debian's update-grub?

    Thank you, wolfi323!

    Just using "grub2-mkconfig" didn't work, but using "grub2-mkconfig -o /boot/grug2/grub.cfg" (as specified in the comment at the top of /etc/default/grub, as you mentioned) DID work.

    Now OpenSUSE boots properly without any intervention, so I can now have some fun exploring the new OS.

    Thanks again!

  4. #4
    Join Date
    Sep 2012
    Posts
    7,096

    Default Re: OpenSUSE equivalent of Debian's update-grub?

    Quote Originally Posted by wolfi323 View Post
    On openSUSE you would need to run "grub2-mkconfig"
    On openSUSE you would actually need to run "update-bootloader --refresh" that should do the right thing, even on past distro versions where your grub.cfg is not necessary in /boot/grub2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •