Results 1 to 3 of 3

Thread: segmentation fault OpenSUSE 13.1 when mounting nfs4 with kerberos

  1. #1
    Join Date
    Feb 2012
    Location
    Copenhagen
    Posts
    15

    Default segmentation fault OpenSUSE 13.1 when mounting nfs4 with kerberos

    Hi Everyone.

    Trying to mount a kerberized nfs4 share on a newly installed OpenSUSE 13.1 X64 system spawns a segfault in rpc.gssd

    kernel: [ 2490.543122] rpc.gssd[7680]: segfault at 20 ip 00007f0b88a58f5b sp 00007fffba45d360 error 4 in libgssapi_krb5.so.2.2[7f0b88a40000+43000]

    currently the bug i traced to libtirpc version. 0.2.3-1.1

    you can obtain a working version from: http://download.opensuse.org/reposit...3.1.x86_64.rpm
    after installing that nfs4 mounting with kerberos works.

    When can we expect it to be added in the Main Update repo?
    right now nfs4 with kerberos is broken.


    Cheers
    - Tim

  2. #2

    Default Re: segmentation fault OpenSUSE 13.1 when mounting nfs4 with kerberos

    Quote Originally Posted by timfolsen View Post

    currently the bug i traced to libtirpc version. 0.2.3-1.1

    you can obtain a working version from: http://download.opensuse.org/reposit...3.1.x86_64.rpm

    Cheers
    - Tim
    It works.

    Thank you very much!!!

    Best regards
    Simon

  3. #3

    Default Re: segmentation fault OpenSUSE 13.1 when mounting nfs4 with kerberos

    Quote Originally Posted by timfolsen View Post
    When can we expect it to be added in the Main Update repo?
    right now nfs4 with kerberos is broken.
    Have you filed a bug report? (http://bugzilla.novell.com/, use the same username/password as here)

    If the maintainers are not aware of that problem, there won't be an update, ever.

    PS: Found this:
    https://bugzilla.novell.com/show_bug.cgi?id=841788

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •