Results 1 to 4 of 4

Thread: Force fan to start using software control

  1. #1
    Join Date
    Mar 2011
    Location
    Denmark
    Posts
    51

    Default Force fan to start using software control

    Is it possible to test the fan by forcing it to start with some kind of software command?

    I think my problem is a hardware fault as the laptop overheat and stop at about 90 degrees C at 80% cpu load without the fan ever starts. As fare I remembered the fault occurred first time when the battery died and charger has to be connected all the time. But I would try a last test before I give up getting this laptop to be running any more :-(

    I have read alot of threads on opensuse, lenovo-forum ... without any luck.

    Here are some of the data:
    Standard opensuse 13.1,kernel 3.11.6, kde 4.11.3 , 32 bit, Lenovo 3000 n200 bios v. 3.5, installed sensors

    Hardware repairs: cleaned fan, replaced with other fan bought on Ebay, new power charger, new thermal paste on cpu.

    The laptop is able to run when I has a vacuum cleaner placed by the fan that is not running. But this is a rather noisy construction :-)

    Jan

  2. #2
    Join Date
    Mar 2011
    Location
    Denmark
    Posts
    51

    Default Re: Force fan to start using software control

    Sorry Bios version is 3.05. Upgraded to the newest according to Lenovo support.

  3. #3
    Join Date
    Jul 2008
    Location
    Warrington, England
    Posts
    161

    Default Re: Force fan to start using software control

    Quote Originally Posted by janoleholm View Post
    Is it possible to test the fan by forcing it to start with some kind of software command?

    I think my problem is a hardware fault as the laptop overheat and stop at about 90 degrees C at 80% cpu load without the fan ever starts.
    Hardware repairs: cleaned fan, replaced with other fan bought on Ebay, new power charger, new thermal paste on cpu.

    The laptop is able to run when I has a vacuum cleaner placed by the fan that is not running. But this is a rather noisy construction :-)

    Jan
    I have
    Similar situation on old Acer 7720, how I use .
    a) start laptop, b)run browser randomly to deliberately overheat CPU (say 3 minutes) c) laptop stops and cuts out
    THEN d) I immediately restart and hold wet finder near fan,e) fan starts with BIOS, Grub loads, select OpenSUSE f)OpenSUSE starts and usually (9 timesout of ten) the fan keeps running and thus temperature drops and system is useable as long as I do not switch off when in cold state running.
    As machine dual boots with Windows VISTA and fan always works in VISTA, it is a software problem in OpenSUSE.
    use a temperature sensor add in to your start program. When fan works; OpenSUSE runs at 25 to 40 C with VISTA temperature is useually 65 to75 C
    Regards
    Eionmac
    openSUSE LEAP 15.3 , Windows 10 ; standby Leap 15.3 on second USB external drive. Various old computers dual boot and Live Linux distros

  4. #4
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: Force fan to start using software control

    Quote Originally Posted by eionmac View Post
    I have
    Similar situation on old Acer 7720, how I use .
    a) start laptop, b)run browser randomly to deliberately overheat CPU (say 3 minutes) c) laptop stops and cuts out
    THEN d) I immediately restart and hold wet finder near fan,e) fan starts with BIOS, Grub loads, select OpenSUSE f)OpenSUSE starts and usually (9 timesout of ten) the fan keeps running and thus temperature drops and system is useable as long as I do not switch off when in cold state running.
    As machine dual boots with Windows VISTA and fan always works in VISTA, it is a software problem in OpenSUSE.
    use a temperature sensor add in to your start program. When fan works; OpenSUSE runs at 25 to 40 C with VISTA temperature is useually 65 to75 C
    @eionmac

    Make sure you update your BIOS to v1.45. That should improve the fan control.

    Here's the download repository for your BIOS:

    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •