Results 1 to 3 of 3

Thread: Mounting NFS and "clnt_create: RPC: Unknown host"

  1. #1

    Default Mounting NFS and "clnt_create: RPC: Unknown host"

    ciaoo (openSUSE,kde 4.12)

    I have a problem with the NFS mount
    accepts only the source path "/"
    if I put the full path does not work
    although on the server, the folder exists and is exported "I guess" correctly

    I also tried to share the same with samba and working properly


    client: UNSUCCESSFUL MOUNTING and if i share the same folder "/home/Shared" with samba, the browsing goes fine
    Code:
     mount  -v -t nfs4 Pentium4.MyNetwork:/home/Shared /mnt/Shared.NFS
    mount.nfs4: timeout set for Mon Jan  6 20:52:53 2014
    mount.nfs4: trying text-based options 'addr=192.168.1.101,clientaddr=192.168.1.100'
    mount.nfs4: mount(2): No such file or directory
    client: MOUNTING WORKS FINE
    Code:
    # mount  -vv -t nfs4 Pentium4.MyNetwork:/ /mnt/Shared.NFS
    mount.nfs4: timeout set for Mon Jan  6 20:54:06 2014
    mount.nfs4: trying text-based options 'addr=192.168.1.101,clientaddr=192.168.1.100'
    expoted on server NFS: [Pentium4.MyNetwork]
    Code:
    /home/Shared    192.168.1.0/24(fsid=0,crossmnt,rw,root_squash,sync,no_subtree_check)
    server and client:
    Code:
    # showmount -a
    clnt_create: RPC: Unknown host
    NetbookVaio:/home/ivan 
    # showmount -e
    clnt_create: RPC: Unknown host
    NetbookVaio:/home/ivan #

    client:
    Code:
    # ping Pentium4.MyNetwork
    PING Pentium4.MyNetwork (192.168.1.101) 56(84) bytes of data.
    64 bytes from Pentium4.MyNetwork (192.168.1.101): icmp_seq=1 ttl=64 time=7.30 ms
    64 bytes from Pentium4.MyNetwork (192.168.1.101): icmp_seq=2 ttl=64 time=3.29 ms
    server and client:
    Code:
    # systemctl -a | grep nfs
    proc-fs-nfsd.mount                                                               loaded active   mounted   /proc/fs/nfsd
    var-lib-nfs-rpc_pipefs.mount                                              loaded active   mounted   /var/lib/nfs/rpc_pipefs
    nfs.service                                                                              loaded active   running   LSB: NFS client services
    nfsserver.service                                                                   loaded active   running   LSB: Start the kernel based NFS daemon
    server and client:
    Code:
    # cat /etc/idmapd.conf
    [General]
    Verbosity = 0
    Pipefs-Directory = /var/lib/nfs/rpc_pipefs
    Domain = MyNetwork
    
    [Mapping]
    Nobody-User = nobody
    Nobody-Group = nobody

    Code:
    # cat /etc/hosts
    127.0.0.1       localhost 
    192.168.1.100   NetbookVaio.MyNetwork 
    192.168.1.101   Pentium4.MyNetwork
    192.168.1.102   Tablet.MyNetwork
    
    # special IPv6 addresses
    ::1             localhost ipv6-localhost ipv6-loopback
    
    fe00::0         ipv6-localnet 
    
    ff00::0         ipv6-mcastprefix 
    ff02::1         ipv6-allnodes 
    ff02::2         ipv6-allrouters 
    ff02::3         ipv6-allhosts

  2. #2
    Join Date
    Sep 2012
    Posts
    7,102

    Default Re: Mounting NFS and "clnt_create: RPC: Unknown host"

    Quote Originally Posted by NeverGiveUp01 View Post
    I have a problem with the NFS mount
    accepts only the source path "/"
    if I put the full path does not work
    Use NFS v3, not NFS v4. Or build your export tree accordingly.

    client: UNSUCCESSFUL MOUNTING
    Code:
     mount  -v -t nfs4 Pentium4.MyNetwork:/home/Shared /mnt/Shared.NFS
    mount.nfs4: mount(2): No such file or directory
    client: MOUNTING WORKS FINE
    Code:
    # mount  -vv -t nfs4 Pentium4.MyNetwork:/ /mnt/Shared.NFS
    expoted on server NFS: [Pentium4.MyNetwork]
    Code:
    /home/Shared    192.168.1.0/24(fsid=0,crossmnt,rw,root_squash,sync,no_subtree_check)
    fsid=0 means root of NFS v4 export tree. So server starts pathname resolution at this directory. It is the similar to doing "chroot /home/Shared" before export. What was the reason to add this option when exporting? It is not needed normally.

  3. #3

    Default Re: Mounting NFS and "clnt_create: RPC: Unknown host"

    Hi
    I did not understand the meaning of the "fsid"
    ...now everything works fine !!!!




    thank you very much for the help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •