Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: Opensuse 13.1 high CPU usage when copying to USB flash

  1. #1

    Default Opensuse 13.1 high CPU usage when copying to USB flash

    My Opensuse 13.1 with KDE hangs because of high cpu usage when trying to copy larger files to usb flash drive. I copy files through Dolphin's GUI. Problem is that when copying the whole system becomes choppy until copying is finished. Also copying takes longer than normal. This happens with every usb stick I tested.Could you help me?

  2. #2

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    I tried copying form terminal and the result is the same. I cannot do anything while files are copying. This is not normal. I never had this problem on previous Opensuse releases.

  3. #3

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    I guess nobody had this situation. I still don't know what's causing this bad behavior with usb storage devices. I want to ask of another problem that I also had on OpenSuse 12.3. if I switch to another session and I try to return to previous session, the screen goes black and there's nothing I can do except pressing ctrl+alt+backspace to return to login window. I don't know if it's Opensuse or KDE's fault. But I didn't find an explanation for that either.

  4. #4
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    On 01/06/2014 07:16 AM, Tiberiu OS wrote:
    >
    > My Opensuse 13.1 with KDE hangs because of high cpu usage when trying to
    > copy larger files to usb flash drive. I copy files through Dolphin's
    > GUI. Problem is that when copying the whole system becomes choppy until
    > copying is finished. Also copying takes longer than normal. This happens
    > with every usb stick I tested.Could you help me?
    >


    I am having a similar issue. What file systems are you using? Maybe that
    is the issue.


    --
    Was I helpful? Click that little star so that I can brag about it to my
    invisible friends
    Bring the Penguins Back! https://features.opensuse.org/316767

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,742

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    Could be you are short of /tmp space

    /tmp is now a virtual file system ie resides in memory. If short on memory it will go to cache and be very slow

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    On 2014-01-12 04:16, gogalthorp wrote:
    >
    > Could be you are short of /tmp space
    >
    > /tmp is now a virtual file system ie resides in memory.


    Since when? I have not seen it in none of my 13.1 systems.
    There are some temporary directories in 13.1 which are indeed tmpfs in
    memory, but "/tmp" is not one of them.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  7. #7

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    I have the same issue, fresh install of openSUSE 13.1. Is there any way to fix this ?

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    On 2014-01-12 19:46, calugarar wrote:
    >
    > I have the same issue, fresh install of openSUSE 13.1. Is there any way
    > to fix this ?


    Please run "top" in a terminal to find out which process (or thread) is
    the culprit.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  9. #9

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    Hi, i couldn't even move the mouse so i took a screenshot and the system froze for about 5 minutes. This never happened on opensuse 12.3 or other linux distros. Here you have the pic



  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    On 2014-01-13 00:36, calugarar wrote:
    >
    > Hi, i couldn't even move the mouse so i took a screenshot and the system
    > froze for about 5 minutes. This never happened on opensuse 12.3 or other
    > linux distros. Here you have the pic
    >
    >
    > [image: http://i42.tinypic.com/34s5agk.jpg]


    Well, it is not a process going full cpu. Instead, the interesting
    figure is on the third line, the "93.8 wa", meaning that the cpu is
    waiting from some i/o to occur. It usually means processes waiting for
    disks to finish reading or writing.

    It is then interesting to see that the busy processes (but not by much
    cpu) are mount.ntfs, kio_file, kswapd0. All of them use disk. What
    exactly is happening there, I don't know.

    It could be some disk not responding. For example, if your disk, or the
    sub stick, is bad or has errors, it could cause this. But to block the
    system, I'd guess it be some system partition. I would try use smartctl
    to tests the disks.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •