Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 37

Thread: Opensuse 13.1 high CPU usage when copying to USB flash

  1. #11

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    I tested on 2 computers and the behavior is the same with any usb flash I tried. Also I tried with both fat and ntfs formatted usb flash and the result is the same. There is no problem when copying to hard drives, from ntfs to ntfs or ext4 to ntfs.

  2. #12
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    On 2014-01-13 11:56, Tiberiu OS wrote:
    >
    > I tested on 2 computers and the behavior is the same with any usb flash
    > I tried. Also I tried with both fat and ntfs formatted usb flash and the
    > result is the same. There is no problem when copying to hard drives,
    > from ntfs to ntfs or ext4 to ntfs.


    I have not yet tried copying large files to usb sticks in 13.1, so I
    can't yet say. I'll try in a minute.

    However, copying to ntfs formatted sticks is cpu intensive in Linux.


    Ok, I'm right now coyping 7 GB to an ntfs stick (EMTEC brand, 16 GB). It
    is crawling along at 10 MB/s, and decreasing to 8 sometimes. CPU load is
    under 15%, wait is 70%. Load peaks up to 80% or so. Laptop is
    responsive, but not snappy (it slows down when it needs to read from
    disk). I just fired up libreoffice, it takes longer to start than usual.
    It does in the end, and it appears to work just fine. 3.8 GB copied so
    far, now going at 11MB/s.

    I'm using XFCE, not KDE.

    [...]

    It finished uneventfully.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #13
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    Just a note USB sticks are NOT SSD the erase cycle in all flash memory devices is SLOW. SSD's have a lot of spare flash that they can swap in to speed the process, sticks normal don''t. Flash is usually organized in 100K blocks any change in a block requires an erase cycle on that block. So it soundsl like the stick is thrashing causing the slowdown.

  4. #14

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    My 13.1 openSUSE KDE is on a HP Compaq 6910p dual core, 3 GB RAM, Samsung SSD laptop and i am copying on Kingston 101 DT flash and SanDisk Cruzer Titanium flash drives.

    I didn't have these issues in KDE/XFCE/Gnome openSUSE 12.3/Tumbleweed, neither in other Debian based distros.
    Neither in the past nor in the present.

    So i am thinking that maybe something is wrong in openSUSE 13.1.

    Copying large files (+1 GB )completes successfully only that the system freezes and it takes longer to copy the files to the flash drive. Small files (~170 MB) don't seem to affect the file transfer.

  5. #15
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    On 2014-01-13 21:06, calugarar wrote:

    > So i am thinking that maybe something is wrong in openSUSE 13.1.
    >
    > Copying large files (+1 GB )completes successfully only that the system
    > freezes and it takes longer to copy the files to the flash drive. Small
    > files (~170 MB) don't seem to affect the file transfer.


    Not in my 13.1...

    Can you try another desktop? Or raw text mode?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  6. #16
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    On 01/13/2014 03:06 PM, calugarar wrote:
    >
    > My 13.1 openSUSE KDE is on a HP Compaq 6910p dual core, 3 GB RAM,
    > Samsung SSD laptop and i am copying on Kingston 101 DT flash and SanDisk
    > Cruzer Titanium flash drives.
    >


    I have a 955BE processor with Kingston HyperX 120GB SSD and a WD 1TB
    Black as my two drives. 13.1 with kde here.

    > I didn't have these issues in KDE/XFCE/Gnome openSUSE 12.3/Tumbleweed,
    > neither in other Debian based distros.
    > Neither in the past nor in the present.
    >
    > So i am thinking that maybe something is wrong in openSUSE 13.1.
    >

    Same here, I never noticed this in Debian Jessie (gnome)

    > Copying large files (+1 GB )completes successfully only that the system
    > freezes and it takes longer to copy the files to the flash drive. Small
    > files (~170 MB) don't seem to affect the file transfer.
    >


    What happens on my system is that I get a lot of the disk sleep and it
    happens only if the data is copied between drives. I cant even type
    things into a terminal because all the I/O is just very sluggish.

    --
    Was I helpful? Click that little star so that I can brag about it to my
    invisible friends
    Bring the Penguins Back! https://features.opensuse.org/316767

  7. #17
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    On 2014-01-13 22:07, alanbortu wrote:
    >
    > What happens on my system is that I get a lot of the disk sleep and it
    > happens only if the data is copied between drives. I cant even type
    > things into a terminal because all the I/O is just very sluggish.


    I don't see any of that.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  8. #18

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    I can't quit to text based only atm.

    Could it have something to do with systems on SSD's ?

  9. #19
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    On 2014-01-13 23:16, calugarar wrote:
    >
    > I can't quit to text based only atm.


    Just type [Ctrl][Alt][F1], login, and do the test. You can type any time
    [Ctrl][Alt][F7] to return to your running KDE session.

    > Could it have something to do with systems on SSD's ?


    No idea...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  10. #20
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: Opensuse 13.1 high CPU usage when copying to USB flash

    On 01/13/2014 06:03 PM, Carlos E. R. wrote:
    > On 2014-01-13 23:16, calugarar wrote:
    >>
    >> I can't quit to text based only atm.

    >
    > Just type [Ctrl][Alt][F1], login, and do the test. You can type any time
    > [Ctrl][Alt][F7] to return to your running KDE session.
    >


    Already tried this, its still laggy. Typing my username in is fine but
    as soon as I press enter it takes forever for the password prompt to
    show up.


    --
    Was I helpful? Click that little star so that I can brag about it to my
    invisible friends
    Bring the Penguins Back! https://features.opensuse.org/316767

Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •