Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Libreoffice is seriously messed up in OS 13.1 KDE

  1. #1

    Default Libreoffice is seriously messed up in OS 13.1 KDE

    Hi All,

    I have a real problem with Libreoffice is Opensuse 13.1 KDE. Most of the time the text for menus, column and row numbers is just garbled -it looks awful.

    I have installed the nvidia driver for this dell precision 380 (x11-video-nvidiaG02), libreoffice-kde4 was installed along with libreoffice. I tried removing libreoffice-kde4 and using libreoffice-gnome but that made no difference. I am using the qtcurve theme for gtk2 and kde4. Here is a picture of how it looks:



    Any ideas on how I can fix this?

    Cheers for any help.

  2. #2

    Default Re: Libreoffice is seriously messed up in OS 13.1 KDE

    Quote Originally Posted by londondaveuk View Post
    Any ideas on how I can fix this?
    Hm, are you sure the KDE4 integration was really working? If you have "ibus" installed, it is disabled. In that case I would suggest to uninstall "ibus", install "libreoffice-kde4" again and see if the fonts are better now.

    Not sure if that helps though...

    You don't have font problems with any other program, right?

    Maybe try to change the font settings in LibreOffice's "View" options ("Use System Font for User Interface", "Font Antialiasing").

  3. #3

    Default Re: Libreoffice is seriously messed up in OS 13.1 KDE

    Thanks wolfi323,

    These are the ibus packages installed at the moment:

    ibus-1.5.4-8.1.i586
    libibus-1_0-5-1.5.4-8.1.i586

    Is it safe to remove ibus completely? I thought it was needed for some types of input?

    Cheers

  4. #4
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Libreoffice is seriously messed up in OS 13.1 KDE

    Quote Originally Posted by londondaveuk View Post
    Thanks wolfi323,

    These are the ibus packages installed at the moment:

    ibus-1.5.4-8.1.i586
    libibus-1_0-5-1.5.4-8.1.i586

    Is it safe to remove ibus completely? I thought it was needed for some types of input?

    Cheers
    That is a really good qustion Londondaveuk, I too have had these font hiccups before and never heard anything about ibus at the time.
    Wolfi323, can you tell us how these things might be related?
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  5. #5

    Default Re: Libreoffice is seriously messed up in OS 13.1 KDE

    Quote Originally Posted by anika200 View Post
    That is a really good qustion Londondaveuk, I too have had these font hiccups before and never heard anything about ibus at the time.
    Wolfi323, can you tell us how these things might be related?
    The "ibus" package effectively disables the KDE4 integration. (https://bugzilla.novell.com/show_bug.cgi?id=851982)
    So you have to uninstall it to actually make that integration work. I don't know if that would fix your problems, but at least it _could_ make a difference.

    And just remove the package "ibus" (and its dependencies). libibus is needed by some other packages (on my systen that's gnome-control-center, gnome-settings-daemon and plasma-addons).

    ibus is only needed for being able to input some asian characters. (Chinese, Korean, ...) If you want to do that, you shouldn't uninstall it of course, although there are alternatives like fcitx.
    See also: https://en.wikipedia.org/wiki/Intelligent_Input_Bus

  6. #6

    Default Re: Libreoffice is seriously messed up in OS 13.1 KDE

    Thanks wolfi & anika,

    I removed the ibus package (with deps) and set the libreoffice theme to oxygen and it seems to have stabilised- if I use the galaxy theme I get the font problems in the picture above?

    There seems to be something messed up with libreoffice under KDE4.

    Thanks for your help.

  7. #7

    Default Re: Libreoffice is seriously messed up in OS 13.1 KDE

    Quote Originally Posted by londondaveuk View Post
    I removed the ibus package (with deps) and set the libreoffice theme to oxygen and it seems to have stabilised- if I use the galaxy theme I get the font problems in the picture above?
    Could you please tell me where you set the theme?

    I can only find the "Symbol size and Symbol style" setting in "View". (could be named slightly different, I'm using it in german)
    The symbol style should be set to "Automatic" by default and use oxygen on KDE. But even if I explicitely set it to galaxy, there's absolutely no change at all regarding the fonts (the option's name wouldn't imply it anyway).

    OTOH, there's the option "Use system font for the user interface" right below that as I already mentioned. If that is enabled (which it is by default), LO should just use your KDE's font settings, not anything from any theme. Here the kde4 integration might come into play of course.
    But even if I disable that and select the symbol style to galaxy, I can't reproduce your problem here.

  8. #8
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,620

    Default Re: Libreoffice is seriously messed up in OS 13.1 KDE

    In Tools>Options you can apply a Firefox Persona under Personalization but otherwise you can only change the icon style under View and the Colours under Appearance.

  9. #9

    Default Re: Libreoffice is seriously messed up in OS 13.1 KDE

    Hi All,

    After my last post i started libreoffice and had mangled fonts again, so I looked for a fix. This is a common problem if you use the nvidia graphics driver which is pretty much essential in Opensuse 13.1.

    The solution is:

    1. Start up system-settings (for kde), go to application appearance -> fonts
    2. In 'use anti-aliasing', click on configure and un-tick subpixel hinting (if ticked), set anti-aliasing to disabled and click apply
    3. In 'use anti-aliasing' reset to enable and click apply


    That should be it, for some reason this works, don't ask me why - it worked for me.

    To set the theme in libreoffice, go to view in options and click on the drop down list with a theme name, it's under 'icon size and style' - I am using galaxy again without problems.

  10. #10

    Default Re: Libreoffice is seriously messed up in OS 13.1 KDE

    Quote Originally Posted by londondaveuk View Post
    To set the theme in libreoffice, go to view in options and click on the drop down list with a theme name, it's under 'icon size and style' - I am using galaxy again without problems.
    Right, that's what I found as well as mentioned.
    But that should only influence the look of the icons, not anything font related.

    Anyway, good to hear that you found a solution for your problem.

    I guess the reason why your procedure works at all is because it creates a fixed font configuration in ~/.config/font-config, which overrides the standard system defaults.
    This is already created even when you just enter that settings dialog though, so I'd guess that not all of your steps would have really been necessary.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •