Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: No sound after upgrade to 13.1

  1. #1
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    69

    Unhappy No sound after upgrade to 13.1

    Hi,

    after upgrading from 12.3 to 13.1 I can't get any sound in KDE.

    Steam sounds fine and I can get sound in Skype and Spotify if I disable Pulse Audio in Yast / Sound.

    If I open Personal Settings / Sound & Multimedia / Sound System, I get the following error:

    Unable to start the sound server to retrieve possible sound I/O methods.
    Only automatic detection will be available.
    Anyone knows what's wrong?

    TIA,
    Gunnar

  2. #2

    Default Re: No sound after upgrade to 13.1

    I don't know if it's related. But I lost all sound after the update yesterday (It's been a week since the last update, I also had to reinstall my ati driver to fix the black screen after the update yesterday).

    In KDE settings, multimedia, the only way I can make my pc have sound is to change conncector from "analog output" to "speaker".

    Something's broken after yesterday's update??

  3. #3

    Default Re: No sound after upgrade to 13.1

    Quote Originally Posted by bonedriven View Post
    I don't know if it's related. But I lost all sound after the update yesterday (It's been a week since the last update, I also had to reinstall my ati driver to fix the black screen after the update yesterday).

    In KDE settings, multimedia, the only way I can make my pc have sound is to change conncector from "analog output" to "speaker".

    Something's broken after yesterday's update??
    What update?
    There was _no_ official update for 13.1 since Jan. 3rd...

    Some packages on Packman were updated, but I doubt those would cause your problems. And they definitely didn't cause your ati driver problem.

    So, what repos are you using?
    Code:
    zypper lr -d
    Check in YaST/zypper's history (and Apper's as well) which packages got installed and try to revert them if possible.
    ("rpm -qa --last | less" will also give you a list of all installed packages sorted by the time they have been installed)

    @gugrim:
    Your problem seems to be related to KDE's phonon.
    Which phonon packages do you have installed? Maybe not all got updated for some reason?
    Code:
    rpm -qa | grep phonon

  4. #4
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    69

    Default Re: No sound after upgrade to 13.1

    This is the output from rpm -qa | grep phonon:

    phonon-backend-vlc-0.7.0-9.1.x86_64
    libphonon4-4.7.0-4.1.x86_64
    phonon-backend-gstreamer-0_10-4.7.0-2.8.1.x86_64
    python-kde4-phonon-4.11.3-42.4.x86_64
    No newer version available according to Yast / Software Management

  5. #5
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    69

    Default Re: No sound after upgrade to 13.1

    Also, sound in Windows running in VMware works fine.

  6. #6

    Default Re: No sound after upgrade to 13.1

    Quote Originally Posted by gugrim View Post
    Also, sound in Windows running in VMware works fine.
    Yeah, right. Everything except KDE apparently (i.e. everything _not_ using Phonon).

    Your packages seem to be ok.

    Is VLC itself working?
    Maybe that's the cause (phonon-backend-vlc has a higher priority than gstreamer-backend-gstreamer-0_10).

    PS: Maybe VLC is configured to use PulseAudio? (that could explain the "Unable to start the sound server" message when PulseAudio is disabled)
    Check that in its settings, or try to remove/rename ~/.config/vlc/ (this will of course reset all VLC settings to their default).

  7. #7
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    69

    Default Re: No sound after upgrade to 13.1

    Quote Originally Posted by wolfi323 View Post
    Is VLC itself working?
    Maybe that's the cause (phonon-backend-vlc has a higher priority than gstreamer-backend-gstreamer-0_10).

    PS: Maybe VLC is configured to use PulseAudio? (that could explain the "Unable to start the sound server" message when PulseAudio is disabled)
    Check that in its settings, or try to remove/rename ~/.config/vlc/ (this will of course reset all VLC settings to their default).
    Yes, VLC works and audio output is set to Automatic.

    Do you know if Personal Settings' failure is logged somewhere? Maybe that could give a clue.

  8. #8
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    69

    Default Re: No sound after upgrade to 13.1

    Also, I tried setting VLC to use ALSA explicitly but that didn't change anything. Personal Settings / Sound System still fails.

  9. #9
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    69

    Default Re: No sound after upgrade to 13.1

    Also tried reactivating PulseAudio in Yast and then setting this as VLC's explicit output. VLC still works but nothing else does with PA enabled.

  10. #10
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    69

    Default Re: No sound after upgrade to 13.1

    OK, you can forget about the "Personal Settings" related stuff. After the upgrade, my start menu contained "Personal Settings" from KDE 3.5. No idea why but I used it when trying to get my sound started. I have now hidden it so I won't do that mistake again. With "Configure Desktop" I could correct my messed up device list. My HDMI card, which is not connected to anything, had been set as the preferred device. Now I have sound in KDE.

    No sound from Skype though, although it uses Pulse (the only option).

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •