Results 1 to 4 of 4

Thread: Fedora not showing up in bootloader

  1. #1

    Default Fedora not showing up in bootloader

    Hello,

    I partitioned my hard disks into different compartments after installing Windows 8. I then installed Fedora 20 in one of the empty partitions. I installed OpenSuse (GNOME) in yet another partition and made sure it wasn't installed in either the Fedora or Windows partition. The installation was successful but now, Fedora is not showing up in the bootloader (GRUB 2). How do I make GRUB see the Fedora OS?

    Thank you.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,675
    Blog Entries
    3

    Default Re: Fedora not showing up in bootloader

    Quote Originally Posted by aayekeen View Post
    How do I make GRUB see the Fedora OS?
    I have not tried Fedora 20, so I'm not sure why that is happening.

    One option would be to manually enter grub boot commands in "/etc/grub.d/40_custom" (on your opensuse install). Then, when grub.cfg is rebuilt, it will contain those commands.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Fedora not showing up in bootloader

    Mount the fedora root partition in openSUSE
    then run

    Code:
    su -
    grub2-mkconfig -o /boot/grub2/grub.cfg
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Sep 2012
    Posts
    7,100

    Default Re: Fedora not showing up in bootloader

    Quote Originally Posted by caf4926 View Post
    Mount the fedora root partition in openSUSE
    Should not be needed. But you need to enable "Probe for foreign OS "in yast bootloader.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •