Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Booting installation USB on UEFI and RAID0

  1. #1

    Default Booting installation USB on UEFI and RAID0

    I'm trying to dual-boot Windows 8 and OpenSuse 13.1 on an Acer S7 191, which has 2 64GB SSD on RAID0. I downloaded the 13.1 Gnome (the DVD wouldn't fit in my flash drive) and used ImageUSB (Tools for OSForensics - ImageUSB - Write an image to multiple USB Flash Drives) to transfer it, as OpenSuse's official ImageWrite didn't work on any PC/flash drive I tried. Now the flash drive is separated between a data and a boot partition. In the boot partition, there's a EFI folder.

    The problem is that when I try to boot the installation, the Acer logo just flickers continuously until I remove the flash drive (then it boots Windows). Even simply trying to open the boot menu causes the same behaviour. Of course I disabled Secure Boot and tried changing boot order and even different distros, but it didn't work. I did manage to install OpenSuse on Legacy (BIOS) mode, but I couldn't boot it afterwards (maybe because of RAID0).

    Is it some sort of stupid "design" decision Acer took (this notebook has its fair share of quirks), or am I doing something wrong?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Booting installation USB on UEFI and RAID0

    Quote Originally Posted by luizedu View Post
    The problem is that when I try to boot the installation, the Acer logo just flickers continuously until I remove the flash drive (then it boots Windows).
    I usually try to help people with UEFI problems. But I admit that you have me stumped on this one.

    On my Dell system, I hit F12 during boot, and the BIOS gives me a boot menu where I can select USB, DVD or a system (such as Windows 8) that is installed on the internal drive. But then, I have no experience with ACER.

    Quote Originally Posted by luizedu View Post
    Now the flash drive is separated between a data and a boot partition. In the boot partition, there's a EFI folder.
    Yes, that's normal. Here's the info for my live KDE installer (on USB):
    Code:
    # fdisk -l /dev/sdd
    
    Disk /dev/sdd: 4004 MB, 4004511744 bytes, 7821312 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk label type: dos
    Disk identifier: 0xa19f8ba9
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdd1            4084       12275        4096   ef  EFI (FAT-12/16/32)
    /dev/sdd2   *       12276     1232895      610310   83  Linux
    /dev/sdd3         1232896     7819264     3293184+  83  Linux
    The third partition (sdd3) is the hybrid partition added when I booted the live system (for persistent changes).

    Yours should look similar, though the partition sizes might be different. And you won't have that third partition since you never actually got it booted.

    Quote Originally Posted by luizedu View Post
    Is it some sort of stupid "design" decision Acer took (this notebook has its fair share of quirks), or am I doing something wrong?
    Hard to say.

    Suggestion 1: Boot into Windows. Plug in the USB while still running Windows. Then see if it works on reboot.

    Microsoft has mandated that manufacturers use a fast start approach. The BIOS is not supposed to initialize USB devices, but leave that to the operating system. Dell does that sensibly -- if I boot from USB, then it initializes the USB devices. But apparently some manufacturers haven't done it that way. So, rebooting from Windows might get the devices initialized for the warm reboot (I hope).

    Suggestion 2: Look into BIOS settings, to see if there is a way of disabling fast startup. Note that there is also a fast start setting in Windows 8, but that's unrelated (though also wise to turn off).

    (added in edit -- oops; that "fdisk" output is from the live repair system rather than the live KDE)
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,352
    Blog Entries
    15

    Default Re: Booting installation USB on UEFI and RAID0

    On Sat 04 Jan 2014 09:36:02 PM CST, luizedu wrote:


    I'm trying to dual-boot Windows 8 and OpenSuse 13.1 on an Acer S7 191,
    which has 2 64GB SSD on RAID0. I downloaded the 13.1 Gnome (the DVD
    wouldn't fit in my flash drive) and used ImageUSB ('Tools for
    OSForensics - ImageUSB - Write an image to multiple USB Flash Drives'
    (http://www.osforensics.com/tools/write-usb-images.html)) to transfer
    it, as OpenSuse's official ImageWrite didn't work on any PC/flash drive
    I tried. Now the flash drive is separated between a data and a boot
    partition. In the boot partition, there's a EFI folder.

    The problem is that when I try to boot the installation, the Acer logo
    just flickers continuously until I remove the flash drive (then it boots
    Windows). Even simply trying to open the boot menu causes the same
    behaviour. Of course I disabled Secure Boot and tried changing boot
    order and even different distros, but it didn't work. I did manage to
    install OpenSuse on Legacy (BIOS) mode, but I couldn't boot it
    afterwards (maybe because of RAID0).

    Is it some sort of stupid "design" decision Acer took (this notebook has
    its fair share of quirks), or am I doing something wrong?


    Hi
    Can you download the 13.1 openSUSE rescue CD (~602MB) and install that
    onto a USB device and try booting, unetbootin should work, else just
    use dd? This is EFI/Secure boot ready.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.6-4-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  4. #4

    Default Re: Booting installation USB on UEFI and RAID0

    Thanks for the replies. I tried both of nrickert's suggestions, but neither worked. And there's no fast boot option on the BIOS, just Secure Boot. I also tried booting the Rescue CD (x64, used unetbootin) but the same thing happened.

    This thread Aspire S7 can't install ubuntu suggests disabling Raid, but apparently the OP had no problem booting the installer.

    Is it possible to install OpenSuse while on Legacy mode with an EFI bootloader so I can later change it back to UEFI?

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Booting installation USB on UEFI and RAID0

    Then you would not be able to boot Windows if it is installed under UEFI

    The problem is undoubtedly RAID. I assume you are using FAKE RAID (ie BIOS assisted) If this is a new FAKE RAID chip set then chances are that the details have not filtered down to us poor Linux users.

    If you are using true hardware RAID ( an installed true hardware RAID card) then it would not be a problem

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Booting installation USB on UEFI and RAID0

    Quote Originally Posted by luizedu View Post
    Is it possible to install OpenSuse while on Legacy mode with an EFI bootloader so I can later change it back to UEFI?
    Yes. But to change it back, you need to be able to boot some linux system in UEFI mode, so as to have access to the "efibootmgr" command. So finding a USB or DVD or CD or similar that you can boot in UEFI mode is the key to solving your problem.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7

    Default Re: Booting installation USB on UEFI and RAID0

    Quote Originally Posted by gogalthorp View Post
    Then you would not be able to boot Windows if it is installed under UEFI

    The problem is undoubtedly RAID. I assume you are using FAKE RAID (ie BIOS assisted) If this is a new FAKE RAID chip set then chances are that the details have not filtered down to us poor Linux users.

    If you are using true hardware RAID ( an installed true hardware RAID card) then it would not be a problem

    I'm not sure what kind of RAID it is, and I couldn't find anything conclusive online, but I suppose it's hardware based, at least Intel RST software says it's RAID0 (but I know next to nothing about this topic).

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Booting installation USB on UEFI and RAID0

    If it is just a chip on the MB then it is most likely FAKE RAID. FAKE RAID does not incorporate a full RAID model and relies on the OS to actually do most of the work. The problem is that these chips are propritary and the interface is ill defined and not truly standard

    Now just for your information RAID 0 is the most dangerous RAID type. Yes it is fast but what it does is write every other sector to a different drive. If you lose either drive for any reason you have lost your data. There is almost zero chance to recover.

  9. #9

    Default Re: Booting installation USB on UEFI and RAID0

    Window's Device Manager says it's an Intel Raid0 Volume, is that an indication of true Raid?. And yes, I'm aware of the danger that comes with this configuration, but I keep most of my important data on the cloud and have backups on other PCs, so that not very much an issue for me.

    If what's preventing me from booting OpenSuse's installer is indeed the RAID configuration, is it possible to just disable it, install the OS and reenable it, or would that mess everything up?

    Or maybe I should try asking Acer about it, since it seems this isn't a Linux-related problem.

  10. #10
    Join Date
    Sep 2012
    Posts
    7,106

    Default Re: Booting installation USB on UEFI and RAID0

    Quote Originally Posted by nrickert View Post
    Yes. But to change it back, you need to be able to boot some linux system in UEFI mode, so as to have access to the "efibootmgr" command.
    It is possible to a) perform "grub-install --target x86_64-efi" on a legacy BIOS system. It will fail on efibootmgr step - just ignore it (newer grub adds --no-nvram option). b) boot into EFI Shell and manually start resulting grubx64.efi.

    I understand that not every vendor provides a (easy) way to boot into EFI Shell though.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •