Results 1 to 4 of 4

Thread: Vdieo playback problem.

  1. #1
    Join Date
    Dec 2013
    Location
    Patras, Greece.
    Posts
    66

    Question Vdieo playback problem.

    Hi!

    I have problem playing my video files (Open SUSE x64 v.13.1 with KDE).
    VLC says that can't play MPGA format (and sometimes MPGV), no matter what format the video has (matroska, avi, flv etc.).
    Dragon also can't play a thing.
    Kaffeine can play only a few, after installing restricted codecs.

    Now what???
    TIA!
    My best wishes, for a happy new year!!!

  2. #2

    Default Re: Vdieo playback problem.

    Quote Originally Posted by Thalassius View Post
    VLC says that can't play MPGA format (and sometimes MPGV), no matter what format the video has (matroska, avi, flv etc.).
    Install the package "vlc-codecs".

    Dragon also can't play a thing.
    Dragon uses phonon, so depending on whether you use phonon-backend-vlc or phonon-backend-gstreamer, you need either "vlc-codecs" or the gstreamer-0_10-plugins-* packages from Packman.

    Kaffeine can play only a few, after installing restricted codecs.
    For Kaffeine you need "libxine2-codecs".

    How did you install "restricted codecs"?

    Could you post your repo list please?
    Code:
    zypper lr -d

  3. #3
    Join Date
    Dec 2013
    Location
    Patras, Greece.
    Posts
    66

    Thumbs up Απ: Vdieo playback problem.

    1) Ooops! My fault!!!
    I didn't installed vlc-codecs.
    I though installing vlc would automatically install it's codecs. I didn't show this isn't the case.
    After installing it, all players working properly.


    2) Both backends are present and the videolan's is active. I suppose that's why Dragon didn't worked at the firt place.

    3) Her'e the output:

    Code:
    giorgos@linux-khvd:~> zypper lr -d
    #  | Ψευδώνυμο                            | Όνομα                              | Ενεργοποιημένο | Ανανέωση | Προτεραιότητα | Τύπος  | URI                                                                              | Υπηρεσία
    ---+--------------------------------------+------------------------------------+----------------+----------+---------------+--------+----------------------------------------------------------------------------------+---------
     1 | Packman Repository                   | Packman Repository                 | Ναι            | Ναι      |   99          | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/                         |         
     2 | home:ecsos                           | home:ecsos                         | Ναι            | Ναι      |   99          | rpm-md | http://download.opensuse.org/repositories/home:/ecsos/openSUSE_13.1/             |         
     3 | libdvdcss repository                 | libdvdcss repository               | Ναι            | Ναι      |   99          | rpm-md | http://opensuse-guide.org/repo/13.1/                                             |         
     4 | nVidia Graphics Drivers              | nVidia Graphics Drivers            | Ναι            | Ναι      |   99          | rpm-md | http://download.nvidia.com/opensuse/13.1/                                        |         
     5 | openSUSE-13.1-1.10                   | openSUSE-13.1-1.10                 | Ναι            | Όχι      |   99          | yast2  | cd:///?devices=/dev/disk/by-id/ata-ATAPI_iHAS124_D_3524552_207241503257,/dev/sr0 |         
     6 | openSUSE-13.1-Language-Add-on_13.1-0 | openSUSE 13.1 Language Add on      | Ναι            | Όχι      |   99          | yast2  | cd:///                                                                           |         
     7 | repo-debug                           | openSUSE-13.1-Debug                | Όχι            | Ναι      |   99          | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/                   |         
     8 | repo-debug-update                    | openSUSE-13.1-Update-Debug         | Όχι            | Ναι      |   99          | NONE   | http://download.opensuse.org/debug/update/13.1/                                  |         
     9 | repo-debug-update-non-oss            | openSUSE-13.1-Update-Debug-Non-Oss | Όχι            | Ναι      |   99          | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/                          |         
    10 | repo-non-oss                         | openSUSE-13.1-Non-Oss              | Ναι            | Ναι      |   99          | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/                     |         
    11 | repo-oss                             | openSUSE-13.1-Oss                  | Ναι            | Ναι      |   99          | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                         |         
    12 | repo-source                          | openSUSE-13.1-Source               | Όχι            | Ναι      |   99          | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/                  |         
    13 | repo-update                          | openSUSE-13.1-Update               | Ναι            | Ναι      |   99          | rpm-md | http://download.opensuse.org/update/13.1/                                        |         
    14 | repo-update-non-oss                  | openSUSE-13.1-Update-Non-Oss       | Ναι            | Ναι      |   99          | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                                |         
    giorgos@linux-khvd:~>
    THANKS A MILLION!!!

  4. #4

    Default Re: Vdieo playback problem.

    Quote Originally Posted by Thalassius View Post
    1) Ooops! My fault!!!
    I didn't installed vlc-codecs.
    I though installing vlc would automatically install it's codecs. I didn't show this isn't the case.
    Actually the "vlc-codecs" package does suggest to be installed automatically. But that information is missing in the Packman repo metadata.

    After installing it, all players working properly.
    Great!


    2) Both backends are present and the videolan's is active. I suppose that's why Dragon didn't worked at the firt place.
    Yes.

    3) Her'e the output:
    That's ok.
    I mainly asked for this to make sure you don't have Packman _and_ the VideoLAN repo, as that can lead to problems.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •