Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: No graphical login

  1. #1

    Unhappy No graphical login

    Hey guys,

    I have got the following problem:
    If I bot my system it doesn't start the normal graphical login with gdm or kdm I tested both(only one was installed at a time and enabled). I lokked into my xinitrc but there is the right display manager. I can normally login via the console and then start gnome or kde with a simple startx or gdm or whatever but it doesn't start when I nromally boot my system.

    I hope you can help me guys.

    Thanks in advance

  2. #2

    Default Re: No graphical login

    Quote Originally Posted by Sebi55 View Post
    I have got the following problem:
    If I bot my system it doesn't start the normal graphical login with gdm or kdm I tested both(only one was installed at a time and enabled). I lokked into my xinitrc but there is the right display manager. I can normally login via the console and then start gnome or kde with a simple startx or gdm or whatever but it doesn't start when I nromally boot my system.
    Is this about openSUSE? And which version?

    On openSUSE the display manager is configured in /etc/sysconfig/displaymanager, not xinitrc. (isn't that executed for the user on login/when calling startx? So it wouldn't work anyway, since the display manager has to be started by root)

    You would start the configured display manager with "systemctl start xdm.service" or "rcxdm start" (depending on your openSUSE version), but it should be started automatically if you boot to runlevel 5.
    So maybe your system is set to boot to runlevel 3 by default? Try "init 5" to start the graphical system", does this work?

  3. #3

    Default Re: No graphical login

    Quote Originally Posted by wolfi323 View Post
    Is this about openSUSE? And which version?

    On openSUSE the display manager is configured in /etc/sysconfig/displaymanager, not xinitrc. (isn't that executed for the user on login/when calling startx? So it wouldn't work anyway, since the display manager has to be started by root)

    You would start the configured display manager with "systemctl start xdm.service" or "rcxdm start" (depending on your openSUSE version), but it should be started automatically if you boot to runlevel 5.
    So maybe your system is set to boot to runlevel 3 by default? Try "init 5" to start the graphical system", does this work?
    I have got openSUSE 13.1 installed.

    Oh ok. Gdm is set as displaymanager in sysconfig I just lokked into it. I can use startx to start gnome for example but not everything works.

    You are right this works. I have to use sudo systemctl start xdm.service to get everything running and it works perfectly. But when I reboot it again doesn't load the display manager.

    init 5 doesn't work. I have to type sudo /sbin/init 5 in order to work. It hangs at loading gnome then. If i type sudo init 5 it says command not found.

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: No graphical login

    On 2014-01-04 15:06, Sebi55 wrote:
    > init 5 doesn't work. I have to type sudo /sbin/init 5 in order to work.
    > It hangs at loading gnome then. If i type sudo init 5 it says command
    > not found.


    It has to be run as root. Sudo might not work properly for this.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" (Elessar))

  5. #5

    Default Re: No graphical login

    Quote Originally Posted by robin_listas View Post
    On 2014-01-04 15:06, Sebi55 wrote:
    > init 5 doesn't work. I have to type sudo /sbin/init 5 in order to work.
    > It hangs at loading gnome then. If i type sudo init 5 it says command
    > not found.


    It has to be run as root. Sudo might not work properly for this.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" (Elessar))
    I know. My question is why does openSUSE not start in graphical mode? sudo systemctl start xdm.service works but it doesn't start a boot.

  6. #6

    Default Re: No graphical login

    Quote Originally Posted by Sebi55 View Post
    I know. MY question is why does openSUSE not start in graphical mode? sudo systemctl start xdm.service works but it doesn't start a boot.
    As I said already. Maybe your system is setup to boot to runlevel 3 by default. You can change this in YaST->System->Services Manager.

    And please post the output of:
    Code:
    systemctl get-default
    and
    Code:
    systemctl status xdm.service

  7. #7

    Default Re: No graphical login

    Quote Originally Posted by wolfi323 View Post
    As I said already. Maybe your system is setup to boot to runlevel 3 by default. You can change this in YaST->System->Services Manager.

    And please post the output of:
    Code:
    systemctl get-default
    and
    Code:
    systemctl status xdm.service
    I did the following: I started my system, started gnome with sudo systemctl start xdm.service, went to services manager (Runlevel) and xdm was enabled and active there. Or do I need to look at another service?

    Output of systemctl get-default:
    Code:
    graphical.target
    Output of systemctl status xdm.service:
    Code:
     Loaded: loaded (/etc/init.d/xdm)
       Active: active (running) since Sat 2014-01-04 13:50:53 UTC; 5min ago
      Process: 3846 ExecStart=/etc/init.d/xdm start (code=exited, status=0/SUCCESS)
       CGroup: /system.slice/xdm.service
               ├─3877 /usr/sbin/gdm
               ├─3880 /usr/lib/gdm/gdm-simple-slave --display-id /org/gnome/Displ...
               └─3886 /usr/bin/Xorg :0 -background none -verbose -auth /run/gdm/a...
    If I dont start the xdm.serivce the output of systemctl status xdm.service is loaded but inactive(dead)

  8. #8

    Default Re: No graphical login

    Quote Originally Posted by Sebi55 View Post
    I did the following: I started my system, started gnome with sudo systemctl start xdm.service, went to services manager and xdm was enabled and active there. Or do I need to look at another service?
    No, that should be fine.

    Output of systemctl get-default:
    Code:
    graphical.target
    That's fine as well.

    So, to recap, the login screen does not show up automatically on boot, but does when you run "sudo systemctl start xdm.service" manually?
    Sounds like some race condition then.

    Could you run and post the output of "sudo systemctl status xdm.service" in text mode on the failed boot before you start it manually? (maybe redirect the output to a file with "> xxx.txt" to be able to post it)

    You could also try to set "kdm" or "xdm" as display manager in /etc/sysconfig/displaymanager, maybe one of those would work?

    Or try to disable plymouth (the boot splash) by adding "plymouth.enable=0" to the boot options. Does the DM start then automatically?

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: No graphical login

    And your videocard is?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Default Re: No graphical login

    Quote Originally Posted by wolfi323 View Post
    No, that should be fine.


    That's fine as well.

    So, to recap, the login screen does not show up automatically on boot, but does when you run "sudo systemctl start xdm.service" manually?

    Could you run and post the output of "sudo systemctl status xdm.service" in text mode on the failed boot before you start it manually? (maybe redirect the output to a file with "> xxx.txt" to be able to post it)

    You could also try to set "kdm" or "xdm" as display manager in /etc/sysconfig/displaymanager, maybe one of those would work?

    Or try to disable plymouth (the boot splash) by adding "plymouth.enable=0" to the boot options. Does the DM start then automatically?

    If I do sudo systemctl start xdm.service it automatically logs me in but I think this is because I said that I want to be logged in automatically.
    I just type it here:

    Code:
    xdm.service - LSB: X Display Manager
                  Loaded: loaded(/etc/init.d/xdm)
                  Active: inactive (dead)
    I also tried this but it didn't work also.
    I booted with plymouth uninstalled completely didn't change anything.

    It is definitly not a video card problem because why should it start gnome if I type to start it but not at boot automatically?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •