Results 1 to 8 of 8

Thread: sudo funktioniert nicht mehr korrekt

  1. #1

    Unhappy sudo funktioniert nicht mehr korrekt

    Hallo!
    Wenn ich Software installieren will, fragt mich das System (openSUSE13.1) nach den Systemverwalterrechten.
    Wenn ich hier das Passwort von root eingebe, funktioniert es nicht (Zugriff verweigert).

    Führe ich den Befehl sudo /sbin/yast2 --install von der Konsole aus, startet das Programm brav im Textmodus!
    Apper und PackageKit habe ich bereits neu installiert.
    Die Rechte für su sehen so aus:
    Hrodhulf@MyHome:/usr/bin> dir su
    -rwsr-xr-x 1 Hrodhulf users 31744 9. Okt 15:07 su

    Wie kann ch die Softwareverwaltung wieder zum Laufen bringen?

    Hrodhulf

  2. #2

    Default Re: sudo funktioniert nicht mehr korrekt

    Quote Originally Posted by Hrodhulf View Post
    Hallo!
    Wenn ich Software installieren will, fragt mich das System (openSUSE13.1) nach den Systemverwalterrechten.
    Wenn ich hier das Passwort von root eingebe, funktioniert es nicht (Zugriff verweigert).

    Führe ich den Befehl sudo /sbin/yast2 --install von der Konsole aus, startet das Programm brav im Textmodus!
    Apper und PackageKit habe ich bereits neu installiert.
    Die Rechte für su sehen so aus:
    Hrodhulf@MyHome:/usr/bin> dir su
    -rwsr-xr-x 1 Hrodhulf users 31744 9. Okt 15:07 su

    Wie kann ch die Softwareverwaltung wieder zum Laufen bringen?
    Wieso gehört "su" dem Benutzer Hrodulf:users? Das sollte root:root sein! Wie soll es denn sonst root Rechte erlangen?
    Code:
    dir /usr/bin/su
    -rwsr-xr-x 1 root root 31744  9. Okt 15:07 /usr/bin/su
    Wenn ich mein /usr/bin/su meinem Benutzer zuteile, funktionierts auch nicht, also wird das vermutlich dein Problem sein.
    Code:
    wolfi@amiga:~/Desktop> sudo chown wolfi: /usr/bin/su
    root's password:
    wolfi@amiga:~/Desktop> dir /usr/bin/su
    -rwxr-xr-x 1 wolfi users 31744  9. Okt 15:07 /usr/bin/su
    wolfi@amiga:~/Desktop> su
    Passwort: 
    su: Fehler bei Authentifizierung
    Ich würde vorschlagen du rufst folgendes in einer Konsole auf, dann sollten die Rechte aller System-dateien auf die korrekten Werte gesetzt werden:
    Code:
    sudo /usr/bin/chkstat --system

  3. #3

    Default Re: sudo funktioniert nicht mehr korrekt

    Quote Originally Posted by wolfi323 View Post
    Wieso gehört "su" dem Benutzer Hrodulf:users? Das sollte root:root sein! Wie soll es denn sonst root Rechte erlangen?
    Code:
    dir /usr/bin/su
    -rwsr-xr-x 1 root root 31744  9. Okt 15:07 /usr/bin/su
    Wenn ich mein /usr/bin/su meinem Benutzer zuteile, funktionierts auch nicht, also wird das vermutlich dein Problem sein.
    Code:
    wolfi@amiga:~/Desktop> sudo chown wolfi: /usr/bin/su
    root's password:
    wolfi@amiga:~/Desktop> dir /usr/bin/su
    -rwxr-xr-x 1 wolfi users 31744  9. Okt 15:07 /usr/bin/su
    wolfi@amiga:~/Desktop> su
    Passwort: 
    su: Fehler bei Authentifizierung
    Ich würde vorschlagen du rufst folgendes in einer Konsole auf, dann sollten die Rechte aller System-dateien auf die korrekten Werte gesetzt werden:
    Code:
    sudo /usr/bin/chkstat --system

    Hallo und vielen Dank für die schnelle Antwort!

    Fuktioniert leider nicht. Die falsche Zuordnung kann ich nicht nachvollziehen; habe das System erst vor zwei Tagen installiert.
    Die Fehlermeldung, die unabhängig davon, ob ich es als Hrodhulf oder root probiere, erscheint:

    MyHome:~ # sudo /usr/bin/chkstat --system
    Checking permissions and ownerships - using the permissions files
    /etc/permissions
    /etc/permissions.easy
    /etc/permissions.d/mail-server
    /etc/permissions.d/postfix
    /etc/permissions.local
    setting /usr/lib/utempter/utempter to root:utmp 2755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/lib/utempter/utempter: will not give away s-bits on an insecure path
    setting /usr/bin/at to root:trusted 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/at: will not give away s-bits on an insecure path
    setting /usr/bin/crontab to root:trusted 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/crontab: will not give away s-bits on an insecure path
    setting /usr/bin/gpasswd to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/gpasswd: will not give away s-bits on an insecure path
    setting /usr/bin/newgrp to root:root 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/newgrp: will not give away s-bits on an insecure path
    setting /usr/bin/passwd to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/passwd: will not give away s-bits on an insecure path
    setting /usr/bin/chfn to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/chfn: will not give away s-bits on an insecure path
    setting /usr/bin/chage to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/chage: will not give away s-bits on an insecure path
    setting /usr/bin/chsh to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/chsh: will not give away s-bits on an insecure path
    setting /usr/bin/expiry to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/expiry: will not give away s-bits on an insecure path
    setting /usr/bin/eject to root:audio 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/eject: will not give away s-bits on an insecure path
    setting /usr/bin/fusermount to root:trusted 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/fusermount: will not give away s-bits on an insecure path
    setting /usr/bin/wall to root:tty 2755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/wall: will not give away s-bits on an insecure path
    setting /usr/bin/write to root:tty 2755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/write: will not give away s-bits on an insecure path
    setting /usr/lib64/kde4/libexec/kcheckpass to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/lib64/kde4/libexec/kcheckpass: will not give away s-bits on an insecure path
    setting /usr/lib64/kde4/libexec/kdesud to root:nogroup 2755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/lib64/kde4/libexec/kdesud: will not give away s-bits on an insecure path
    setting /usr/lib64/kde4/libexec/start_kdeinit to root:root 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/lib64/kde4/libexec/start_kdeinit: will not give away s-bits on an insecure path
    setting /usr/lib/polkit-1/polkit-agent-helper-1 to root:root 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/lib/polkit-1/polkit-agent-helper-1: will not give away s-bits on an insecure path
    setting /usr/bin/pkexec to root:root 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/pkexec: will not give away s-bits on an insecure path
    setting /lib/dbus-1/dbus-daemon-launch-helper to root:messagebus 4750. (wrong owner/group Hrodhulf:users permissions 0750)
    /lib/dbus-1/dbus-daemon-launch-helper: will not give away s-bits on an insecure path
    setting /usr/sbin/lockdev to root:lock 2755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/sbin/lockdev: will not give away s-bits on an insecure path
    setting /usr/bin/su to root:root 4755. (wrong owner/group Hrodhulf:users)
    /usr/bin/su: will not give away s-bits on an insecure path
    setting /usr/bin/mount to root:root 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/mount: will not give away s-bits on an insecure path
    setting /usr/bin/umount to root:root 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/umount: will not give away s-bits on an insecure path
    ERROR: not all operations were successful.

    Irgendwelche Ideen???

  4. #4

    Default Re: sudo funktioniert nicht mehr korrekt

    Quote Originally Posted by Hrodhulf View Post
    Fuktioniert leider nicht. Die falsche Zuordnung kann ich nicht nachvollziehen; habe das System erst vor zwei Tagen installiert.
    Hm. Hast du vielleicht irgendwas installiert, dass das verursacht haben könnte?
    Oder ein fehlerhafter "chown -R" Aufruf?
    Natürlich sind root-Rechte nötig um sowas zu machen...

    Die Fehlermeldung, die unabhängig davon, ob ich es als Hrodhulf oder root probiere, erscheint:

    MyHome:~ # sudo /usr/bin/chkstat --system
    Checking permissions and ownerships - using the permissions files
    /etc/permissions
    /etc/permissions.easy
    /etc/permissions.d/mail-server
    /etc/permissions.d/postfix
    /etc/permissions.local
    setting /usr/lib/utempter/utempter to root:utmp 2755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/lib/utempter/utempter: will not give away s-bits on an insecure path
    ...
    setting /usr/bin/umount to root:root 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    /usr/bin/umount: will not give away s-bits on an insecure path
    ERROR: not all operations were successful.

    Irgendwelche Ideen???
    Ja. Diese Fehlermeldungen kommen, wenn auch die Rechte für die Verzeichnisse selber falsch sind.
    Da ist also gröber was passiert auf deinem System...

    Ich würde mal das Paket "filesystem" neu installieren, das sollte mal die Rechte der meisten Verzeichnisse beheben:
    Code:
    sudo zypper in -f filesystem
    Außerdem sollten noch folgende Pakete neu installiert werden laut deiner Ausgabe: (ich hoffe ich hab jetzt nichts übersehen)
    Code:
    sudo zypper in -f libutempter0 kde4-filesystem polkit dbus-1
    Danach nochmal "chkstat" starten und die Ausgabe posten.

  5. #5
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: sudo funktioniert nicht mehr korrekt

    * Hrodhulf wrote, On 01/04/2014 10:56 AM:
    > Irgendwelche Ideen???


    Deine Dateieigentümerschaften sind komplett hinüber. Früher konnte man das an der Kommandozeile wieder hinbiegen, aber m.W. gibt es die Möglichkeit nicht mehr.
    Ich würde das System einmal drüberinstallieren, wenn es eh noch ganz neu ist.

    Gruß
    Uwe

  6. #6

    Default Re: sudo funktioniert nicht mehr korrekt

    Quote Originally Posted by wolfi323 View Post
    Hm. Hast du vielleicht irgendwas installiert, dass das verursacht haben könnte?
    Oder ein fehlerhafter "chown -R" Aufruf?
    Natürlich sind root-Rechte nötig um sowas zu machen...
    Nicht, dass ich wüsste :-(
    Nur das System, Firefox und Thunderbird sowie VLC über eigenes Repo.
    Der Fehler machte sich bemerkbar, als ich danach TeamViewer installieren wollte.


    Quote Originally Posted by wolfi323 View Post
    Ja. Diese Fehlermeldungen kommen, wenn auch die Rechte für die Verzeichnisse selber falsch sind.
    Da ist also gröber was passiert auf deinem System...

    Ich würde mal das Paket "filesystem" neu installieren, das sollte mal die Rechte der meisten Verzeichnisse beheben:
    Code:
    sudo zypper in -f filesystem
    Außerdem sollten noch folgende Pakete neu installiert werden laut deiner Ausgabe: (ich hoffe ich hab jetzt nichts übersehen)
    Code:
    sudo zypper in -f libutempter0 kde4-filesystem polkit dbus-1
    Danach nochmal "chkstat" starten und die Ausgabe posten.
    Also, die Software-Installation läuft jetzt wieder und die Teamviewer-Installation startet auch.
    Allerdings bleiben noch ein paar Fehler im System. Kannst Du mir da auch auf die Sprünge helfen? Bin halt "nur" ein User ;-)

    Code:
    Hrodhulf@MyHome:~> sudo /usr/bin/chkstat --system
    Checking permissions and ownerships - using the permissions files
            /etc/permissions
            /etc/permissions.easy
            /etc/permissions.d/mail-server
            /etc/permissions.d/postfix
            /etc/permissions.local
    setting /usr/bin/at to root:trusted 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/crontab to root:trusted 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/gpasswd to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/newgrp to root:root 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/passwd to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/chfn to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/chage to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/chsh to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/expiry to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/eject to root:audio 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/fusermount to root:trusted 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/wall to root:tty 2755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/write to root:tty 2755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/lib64/kde4/libexec/kcheckpass to root:shadow 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/lib64/kde4/libexec/kdesud to root:nogroup 2755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/lib64/kde4/libexec/start_kdeinit to root:root 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/sbin/lockdev to root:lock 2755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/su to root:root 4755. (wrong owner/group Hrodhulf:users)
    setting /usr/bin/mount to root:root 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    setting /usr/bin/umount to root:root 4755. (wrong owner/group Hrodhulf:users permissions 0755)
    Hrodhulf@MyHome:~>

  7. #7

    Default Re: sudo funktioniert nicht mehr korrekt

    Quote Originally Posted by Hrodhulf View Post
    Nicht, dass ich wüsste :-(
    Nur das System, Firefox und Thunderbird sowie VLC über eigenes Repo.
    Der Fehler machte sich bemerkbar, als ich danach TeamViewer installieren wollte.
    Tja, dann muss es wohl eins von denen gewesen sein...

    Von wo hast du denn Firefox und Thunderbird installiert?
    Die sind doch sowieso in aktuellster Version in openSUSE enthalten und werden auch laufend upgedated...

    Zu VLC ist zu sagen, dass du das VLC repo nicht mit Packman zusammen verwenden solltest. (das hat jetzt aber nichts mit diesem Problem zu tun)
    Wenn du also irgendwann Packman verwenden willst (_das_ Standard repo für Multimedia), solltest du das VLC repo vorher entfernen und danach alle Pakete (inklusive vlc) zu den Versionen von Packman wechseln.
    Sh. auch SDB:Vendor change update - openSUSE

    Also, die Software-Installation läuft jetzt wieder und die Teamviewer-Installation startet auch.
    Allerdings bleiben noch ein paar Fehler im System. Kannst Du mir da auch auf die Sprünge helfen? Bin halt "nur" ein User ;-)
    Nein, da waren keine Fehler mehr. chkstat hat nur geschrieben, welche Änderungen es durchführt.
    Wenn du es nochmal startest, sollte keine Ausgabe mehr kommen.

  8. #8

    Thumbs up Re: sudo funktioniert nicht mehr korrekt

    Quote Originally Posted by wolfi323 View Post
    Tja, dann muss es wohl eins von denen gewesen sein...

    Von wo hast du denn Firefox und Thunderbird installiert?
    Die sind doch sowieso in aktuellster Version in openSUSE enthalten und werden auch laufend upgedated...

    Zu VLC ist zu sagen, dass du das VLC repo nicht mit Packman zusammen verwenden solltest. (das hat jetzt aber nichts mit diesem Problem zu tun)
    Wenn du also irgendwann Packman verwenden willst (_das_ Standard repo für Multimedia), solltest du das VLC repo vorher entfernen und danach alle Pakete (inklusive vlc) zu den Versionen von Packman wechseln.
    Sh. auch SDB:Vendor change update - openSUSE


    Nein, da waren keine Fehler mehr. chkstat hat nur geschrieben, welche Änderungen es durchführt.
    Wenn du es nochmal startest, sollte keine Ausgabe mehr kommen.
    Klasse, keine Fehler mehr! Vielen, vielen Dank!

    Firefox und Thunderbird hatte ich aus den openSUSE-Repos installiert und VLC aus dem PackMan-Repo.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •