Results 1 to 5 of 5

Thread: libcap-devel and recompiling NTP

  1. #1

    Default libcap-devel and recompiling NTP

    I'm running OpenSUSE 12.3 and I want to enable ATOM support in NTP. I've installed the source RPM. When I try to compile it, it errors out on "libcap-devel" required. I've looked in the library and packages repositories and I'm just not seeing this package.

    Can someone clue me in on how to get libcap-devel (which provides sys/capability.h) so I can re-compile NTP?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,325
    Blog Entries
    15

    Default Re: libcap-devel and recompiling NTP

    On Sat 04 Jan 2014 12:06:02 AM CST, gsexton wrote:


    I'm running OpenSUSE 12.3 and I want to enable ATOM support in NTP. I've
    installed the source RPM. When I try to compile it, it errors out on
    "libcap-devel" required. I've looked in the library and packages
    repositories and I'm just not seeing this package.

    Can someone clue me in on how to get libcap-devel (which provides
    sys/capability.h) so I can re-compile NTP?


    Hi
    It's there for 12.3 on the dvd or the oss repo?
    http://software.opensuse.org/package/libcap

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLED 11 SP3 (x86_64) GNOME 2.28.0 Kernel 3.0.101-0.8-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3

    Default Re: libcap-devel and recompiling NTP

    No, it's actually not. Here's a list of files starting with "libcap*"

    ./suse/i586/libcap-ng-devel-0.6.6-11.1.1.i586.rpm
    ./suse/i586/libcap2-2.22-7.1.2.i586.rpm
    ./suse/i586/libcapi20-3-2011.8.29-12.1.1.i586.rpm
    ./suse/i586/libcap-ng0-0.6.6-11.1.1.i586.rpm
    ./suse/i586/libcap-progs-2.22-7.1.2.i586.rpm


    I've installed libcap-ng-devel, but the file/library names are not the same, and it doesn't compile.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,325
    Blog Entries
    15

    Default Re: libcap-devel and recompiling NTP

    Quote Originally Posted by gsexton View Post
    No, it's actually not. Here's a list of files starting with "libcap*"

    ./suse/i586/libcap-ng-devel-0.6.6-11.1.1.i586.rpm
    ./suse/i586/libcap2-2.22-7.1.2.i586.rpm
    ./suse/i586/libcapi20-3-2011.8.29-12.1.1.i586.rpm
    ./suse/i586/libcap-ng0-0.6.6-11.1.1.i586.rpm
    ./suse/i586/libcap-progs-2.22-7.1.2.i586.rpm


    I've installed libcap-ng-devel, but the file/library names are not the same, and it doesn't compile.
    Hi
    I beg to differ I see libcap-devel here?
    Index of /distribution/12.3/repo/oss/suse/i586

    Now if you have a hard coded mirror in you repos that is not synced properly, then yes it's possible.

    Mirror List
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: libcap-devel and recompiling NTP

    Very strange. I'm certain I did a zypper install libcap-devel and it failed. I'll have to check my repository configuration. Thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •