Results 1 to 4 of 4

Thread: OpenSuSE 13.1 X server crashing

  1. #1

    Default OpenSuSE 13.1 X server crashing

    I just upgraded to OpenSuSE 13.1 64 bit (from 12.2). When I try to use the normal graphics controller for my Intel, Ironlake Mobile Graphics Controller, X crashes. I can use the computer if I add nomodeset at boot, in which case it uses a generic driver, but then I have to use resolution 1024x768, although the laptop's screen is 1366X768.

    The X server, not KDE or anything above that, is definitely what is crashing. I have tried other desktop environments (IceVM and TinyVM), which all have the same problem. Since the problem goes away if I use nomodeset, the crash seems to be caused by the underlying driver. This is in the xf86-video-intel package, which is at version 2.99.906.

    So, what should I do to fix this? My best guess after trawling around various forums is that a bug in that driver package is causing my problem. The solution to that would be to downgrade the package, or wait for an upgrade. However, I would appreciate your advice.

    I have looked in the files: /var/log/Xorg.0.log , /var/log/messages , and /var/log/kdm.log . ~/.xsession-errors-:0 (.xsession-errors had nothing in it) did not seem to add much, although I can get it for you.

    The Xorg.0.log file does not give too much useful information. These are the last lines.
    Code:
    [  5127.397] setversion 1.4 failed
    [  5129.650] (II) AIGLX: Suspending AIGLX clients for VT switch
    [  5134.698] (II) AIGLX: Resuming AIGLX clients after VT switch
    [  5134.698] (II) intel(0): switch to mode 1366x768@60.0 on pipe 0 using LVDS1, position (0, 0), rotation normal
    [  5134.751] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
    [  5136.984] (II) AIGLX: Suspending AIGLX clients for VT switch
    /var/log/messages has the following relevant section:
    Code:
    2014-01-02T14:18:07.573991-05:00 linux-bg34 polkitd[1011]: Unregistered Authentication Agent for unix-session:22 (system bus name :1.373, object path /org/kde/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
    2014-01-02T14:18:08.056588-05:00 linux-bg34 kdm[3440]: X server for display :0 terminated unexpectedly
    2014-01-02T14:18:08.079805-05:00 linux-bg34 kdm[3440]: plymouth should quit after server startup
    2014-01-02T14:18:08.108655-05:00 linux-bg34 acpid: 1 client rule loaded
    2014-01-02T14:18:08.265541-05:00 linux-bg34 kdm[3440]: Quitting Plymouth with transition
    2014-01-02T14:18:08.269630-05:00 linux-bg34 kdm[3440]: Is Plymouth still running? no
    2014-01-02T14:18:10.639520-05:00 linux-bg34 systemd[1]: Starting Session 26 of user leesn.
    2014-01-02T14:18:10.643226-05:00 linux-bg34 systemd-logind[673]: New session 26 of user leesn.
    2014-01-02T14:18:10.643684-05:00 linux-bg34 systemd[1]: Started Session 26 of user leesn.
    2014-01-02T14:18:12.512146-05:00 linux-bg34 dbus[660]: [system] Activating via systemd: service name='org.freedesktop.Avahi' unit='dbus-org.freedesktop.Avahi.service'
    2014-01-02T14:18:12.512808-05:00 linux-bg34 dbus[660]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.Avahi.service': Unit dbus-org.freedesktop.Avahi.service failed to load: No such file or directory.
    2014-01-02T14:18:19.723790-05:00 linux-bg34 hp-systray: hp-systray[19138]: error: option -s not recognized
    2014-01-02T14:18:21.922484-05:00 linux-bg34 polkitd[1011]: Registered Authentication Agent for unix-session:26 (system bus name :1.408 [/usr/lib64/kde4/libexec/polkit-kde-authentication-agent-1], object path /org/kde/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
    2014-01-02T14:19:10.959372-05:00 linux-bg34 systemd-logind[673]: Removed session 22.
    2014-01-02T14:19:33.742373-05:00 linux-bg34 dbus[660]: [system] Activating service name='org.freedesktop.PackageKit' (using servicehelper)
    2014-01-02T14:19:33.784243-05:00 linux-bg34 dbus[660]: [system] Successfully activated service 'org.freedesktop.PackageKit'
    2014-01-02T14:24:03.726331-05:00 linux-bg34 smartd[666]: Device: /dev/sda [SAT], 26 Currently unreadable (pending) sectors
    2014-01-02T14:24:14.458689-05:00 linux-bg34 dbus[660]: [system] Activating service name='org.freedesktop.PackageKit' (using servicehelper)
    2014-01-02T14:24:14.816679-05:00 linux-bg34 dbus[660]: [system] Successfully activated service 'org.freedesktop.PackageKit'
    2014-01-02T14:25:13.057314-05:00 linux-bg34 kernel: [ 5481.512849] ppdev: user-space parallel port driver
    2014-01-02T14:25:13.057335-05:00 linux-bg34 kernel: [ 5481.513663] lp: driver loaded but no devices found
    2014-01-02T14:25:13.123323-05:00 linux-bg34 kernel: [ 5481.578848] lp: driver loaded but no devices found
    2014-01-02T14:25:13.157303-05:00 linux-bg34 kernel: [ 5481.612991] st: Version 20101219, fixed bufsize 32768, s/g segs 256
    2014-01-02T14:25:13.251299-05:00 linux-bg34 kernel: [ 5481.707458] BIOS EDD facility v0.16 2004-Jun-25, 1 devices found
    2014-01-02T14:25:25.204301-05:00 linux-bg34 kernel: [ 5493.639553] lp: driver loaded but no devices found
    2014-01-02T14:25:25.246302-05:00 linux-bg34 kernel: [ 5493.681437] lp: driver loaded but no devices found
    2014-01-02T14:30:01.995570-05:00 linux-bg34 systemd[1]: Starting Session 27 of user root.
    2014-01-02T14:30:02.360413-05:00 linux-bg34 systemd[1]: Started Session 27 of user root.
    2014-01-02T14:37:17.167464-05:00 linux-bg34 su: (to leesn) leesn on none
    2014-01-02T14:37:17.511700-05:00 linux-bg34 su: pam_systemd(su:session): pam_putenv: delete non-existent entry; XDG_RUNTIME_DIR

  2. #2

    Default Re: OpenSuSE 13.1 X server crashing

    Two additional things. First, I can always access the virtual terminal at Ctrl-Alt-F1 (et cetera), whatever the state of the X server is. Also, here is my ~/.xsession-errors-:0 for anyone who wants it.
    Thanks.

    Code:
    kwin: Fatal IO error: client killed
    kdeinit4: sending SIGTERM to children.
    kdeinit4: Exit.
    akonadi_nepomuk_feeder: Fatal IO error: client killed
    akonadi_newmailnotifier_agent: Fatal IO error: client killed
    akonadi_sendlater_agent: Fatal IO error: client killed
    akonadi_archivemail_agent: Fatal IO error: client killed
    akonadi_mailfilter_agent: Fatal IO error: client killed
    QtDBus: cannot relay signals from parent QObject(0x1291c60 "") unless they are emitted in the object's thread QThread(0x10a11c0 ""). Current thread is QProcessManager(0x7f3cae93f520 "").
    QProcess: Destroyed while process is still running.
    ksmserver: Fatal IO error: client killed
    ror: client killed
    kglobalaccel: Fatal IO error: client killed
    ProcessControl: Application '/usr/bin/akonadi_maildispatcher_agent' returned with exit code 1 (Unknown error)
    ProcessControl: Application '/usr/bin/akonadi_newmailnotifier_agent' returned with exit code 1 (Unknown error)
    ProcessControl: Application '/usr/bin/akonadi_sendlater_agent' returned with exit code 1 (Unknown error)
    ProcessControl: Application '/usr/bin/akonadi_archivemail_agent' returned with exit code 1 (Unknown error)
    ProcessControl: Application '/usr/bin/akonadi_mailfilter_agent' returned with exit code 1 (Unknown error)
    ProcessControl: Application '/usr/bin/akonadi_agent_launcher' returned with exit code 1 (Unknown error)
    ProcessControl: Application '/usr/bin/akonadi_nepomuk_feeder' returned with exit code 1 (Unknown error)
    No protocol specified
    akonadi_maildispatcher_agent: cannot connect to X server :0
    No protocol specified
    akonadi_newmailnotifier_agent: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_maildispatcher_agent' returned with exit code 1 (Unknown error)
    ProcessControl: Application '/usr/bin/akonadi_newmailnotifier_agent' returned with exit code 1 (Unknown error)
    No protocol specified
    akonadi_agent_launcher: cannot connect to X server :0
    No protocol specified
    akonadi_nepomuk_feeder: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_agent_launcher' returned with exit code 1 (Unknown error)
    No protocol specified
    akonadi_mailfilter_agent: cannot connect to X server :0
    No protocol specified
    akonadi_archivemail_agent: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_mailfilter_agent' returned with exit code 1 (Unknown error)
    ProcessControl: Application '/usr/bin/akonadi_nepomuk_feeder' returned with exit code 1 (Unknown error)
    No protocol specified
    akonadi_sendlater_agent: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_sendlater_agent' returned with exit code 1 (Unknown error)
    ProcessControl: Application '/usr/bin/akonadi_archivemail_agent' returned with exit code 1 (Unknown error)
    No protocol specified
    akonadi_agent_launcher: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_agent_launcher' returned with exit code 1 (Unknown error)
    No protocol specified
    akonadi_newmailnotifier_agent: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_newmailnotifier_agent' returned with exit code 1 (Unknown error)
    No protocol specified
    akonadi_maildispatcher_agent: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_maildispatcher_agent' returned with exit code 1 (Unknown error)
    No protocol specified
    akonadi_agent_launcher: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_agent_launcher' returned with exit code 1 (Unknown error)
    "/usr/bin/akonadi_agent_launcher" crashed too often and will not be restarted! 
    No protocol specified
    akonadi_nepomuk_feeder: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_nepomuk_feeder' returned with exit code 1 (Unknown error)
    No protocol specified
    akonadi_mailfilter_agent: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_mailfilter_agent' returned with exit code 1 (Unknown error)
    No protocol specified
    akonadi_archivemail_agent: cannot connect to X server :0
    No protocol specified
    akonadi_newmailnotifier_agent: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_archivemail_agent' returned with exit code 1 (Unknown error)
    ProcessControl: Application '/usr/bin/akonadi_newmailnotifier_agent' returned with exit code 1 (Unknown error)
    "/usr/bin/akonadi_newmailnotifier_agent" crashed too often and will not be restarted! 
    No protocol specified
    akonadi_maildispatcher_agent: cannot connect to X server :0
    No protocol specified
    akonadi_nepomuk_feeder: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_maildispatcher_agent' returned with exit code 1 (Unknown error)
    "/usr/bin/akonadi_maildispatcher_agent" crashed too often and will not be restarted! 
    ProcessControl: Application '/usr/bin/akonadi_nepomuk_feeder' returned with exit code 1 (Unknown error)
    "/usr/bin/akonadi_nepomuk_feeder" crashed too often and will not be restarted! 
    No protocol specified
    akonadi_sendlater_agent: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_sendlater_agent' returned with exit code 1 (Unknown error)
    No protocol specified
    akonadi_mailfilter_agent: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_mailfilter_agent' returned with exit code 1 (Unknown error)
    "/usr/bin/akonadi_mailfilter_agent" crashed too often and will not be restarted! 
    No protocol specified
    akonadi_archivemail_agent: cannot connect to X server :0
    No protocol specified
    akonadi_sendlater_agent: cannot connect to X server :0
    ProcessControl: Application '/usr/bin/akonadi_archivemail_agent' returned with exit code 1 (Unknown error)
    "/usr/bin/akonadi_archivemail_agent" crashed too often and will not be restarted! 
    ProcessControl: Application '/usr/bin/akonadi_sendlater_agent' returned with exit code 1 (Unknown error)
    "/usr/bin/akonadi_sendlater_agent" crashed too often and will not be restarted! 
    kdeinit4: sending SIGTERM to children.
    kdeinit4: Exit.
    D-Bus session bus went down - quitting
    D-Bus session bus went down - quitting
    Application 'akonadiserver' exited normally...

  3. #3

    Default Re: OpenSuSE 13.1 X server crashing

    Quote Originally Posted by s-phi-nl View Post
    So, what should I do to fix this? My best guess after trawling around various forums is that a bug in that driver package is causing my problem. The solution to that would be to downgrade the package, or wait for an upgrade. However, I would appreciate your advice.
    I see you have "acpid" installed. Try to remove that if you don't need it, as systemd has taken over most of its functionality, so there may be conflicts. (if you're not sure whether you need it, then you most probably DON'T need it... )

    Maybe your problem is caused by the SNA acceleration? Try switching back to the older/more stable UXA:
    https://wiki.archlinux.org/index.php...eration_method

    If that doesn't help you could try to downgrade the intel driver to the 2.99.905 version in the standard OSS repo.
    (Run YaST->Software Management, select the "xf86-video-intel" package, click on "Versions" below the package list and select the lower version there.)
    Does it work then?

    Or you could also try to upgrade your graphics stack to the latest version from the X11:XOrg repo:
    Index of /repositories/X11:/XOrg/openSUSE_13.1
    Add that repo with YaST or zypper and do a "Full repository Vendor change" update:
    SDB:Vendor change update - openSUSE
    But be aware that this is bleeding edge, so might even break at times.
    Maybe you should disable that repo again after the install so you don't get updates that might break functionality...

  4. #4

    Default Re: OpenSuSE 13.1 X server crashing

    So it turned out that switching back from SNA to the stable UXA acceleration did the trick. Thanks a lot!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •