Results 1 to 3 of 3

Thread: Samba permissions settings

  1. #1

    Default Samba permissions settings

    Hi everyone ( openSUSE 13.1 , kde 4.12)

    I'm trying to create a shared folder with full read and write access :
    well ... at the local level "/ home / Shared" , everything works fine! , either by mounting the shared folder in fstab with bindfs , that setting the ACL' s

    What I can not understand is how to do the same thing I do at the local level , but with SAMBA
    ... smb :/ / netbook / Shared / (/ home / Shared ) .
    Should I try to inherit permissions from a parent folder or is it better try to set a spec rule "777" for all new files and folders

    namely:
    - I tried to change the umask in login.defs, but does not work
    - I tried with bindfs, but does not work
    - I tried to force the permissions in smb.conf,, but does not work
    - I tried to inherit the acl's, but does not work
    - I tried to edit / etc / permission, however, nothing to do

    Whatever I do, I always find myself with " 755 ". !!!!!
    On openSUSE, who is involved to set these permissions ? login. defs, umask, apparmor ?????
    What can I do to set them in "777" ?
    Possible that any changes I make in smb.conf, do not take effect ?


    Code:
        inherit acls = Yes                                    
        inherit owner = Yes
        inherit permissions = No 
        vfs objects = acl_xattr                               
        acl group control = Yes
        acl map full control = Yes
        nt acl support = Yes
        profile acls = No
        map acl inherit = Yes
        map archive = no
        ; force unknown acl user = No
        ; force user = pippo                                  
        force group = users
        create mask = 2777                                  
        directory mask = 2777   
        force create mode = 2777   
        force directory mode = 2777
    thanks

  2. #2

    Default Re: Samba permissions settings

    but sorry, no one is able to give me some help? are weeks that I try but I can not find a solution !!!!!

  3. #3

    Default Re: Samba permissions settings

    Now I tried to disable AppArmor for smb and nmb but nothing to do permissions on Shares remain the same "755"

    bhooo ??


    Ciaoooo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •