Results 1 to 7 of 7

Thread: Otter browser installation

  1. #1
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    107

    Default Otter browser installation

    When I try to instal (compile) Otter wrowser, then I see:

    Code:
    # cmake ../
    CMake Error at CMakeLists.txt:36 (find_package):
      By not providing "FindQt5Core.cmake" in CMAKE_MODULE_PATH this project has
      asked CMake to find a package configuration file provided by "Qt5Core", but
      CMake did not find one.
    
      Could not find a package configuration file provided by "Qt5Core" with any
      of the following names:
    
        Qt5CoreConfig.cmake
        qt5core-config.cmake
    
      Add the installation prefix of "Qt5Core" to CMAKE_PREFIX_PATH or set
      "Qt5Core_DIR" to a directory containing one of the above files.  If
      "Qt5Core" provides a separate development package or SDK, be sure it has
      been installed.
    
    
    -- Configuring incomplete, errors occurred!
    Where can I find Qt5CoreConfig.cmake?

    Otter Browser

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,671
    Blog Entries
    14

    Default Re: Otter browser installation

    AFAICS you're missing -devel packages, probably for qt5, but there may be more.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    107

    Default Re: Otter browser installation

    But I can't find any package like libQt5Core5-devel?
    What is the name of packache which you are thinking about?

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,671
    Blog Entries
    14

    Default Re: Otter browser installation

    Quote Originally Posted by rysic View Post
    But I can't find any package like libQt5Core5-devel?
    What is the name of packache which you are thinking about?
    The devel packages are built from the same sources the "normal" packages are built from.
    Now, what I did:
    - Yast - Software - Software manager - Search
    - search for "libqt5core" with defaults checked. It returns nothing.
    - search again with "file list" checked, returns libqt5-qtbase
    - my conclusion: I need libqt5-qtbase-devel.
    Note, you may need other devel packages.

    Another option you have is to install the KDE development pattern. That should pull in all you need to develop and compile KDE programs.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,537
    Blog Entries
    15

    Default Re: Otter browser installation

    On Thu 02 Jan 2014 02:26:01 PM CST, rysic wrote:


    When I try to instal (compile) Otter wrowser, then I see:


    Code:
    --------------------

    # cmake ../
    CMake Error at CMakeLists.txt:36 (find_package):
    By not providing "FindQt5Core.cmake" in CMAKE_MODULE_PATH this
    project has asked CMake to find a package configuration file provided
    by "Qt5Core", but CMake did not find one.

    Could not find a package configuration file provided by "Qt5Core"
    with any of the following names:

    Qt5CoreConfig.cmake
    qt5core-config.cmake

    Add the installation prefix of "Qt5Core" to CMAKE_PREFIX_PATH or set
    "Qt5Core_DIR" to a directory containing one of the above files. If
    "Qt5Core" provides a separate development package or SDK, be sure it
    has been installed.


    -- Configuring incomplete, errors occurred!

    --------------------


    Where can I find Qt5CoreConfig.cmake?

    'Otter Browser' (http://otter-browser.org/)


    Hi
    It only builds against QT >= 5.2 to build you need;
    Code:
    BuildRequires:  cmake
    BuildRequires:  libqt5-qtbase-devel >= 5.2
    BuildRequires:  libqt5-qtsensors-devel
    BuildRequires:  libQt5WebKit5-devel
    BuildRequires:  libQt5WebKitWidgets-devel
    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLED 11 SP3 (x86_64) GNOME 2.28.0 Kernel 3.0.101-0.8-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,537
    Blog Entries
    15

    Default Re: Otter browser installation

    On Thu 02 Jan 2014 05:02:23 PM CST, malcolmlewis wrote:

    On Thu 02 Jan 2014 02:26:01 PM CST, rysic wrote:


    When I try to instal (compile) Otter wrowser, then I see:


    Code:
    --------------------

    # cmake ../
    CMake Error at CMakeLists.txt:36 (find_package):
    By not providing "FindQt5Core.cmake" in CMAKE_MODULE_PATH this
    project has asked CMake to find a package configuration file provided
    by "Qt5Core", but CMake did not find one.

    Could not find a package configuration file provided by "Qt5Core"
    with any of the following names:

    Qt5CoreConfig.cmake
    qt5core-config.cmake

    Add the installation prefix of "Qt5Core" to CMAKE_PREFIX_PATH or set
    "Qt5Core_DIR" to a directory containing one of the above files. If
    "Qt5Core" provides a separate development package or SDK, be sure it
    has been installed.


    -- Configuring incomplete, errors occurred!

    --------------------


    Where can I find Qt5CoreConfig.cmake?

    'Otter Browser' (http://otter-browser.org/)


    Hi
    It only builds against QT >= 5.2 to build you need;
    Code:
    BuildRequires:  cmake
    BuildRequires:  libqt5-qtbase-devel >= 5.2
    BuildRequires:  libqt5-qtsensors-devel
    BuildRequires:  libQt5WebKit5-devel
    BuildRequires:  libQt5WebKitWidgets-devel
    Hi
    And built here;
    https://build.opensuse.org/package/s...:TESTING/otter

    Will it break other stuff....probably, use at your own risk.....

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLED 11 SP3 (x86_64) GNOME 2.28.0 Kernel 3.0.101-0.8-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,537
    Blog Entries
    15

    Default Re: Otter browser installation

    On Thu 02 Jan 2014 05:23:03 PM CST, malcolmlewis wrote:

    On Thu 02 Jan 2014 05:02:23 PM CST, malcolmlewis wrote:

    On Thu 02 Jan 2014 02:26:01 PM CST, rysic wrote:


    When I try to instal (compile) Otter wrowser, then I see:


    Code:
    --------------------

    # cmake ../
    CMake Error at CMakeLists.txt:36 (find_package):
    By not providing "FindQt5Core.cmake" in CMAKE_MODULE_PATH this
    project has asked CMake to find a package configuration file provided
    by "Qt5Core", but CMake did not find one.

    Could not find a package configuration file provided by "Qt5Core"
    with any of the following names:

    Qt5CoreConfig.cmake
    qt5core-config.cmake

    Add the installation prefix of "Qt5Core" to CMAKE_PREFIX_PATH or set
    "Qt5Core_DIR" to a directory containing one of the above files. If
    "Qt5Core" provides a separate development package or SDK, be sure it
    has been installed.


    -- Configuring incomplete, errors occurred!

    --------------------


    Where can I find Qt5CoreConfig.cmake?

    'Otter Browser' (http://otter-browser.org/)


    Hi
    It only builds against QT >= 5.2 to build you need;
    Code:
    BuildRequires:  cmake
    BuildRequires:  libqt5-qtbase-devel >= 5.2
    BuildRequires:  libqt5-qtsensors-devel
    BuildRequires:  libQt5WebKit5-devel
    BuildRequires:  libQt5WebKitWidgets-devel
    Hi
    And built here;
    https://build.opensuse.org/package/s...:TESTING/otter

    Will it break other stuff....probably, use at your own risk.....

    Hi
    I had to rename as a conflict with a debian package called otter...
    It's also listed as an un-official package as well...
    https://github.com/Emdek/otter/wiki/Packages

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLED 11 SP3 (x86_64) GNOME 2.28.0 Kernel 3.0.101-0.8-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •