Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Ctl-Alt-Del dialog not responsive in 13.1

  1. #1
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    359

    Default Ctl-Alt-Del dialog not responsive in 13.1

    Just wondering if anyone else noticed that the shutdown menu waits 30 seconds before acting on the command to restart or halt. My older server has a very basic video display on the motherboard, which is slow for sure. But I expected to see a flicker of the button I click on, which I don't see. Eventually the command is carried out.
    Leap/KDE and a film-based photographer

  2. #2
    Join Date
    Sep 2012
    Posts
    7,103

    Default Re: Ctl-Alt-Del dialog not responsive in 13.1

    A wild guess - do you have libvirt installed?

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: Ctl-Alt-Del dialog not responsive in 13.1

    Never use Ctl-Alt-Del; I have always used Ctl-Alt_Backspace (actually double Backspace in openSUSE to avoid accidents).

  4. #4
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    359

    Default Re: Ctl-Alt-Del dialog not responsive in 13.1

    Quote Originally Posted by arvidjaar View Post
    A wild guess - do you have libvirt installed?
    Not that Yast shows. Yast finds no libvirt in any repository. The closest is lilbverto.so, a component of Kerberos. What is libvert?
    Leap/KDE and a film-based photographer

  5. #5

    Default Re: Ctl-Alt-Del dialog not responsive in 13.1

    Quote Originally Posted by john_hudson View Post
    Never use Ctl-Alt-Del; I have always used Ctl-Alt_Backspace (actually double Backspace in openSUSE to avoid accidents).
    But that doesn't shut down the session correctly.
    It forcefully kills all processes instead.

    Not really the best idea for daily use...

  6. #6

    Default Re: Ctl-Alt-Del dialog not responsive in 13.1

    Quote Originally Posted by konsultor View Post
    What is libvert?
    Arvidjaar was talking about libvirt, there is no libvert...

    But just to be sure I understand your problem correctly:
    You get the shutdown dialog (with the 30 seconds countdown), but are unable to press any button?
    So it takes the default action after 30 seconds?

  7. #7
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: Ctl-Alt-Del dialog not responsive in 13.1

    Quote Originally Posted by wolfi323 View Post
    But that doesn't shut down the session correctly.
    It forcefully kills all processes instead.

    Not really the best idea for daily use...
    Then I haven't noticed a problem in the GUI shutdown menu; I only use Ctl-Alt-Backspace when there is a problem with the GUI and I cannot open a console to issue init 0 (or 6). But I do notice that KDE takes longer to shut down than the lighter desktops anyway.

  8. #8
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: Ctl-Alt-Del dialog not responsive in 13.1

    I decided to do some further investigation.

    According to System Settings>Shortcuts>Global>KDE Session manager, all that Ctl-Alt-Del does is bring up the 'Logout' menu (I always use right-click>Leave for this); this then shows a 30 second countdown to allow you to select Shutdown or Restart. After this, it defaults to Logout. AFAIK, this has been a feature of this menu since around KDE4.3.

    To avoid the 30 second countdown, you have to use Ctl-Alt-Shift followed by Del for Logout, PgDn for Shutdown or PgUp for Restart. Perhaps these are new shortcuts for KDE11?

  9. #9

    Default Re: Ctl-Alt-Del dialog not responsive in 13.1

    [QUOTE=john_hudson;2613452According to System Settings>Shortcuts>Global>KDE Session manager, all that Ctl-Alt-Del does is bring up the 'Logout' menu (I always use right-click>Leave for this); this then shows a 30 second countdown to allow you to select Shutdown or Restart. After this, it defaults to Logout. AFAIK, this has been a feature of this menu since around KDE4.3.[/QUOTE]
    Correct.
    And you can choose the default action in "Configure Desktop"->"Startup and Shutdown"->"Session Management"->"Default Leave Action".

    But the OP's problem as I understand it is that he can't click on any button, so he has to wait for the timeout.

    To avoid the 30 second countdown, you have to use Ctl-Alt-Shift followed by Del for Logout, PgDn for Shutdown or PgUp for Restart. Perhaps these are new shortcuts for KDE11?
    Those shortcuts are also there for a while already.

    You can also disable the 30s countdown/showing of the leave dialog in KDE's settings, see above.
    Or you can choose the separate actions in Kickoff's "Leave" tab.

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Ctl-Alt-Del dialog not responsive in 13.1

    On 2014-01-04 07:56, wolfi323 wrote:
    >
    > john_hudson;2613452


    > According to System Settings>Shortcuts>Global>KDE Session manager, all that Ctl-Alt-Del does is bring up the 'Logout' menu (I always use right-click>Leave for this); this then shows a 30 second countdown to allow you to select Shutdown or Restart. After this, it defaults to Logout. AFAIK, this has been a feature of this menu since around KDE4.3.


    > Correct.
    > And you can choose the default action in "Configure Desktop"->"Startup
    > and Shutdown"->"Session Management"->"Default Leave Action".


    What ctrl-alt-supr does depends on where you type it.

    If you do it on a console, it is more or less the same as if you type "halt -p". This closes the
    graphical session, probably with a _forced_ logout. There should be no questions asked to save data
    on running programs, they are simply killed.

    Programs that have service files, like daemons, are properly closed, they are designed for this.

    If you type the command in KDE it might intercept the sequence and do extra things. I'm not sure of
    this. But by default, pressing the ctrl-alt-supr sequence means you have no way to type anything
    else to modify things, abort or speed it up.

    On a real hurry, press first ctrl-alt-backspace, twice, to kill the graphical session without mercy,
    then ctrl-alt-supr to shutdown the computer.

    Otherwise, better to log out from the session normally, then ctrl-alt-supr.

    Warning: it can also reboot the computer instead. Configurable.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" (Elessar))

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •