Results 1 to 6 of 6

Thread: Desktop Effects disabled every X restarts/startups

  1. #1

    Default Desktop Effects disabled every X restarts/startups

    Hi,

    I'm a new opensuse user who just installed the latest 13.1 and I'm very satisfied with a new distro However I have one problem, every x (random) restarts/startups my desktop effects become disabled when I login to the system and then I have to enable it manually (alt shift f12). Few spec. information: open suse 13.1x64, fully updated with nvidia blob installed (through 1 click). Apart from this little annoying problem everything works as expected (movies, games,steam etc)

    I tried to remove .kde but I didn't help. I cant find anything useful in logs. After the issue occurred xsession_errors showed some kde specific data but I'm not sure if it contains anything useful SUSE Paste

    Much appreciated any comments or hints.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,762

    Default Re: Desktop Effects disabled every X restarts/startups

    The pertinent directory is ~/.kde4 note you need to be logged as root at the command line to do it right since that Directory has active files when you are logged as the user

    It seems strange that sometimes it works and some times not. Maybe run smartctrl to check the disk for errors

  3. #3

    Default Re: Desktop Effects disabled every X restarts/startups

    Quote Originally Posted by gogalthorp View Post
    The pertinent directory is ~/.kde4 note you need to be logged as root at the command line to do it right since that Directory has active files when you are logged as the user

    It seems strange that sometimes it works and some times not. Maybe run smartctrl to check the disk for errors
    I of course deleted .kde4 directory from a terminal and not being logged to kde. Thx, I will scan the disk and do the memtest as well.

  4. #4

    Default Re: Desktop Effects disabled every X restarts/startups

    All tests passed. When the issue reoccurs I'm able to start kwin from a console:

    Code:
    QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
    QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
    artur@ordos:~> QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
    QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
    OpenGL vendor string:                   NVIDIA Corporation
    OpenGL renderer string:                 GeForce GTX 460/PCIe/SSE2
    OpenGL version string:                  4.4.0 NVIDIA 331.20
    OpenGL shading language version string: 4.40 NVIDIA via Cg compiler
    Driver:                                 NVIDIA
    Driver version:                         331.20
    GPU class:                              GF100
    OpenGL version:                         4.4
    GLSL version:                           4.40
    X server version:                       1.14.3
    Linux kernel version:                   3.11.6
    Direct rendering:                       yes
    Requires strict binding:                no
    GLSL shaders:                           yes
    Texture NPOT support:                   yes
    Virtual Machine:                        no
    kwin(4613) KWin::GlxBackend::present: 
    It seems you are using the nvidia driver without triple buffering
    You must export __GL_YIELD="USLEEP" to prevent large CPU overhead on synced swaps
    Preferably, enable the TripleBuffer Option in the xorg.conf Device
    For this reason, the tearing prevention has been disabled.
    See https://bugs.kde.org/show_bug.cgi?id=322060
    Is there any way to log kde activity during a logon process?

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,996
    Blog Entries
    14

    Default Re: Desktop Effects disabled every X restarts/startups

    Removing the entire ~/.kde4 folder is a rigorous measure. Re. graphical issues most of the time removal of the plasm* files in ~/.kde4/share/config whilst not logged in is enough.
    IMHO you'd better have a look at the rendering by KDE: Systemsettings - Desktop effects - Advanced. Which are the settings now?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Re: Desktop Effects disabled every X restarts/startups

    Quote Originally Posted by Knurpht View Post
    Removing the entire ~/.kde4 folder is a rigorous measure. Re. graphical issues most of the time removal of the plasm* files in ~/.kde4/share/config whilst not logged in is enough.
    IMHO you'd better have a look at the rendering by KDE: Systemsettings - Desktop effects - Advanced. Which are the settings now?
    Compositing type: opengl 3.1 (same effect on 2.1)
    QT graphics system: raster
    Keep windows thumbnails: only for shown windows
    Scale method: accurate
    Suspend desktop effects for fullscren windows - checked
    Vsync: automatic
    Enable color correction - unchecked

    This randomnes is weird and lack of errors when I start kwin manually Anyway I'm glad for help.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •