Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Using a mic in Steam?

  1. #1
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Using a mic in Steam?

    I have been trying to get my Logitech USB Headset to work with steam for a while now but have had no luck so far. Has anyone had any luck with this? I am using PulseAudio and from what I have seen by asking around, Steam is supposed to show an option for the mic labeled "PulseAudio" but it does not do this for me. I am pretty sure I have installed the needed packages that it needs to talk with PulseAudio. Here is a zypper se for pulse http://paste.opensuse.org/view/raw/21067647
    openSUSE Leap (42.1) 64 bit
    Plasma 5.4

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: Using a mic in Steam?

    Quote Originally Posted by alanbortu View Post
    I have been trying to get my Logitech USB Headset to work with steam for a while now but have had no luck so far. Has anyone had any luck with this? I am using PulseAudio and from what I have seen by asking around, Steam is supposed to show an option for the mic labeled "PulseAudio" but it does not do this for me. I am pretty sure I have installed the needed packages that it needs to talk with PulseAudio. Here is a zypper se for pulse http://paste.opensuse.org/view/raw/21067647
    I don't have the definitive answer, and forgive me if I'm on the wrong track, but do you have 'pavucontrol' installed? That might required to set the default source.

    From the terminal, you can examine default sink and source
    Code:
    pactl stat
    To list all available sources
    Code:
    pacmd list-sources
    The default source can be set with
    Code:
    pacmd set-default-source <name of source>
    For example, I have one source (internal mic) reported as
    Code:
    name: <alsa_input.pci-0000_00_1b.0.analog-stereo>
    so I can set as default with
    Code:
    pacmd set-default-source alsa_input.pci-0000_00_1b.0.analog-stereo

  3. #3
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: Using a mic in Steam?

    Quote Originally Posted by deano_ferrari View Post
    I don't have the definitive answer, and forgive me if I'm on the wrong track, but do you have 'pavucontrol' installed? That might required to set the default source.
    Yeah I have pavucontrol, the mic is unmuted and it works in other programs like Audacity. The problem is that steam is not showing the PulseAudio option so I figure there is some 32bit package I am missing.
    openSUSE Leap (42.1) 64 bit
    Plasma 5.4

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,286

    Default Re: Using a mic in Steam?

    Yes you need the 32 bit pulseadio stuff

    alsa-plugins-pulse-32bit

  5. #5
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: Using a mic in Steam?

    Quote Originally Posted by gogalthorp View Post
    Yes you need the 32 bit pulseadio stuff

    alsa-plugins-pulse-32bit
    If you check my link in the OP I have it installed, thats why I am so puzzled as to why it wont work. Is it possible that pulse isnt actually running? (I can open pavucontrol though which usually complains if pulse isnt running)
    openSUSE Leap (42.1) 64 bit
    Plasma 5.4

  6. #6
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Using a mic in Steam?

    You should start steam from the terminal and see what errors it writes to stout. I remember seeing something about the mic in the terminal, it may not be helpful though.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: Using a mic in Steam?

    Quote Originally Posted by alanbortu View Post
    If you check my link in the OP I have it installed, thats why I am so puzzled as to why it wont work. Is it possible that pulse isnt actually running? (I can open pavucontrol though which usually complains if pulse isnt running)
    Maybe these are relevant?

    No sound on openSUSE :: Steam for Linux Obecné diskuze

    [Dup] Pulse audio :: Steam for Linux Valve Games and Steam for Linux Client

  8. #8
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: Using a mic in Steam?

    Quote Originally Posted by anika200 View Post
    You should start steam from the terminal and see what errors it writes to stout. I remember seeing something about the mic in the terminal, it may not be helpful though.
    Here it is http://paste.opensuse.org/view/raw/87058156

    Line of intrest
    Code:
     PulseAudio connect failed (used only for Mic Volume Control) with error: Access denied
    openSUSE Leap (42.1) 64 bit
    Plasma 5.4

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: Using a mic in Steam?

    FWIW, an odd workaround posted here (ref post #2 and #3)

    https://forums.opensuse.org/english/...ml#post2563991

  10. #10
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: Using a mic in Steam?

    Quote Originally Posted by deano_ferrari View Post
    FWIW, an odd workaround posted here (ref post #2 and #3)

    https://forums.opensuse.org/english/...ml#post2563991
    And there it is, just like magic
    Thank you very much. What a strange strange bug though...

    openSUSE Leap (42.1) 64 bit
    Plasma 5.4

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •