Results 1 to 4 of 4

Thread: lxdm at boot

  1. #1

    Default lxdm at boot

    hi,
    I build an appliance with lxde (cloned)
    - including package "lxdm"
    - selected runlevel 5 graphical

    but when start it stop at login no-graphical

    and I dont view service lxdm




    how can I start lxdm at boot?




    thank you

  2. #2
    Join Date
    Jun 2008
    Location
    Düsseldorf/Germany
    Posts
    248

    Default Re: lxdm at boot

    Hm...not sure if here or on the Suse-Studio Forum is less traffic.

    Anyway, I face the same problem. For whatever reason it does not find lxdm and starts with xfce as windowmanager. although /etc/sysconfig/displaymanager is properly maintained....

    Seems that the pattern lxde is broken - otherwise it should boot....

  3. #3

    Default Re: lxdm at boot

    I try removing lxdm and installing lightdm

    and I put in script:

    DISPLAYMANAGER="lightdm"

    but when start (graphics) it stops here:

    http://digilander.libero.it/sacarde/np/suse5.jpg




    do you solve?

    thank you

  4. #4

    Default Re: lxdm at boot

    I solve by heizi suggestion I add to start-script:

    Code:
    #set lxde as default wm
    sed 's/^DEFAULT_WM *=.*/DEFAULT_WM="lxde" /g'  -i /etc/sysconfig/windowmanager
    #enable lxdm
    cat << EOF >> /usr/lib/systemd/system/lxdm.service
    [Unit]
    Description=LXDM (Lightweight X11 Display Manager)
    #Documentation=man:lxdm(8)
    Conflicts=getty@tty1.service
    After=systemd-user-sessions.service getty@tty1.service plymouth-quit.service livesys-late.service
    #Conflicts=plymouth-quit.service
    
    [Service]
    ExecStart=/usr/bin/lxdm
    Restart=always
    IgnoreSIGPIPE=no
    #BusName=org.freedesktop.lxdm
    
    [Install]
    Alias=display-manager.service
    EOF
    
    systemctl enable lxdm

    thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •