Results 1 to 2 of 2

Thread: PXE-booting 13.1 Live CD

  1. #1

    Default PXE-booting 13.1 Live CD

    After some hours of searching the internet and testing I finally nearly got openSUSE-13.1-GNOME-i686.iso booting via PXE and NFS. "Nearly" because the boot process stops at some point due to a lost network connection (I guess). I'm using VirtualBox for the tests.

    I added the following lines to my PXE config to add a menu entry for the live CD:

    Code:
    label openSUSE13.1 Live 
      menu label Live openSUSE 13.1
      kernel /opensuse13.1-live-32/linux
      append initrd=opensuse13.1-live-32/initrd splash=verbose isofrom_device=nfs:192.168.1.11:/mnt/data/tftp isofrom_system=opensuse13.1-live-32/openSUSE-13.1-GNOME-Live-i686.iso vga=791
    isofrom_device is my NFS export share and isofrom_system the path to the ISO on this share. This works nicely and the system is starting up. At some point (varies from boot to boot) the startup process hangs. Last message might be "Started Accounts Service" or "Reached Target Login Prompts" or something else in that area. There is no further output on this console. Switching to F10 and wait for some minutes shows: "linux systemd-logind[1608]: Failed to issue method call: Did not receive a reply. Possible causes include: the remote application did no send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.". This is followed by complains about unreadable SQUASH file system and missing NFS shares.

    Any idea how to fix this?

    (Sorry for not providing complete logs, but I have to re-type everything as I didn't found a way to copy-and-paste the stuff)

  2. #2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •