Results 1 to 3 of 3

Thread: No 32-Bit Runtime Environment Pattern in 13.1 YAST ?

  1. #1
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default No 32-Bit Runtime Environment Pattern in 13.1 YAST ?

    I just noticed that this Pattern option is not displayed in YAST for 13.1.

    Is there a particular reason?
    I think I may be chasing a 32bit library issue (THREAD) with a proprietary program, but am not sure exactly what might be missing.

    I was about to apply the shotgun approach (install the 32bit Pattern), then noticed it wasn’t there.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,043

    Default Re: No 32-Bit Runtime Environment Pattern in 13.1 YAST ?

    On Tue, 31 Dec 2013 01:46:04 +0000, cmcgrath5035 wrote:

    > I just noticed that this Pattern option is not displayed in YAST for
    > 13.1.
    >
    > Is there a particular reason?
    > I think I may be chasing a 32bit library issue ('THREAD'
    > (http://tinyurl.com/plrogu5)) with a proprietary program, but am not
    > sure exactly what might be missing.
    >
    > I was about to apply the shotgun approach (install the 32bit Pattern),
    > then noticed it wasn’t there.


    Probably because a shotgun approach isn't the best approach to selecting
    libraries to install.

    From your other thread, it looks like you might either need zlib-32bit
    or, failing that, the program just isn't compatible with the library
    version included with 13.1.

    You can run ldd against the binary to see what libraries it's looking for.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: No 32-Bit Runtime Environment Pattern in 13.1 YAST ?

    Thanks for the idea Jim
    I ran ldd - v on the executable and there are no missing dependencies.
    But I am also confused that all the dependencies are 64bit; while the vuescan support info implies that some 32 bit libs are needed.

    Could be an evolution issue, not clear yet.
    I'll keep digging.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •