Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: SOLUTION FOR KSCREEN NOT SAVING DUAL MONITOR CONFIGURATION IN OPENSUSE 13.1

  1. #1

    Default SOLUTION FOR KSCREEN NOT SAVING DUAL MONITOR CONFIGURATION IN OPENSUSE 13.1

    PROBLEM

    If you are running a dual monitor screen configuration in openSUSE 13.1 you might be having problems with Kscreen saving your configuration. If you logout or reboot, your dual monitor configuration will be lost. This problem persists even if you install proprietary drivers from Nvidia and attempt saving your configuration trough nvidia-settings.

    SOLUTION


    1. Download and install arandr and make sure that xrandr is also installed along with its libraries (it should already be.)

    2. Open terminal and run arandr as user, not as su. It will open a configuration screen similar to the one used by Kscreen. Place your monitors as per your needs and save the configuration. Name it aranadr.conf. The program will save the configuration file in a shell script in a hidden folder in /home/username/.screenlayout/arandr.conf.sh.

    3. Open Configure Desktop > Startup and Shutdown > Autostart > Add Script Provide the complete path for your arandr.conf.sh script, i.e.

    /home/username/.screenlayout/arandr.conf.sh

    and make sure to enable it at Startup. Apply this change.

    That's it. Now when you logout or reboot, your KDE will open momentarily with the old screwed up configuration, but almost immediately after that the script will correct it to the way you want.

    Enjoy!

  2. #2

    Default Re: SOLUTION FOR KSCREEN NOT SAVING DUAL MONITOR CONFIGURATION IN OPENSUSE 13.1

    Quote Originally Posted by rgutierrezg View Post
    PROBLEM

    If you are running a dual monitor screen configuration in openSUSE 13.1 you might be having problems with Kscreen saving your configuration. If you logout or reboot, your dual monitor configuration will be lost. This problem persists even if you install proprietary drivers from Nvidia and attempt saving your configuration trough nvidia-settings.

    SOLUTION


    1. Download and install arandr and make sure that xrandr is also installed along with its libraries (it should already be.)

    2. Open terminal and run arandr as user, not as su. It will open a configuration screen similar to the one used by Kscreen. Place your monitors as per your needs and save the configuration. Name it aranadr.conf. The program will save the configuration file in a shell script in a hidden folder in /home/username/.screenlayout/arandr.conf.sh.

    3. Open Configure Desktop > Startup and Shutdown > Autostart > Add Script Provide the complete path for your arandr.conf.sh script, i.e.

    /home/username/.screenlayout/arandr.conf.sh

    and make sure to enable it at Startup. Apply this change.

    That's it. Now when you logout or reboot, your KDE will open momentarily with the old screwed up configuration, but almost immediately after that the script will correct it to the way you want.

    Enjoy!
    Well, you could also just disable the "KScreen 2" service in "Configure Desktop"->"Startup and Shutdown"->"Service Management".
    Then Kscreen's saved configuration should not be restored on login.

  3. #3

    Default Re: SOLUTION FOR KSCREEN NOT SAVING DUAL MONITOR CONFIGURATION IN OPENSUSE 13.1

    Quote Originally Posted by wolfi323 View Post
    Well, you could also just disable the "KScreen 2" service in "Configure Desktop"->"Startup and Shutdown"->"Service Management".
    Then Kscreen's saved configuration should not be restored on login.
    Thanks, wolfi. That was the finishing touch needed to completely substitute a flaky Kscreen. Man, you DO know your openSUSE !!!

    I never had this problem with 10.x, 11.x, and 12.x iterations of openSUSE that used sax2, xorg.conf, and then krandr. But ever since I installed openSUSE 13.1 a day or two after it was released, I have been grappling with this very vexing problem with Kscreen and my dual monitors since 13.1 no longer uses any of the old, proven screen utilities. And the proprietary driver settings managers offer no relief either, as you might attempt saving your configuration even as su, to the same ineffectual results.

    And it is not an openSUSE problem only. I found the same sad situation in Fedora 20 KDE and Kubuntu 13,10, and even in 14.04 RC1 with the new 3.12 kernel. It is a shame that the nice folks at KDE have dropped the ball with Kscreen/dual monitors and, apparently, without having done anything yet to solve it. And it is a problem that, judging by the myriad complaints all over the internet, affects a whole LOT of people.

    The arandr solution I offered here (and completed with your very accurate finishing detail) is, I think, the easiest one to implement and the one involving no undesired package regressions (like you would have if you attempted to bring back and use the old krandr), and absolutely no risk, AFAIK, to your installation.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,700
    Blog Entries
    1

    Default Re: SOLUTION FOR KSCREEN NOT SAVING DUAL MONITOR CONFIGURATION IN OPENSUSE 13.1

    Feel free to post a bug report concerning issues with KScreen. It's the only way it will get fixed.

    https://bugs.kde.org/show_bug.cgi?id=325277

    http://community.kde.org/Solid/Proje...o_report_a_bug
    Last edited by deano_ferrari; 31-Dec-2013 at 19:44.

  5. #5

    Default Re: SOLUTION FOR KSCREEN NOT SAVING DUAL MONITOR CONFIGURATION IN OPENSUSE 13.1

    Quote Originally Posted by deano_ferrari View Post
    Feel free to post a bug report concerning issues with KScreen. It's the only way it will get fixed.

    https://bugs.kde.org/show_bug.cgi?id=325277

    http://community.kde.org/Solid/Proje...o_report_a_bug
    This problem-- essentially that Kscreen does not save multidisplay configurations through logouts/reboots in many systems --has been widely reported to KDE already. But as far as I can tell after poring for hours the related KDE forums seeking a solution (and finding none there, I might add), the KDE team responsible for Kscreen has not implemented a cure yet. IMHO Kscreen was supposed to have been a be-it-all, do-it-all screen master able to leap over and supersede all previous (and fully functional) screen utilities. All it has ended being, though, is a horrible, regressive aggravation. A very compelling argument as to why developers should not mess around with things that already work just fine...

  6. #6

    Default Re: SOLUTION FOR KSCREEN NOT SAVING DUAL MONITOR CONFIGURATION IN OPENSUSE 13.1

    Add my name to the list of grumbling users. I had a perfectly working krandrrc for my triple monitor setup that included a startup command to add a screen mode that's improperly detected through a DisplayPort to DVI adapter. Worked fine in previous openSUSE versions.

    Then they go and remove the functionality and replace it with something that isn't even finished? C'mon, how did the Kscreen module even make it past alpha test when that basic function is so broken?

  7. #7

    Default Re: SOLUTION FOR KSCREEN NOT SAVING DUAL MONITOR CONFIGURATION IN OPENSUSE 13.1

    Found this thread yesterday and it got me 80% of the way there.
    Every since upgrading to 13.1 my dual monitors insist in starting up in, basically clone mode (same desktop duplicated on both screens).

    I'm able to bring up the desktop settings, configure them side by side, with the leftside active, with no problem but, as has been mentioned above it does not seem to save that configuration anywhere.

    I created an arandr.config.sh, set it up in the startup folder, and unchecked kscreen in the "Service Management".
    Now when I logout/login it does configure my monitors correctly but, not before restoring most of my saved session, much of which consists of windows on the second monitor, meaning I have to go through each desktop dragging the windows to their proper location.

    Can anyone suggest a way to move the "arandr.config" earlier in the X startup, so that the desktop is configured before the session is restored?

    Thank you

  8. #8

    Default Re: SOLUTION FOR KSCREEN NOT SAVING DUAL MONITOR CONFIGURATION IN OPENSUSE 13.1

    Quote Originally Posted by LarryStarr View Post
    Can anyone suggest a way to move the "arandr.config" earlier in the X startup, so that the desktop is configured before the session is restored?
    You could configure this in /etc/X11/xorg.conf or /etc/X11/xorg.conf.d/. Then it would be system-wide for the whole X and therefore applied _before_ your KDE session is started.
    But I can't tell you how to do this exactly. (I only have single monitor setups)

    If you're using nvidia, you might be able to use "nvidia-settings" for creating this config file.

    Or maybe run that arandr.config script in /etc/X11/xinit/xinitrc or similar. (maybe just put it to /etc/X11/xinit/xinitrc.d/, it should then be called automatically when the X session is started, _before_ KDE runs)

  9. #9

    Default Re: SOLUTION FOR KSCREEN NOT SAVING DUAL MONITOR CONFIGURATION IN OPENSUSE 13.1

    Quote Originally Posted by wolfi323 View Post
    You could configure this in /etc/X11/xorg.conf or /etc/X11/xorg.conf.d/. Then it would be system-wide for the whole X and therefore applied _before_ your KDE session is started.
    But I can't tell you how to do this exactly. (I only have single monitor setups)

    If you're using nvidia, you might be able to use "nvidia-settings" for creating this config file.

    Or maybe run that arandr.config script in /etc/X11/xinit/xinitrc or similar. (maybe just put it to /etc/X11/xinit/xinitrc.d/, it should then be called automatically when the X session is started, _before_ KDE runs)
    It turns out that a closer look at the options in the "Autostart->System Settings->Script file->Run On" drop down provided the answer.

    I had set it to "Startup", setting it to "Pre-KDE startup", runs the script and configures the desktop prior to my session being restored.

    Hope this helps someone else.

  10. #10

    Default Re: SOLUTION FOR KSCREEN NOT SAVING DUAL MONITOR CONFIGURATION IN OPENSUSE 13.1

    Quote Originally Posted by LarryStarr View Post
    It turns out that a closer look at the options in the "Autostart->System Settings->Script file->Run On" drop down provided the answer.

    I had set it to "Startup", setting it to "Pre-KDE startup", runs the script and configures the desktop prior to my session being restored.

    Hope this helps someone else.
    Great find, thanks Larry!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •