Results 1 to 3 of 3

Thread: After 12.3 -> 13.1 upgrade, kded4 does not start

  1. #1
    Join Date
    Nov 2009
    Location
    IA
    Posts
    38

    Default After 12.3 -> 13.1 upgrade, kded4 does not start

    Trying to run KDED manually I get

    Code:
    staffan@towel:~/.kde4> kded4
    Object::connect: No such signal QDBusAbstractInterface::StateChanged(uint)                                                                                                                                                                  
    Xlib:  extension "RANDR" missing on display ":0".                                                                                                                                                                                           
    Xlib:  extension "RANDR" missing on display ":0".                                                                                                                                                                                           
    Xlib:  extension "RANDR" missing on display ":0".                                                                                                                                                                                           
    Can't get XRandR version                                                                                                                                                                                                                    
    kded4: Fatal IO error: client killed                                                                                                                                                                                                        
    kded(28857): Communication problem with  "kded" , it probably crashed.                                                                                                                                                                      
    Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "

  2. #2

    Default Re: After 12.3 -> 13.1 upgrade, kded4 does not start

    Quote Originally Posted by staffantj View Post
    Trying to run KDED manually I get

    Code:
    staffan@towel:~/.kde4> kded4
    Object::connect: No such signal QDBusAbstractInterface::StateChanged(uint)                                                                                                                                                                  
    Xlib:  extension "RANDR" missing on display ":0".                                                                                                                                                                                           
    Xlib:  extension "RANDR" missing on display ":0".                                                                                                                                                                                           
    Xlib:  extension "RANDR" missing on display ":0".                                                                                                                                                                                           
    Can't get XRandR version                                                                                                                                                                                                                    
    kded4: Fatal IO error: client killed                                                                                                                                                                                                        
    kded(28857): Communication problem with  "kded" , it probably crashed.                                                                                                                                                                      
    Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "
    This looks like a graphics driver problem. Which card/driver are you using?

    Try to disable the KScreen2 service in "Configure Desktop"->"Startup and Shutdown"->"Service Management".
    Does it start then?

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: After 12.3 -> 13.1 upgrade, kded4 does not start

    On 2013-12-30 15:56, staffantj wrote:
    >
    > Trying to run KDED manually I get


    How exactly did you run the upgrade?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" (Elessar))

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •