Results 1 to 3 of 3

Thread: Yast bootloader. Does not set the active partition.. nor accept change, and cannot boot

  1. #1

    Default Yast bootloader. Does not set the active partition.. nor accept change, and cannot boot

    I installed Opensuse13.1 (64bit) on a second hard disk(sdb), as I experience many problems with Ubuntu13.10(64bit), on the first one (sda). It worked fine. I could boot Ubuntu and Opensuse dual boot using the Ubuntu boot sequence. Having lots of problems on Unbuntu I decided to abandon it and just use Opensuse. I used yast and configure the boot loader and remove the ubuntu disk. Now the system does not boot.. no problem use rescue cd and select boot linux on harddisk. It works and Opensuse boots run fine.
    I then run
    1. grub2-mkconfig -o /boot/grub2/grub.cfg (to get rid of the ubuntu settings)
    2. Yast-> bootloader. set bootloader options 'set active flag....', write generic boot code' . etc done

    a. If I run fdisk -l , Ican see that no partition is set active .. , I retried this a a few times, nothing , I need to set it with fdisk??
    b. I can change the 'boot loader location' to anything .. it says it has been change, and I can exit yast and when I return it does show my changes, but on reboot (via the rescue disk select boot linux) it always select the Custom boot option??, as if I never changed it at all . I tried this a couple of times..

    Needless to say the system cannot boot, saying .. no operation system found.

    Why can't Yast recover me?

    Thanks in advance
    Gerrie

  2. #2
    Join Date
    Sep 2012
    Posts
    7,090

    Default Re: Yast bootloader. Does not set the active partition.. nor accept change, and cannot boot

    Try first select "Do not install bootloader" in yast; save settings and exit. Then start yast bootloader again, select bootloader and configure it.

    There is a bug in yast bootloader module - some parameters are set only the very first time you call it.

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Yast bootloader. Does not set the active partition.. nor accept change, and cannot boot

    Quote Originally Posted by creatron View Post
    I installed Opensuse13.1 (64bit) on a second hard disk(sdb), as I experience many problems with Ubuntu13.10(64bit), on the first one (sda). It worked fine. I could boot Ubuntu and Opensuse dual boot using the Ubuntu boot sequence. Having lots of problems on Unbuntu I decided to abandon it and just use Opensuse. I used yast and configure the boot loader and remove the ubuntu disk. Now the system does not boot.
    What does /boot/grub2/device.map have in it? Is the entry correct?

    As for setting active, you can use the Gparted to do that (set boot flag), might help if you do that and then run

    grub2-mkconfig -o /boot/grub2/grub.cfg

    -fb
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •