Results 1 to 6 of 6

Thread: Opstartprobleem Laptop HP Compaq 6710b, Intel graphics GM965/GL960 en openSUSE 13.1

  1. #1
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    370

    Default Opstartprobleem Laptop HP Compaq 6710b, Intel graphics GM965/GL960 en openSUSE 13.1

    Graag hulp bij het volgende:

    Op bovengenoemde laptop heb ik openSUSE 12.3 met XFCE altijd zonder problemen gedraaid. Nu heb ik er openSUSE 13.1 met XFCE naast gezet en boot met GRUB2. Beide systemen starten op, maar alleen 13.1 hangt bijna altijd (ja, echt) net voor het grafische inlogscherm. En dat gebeurt ook als ik in de safety mode van 13.1 start.

    Door te switchen naar tty kanaal 1 met ctr-alt-F1 kan ik inloggen. Als gewone gebruiker kan ik dan door startx te typen niet de GUI starten. Maar door daarna met su root te worden, kan dat wel.
    Ook xdm kan ik opstarten in tty1 als root door het volgende commando te geven (tip van iemand op de releaseparty):

    Code:
    /etc/init.d/xdm restart
    Ik krijg dan het inlogscherm, log in als normale gebruiker en alles loopt normaal verder. Afsluiten gaat ook normaal. Herstarten meestal niet.



    Het gekke is dat hij af en toe wel normaal opstart, dus zonder kunstgrepen.

    Ik kom er zelf niet uit en misschien dat er bollebozen onder jullie zijn, die hier wel wat mee kunnen. Allereerst de output van de volgende commando's:
    Code:
    lspci -nnk | grep VGA -A2
    
    00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 0c)
    
        Subsystem: Hewlett-Packard Company Compaq 6710b [103c:30c0]
    
        Kernel driver in use: i915
    Code:
    uname -r
    3.11.6-4-desktop
    Code:
    rpm -qa |grep intel
    
    libdrm_intel1-2.4.46-3.2.2.x86_64
    
    vaapi-intel-driver-1.2.0-2.1.1.x86_64
    
    intel-gpu-tools-1.3-5.1.2.x86_64
    
    ucode-intel-20130906-6.2.x86_64
    
    xf86-video-intel-2.99.906-12.1.x86_64
    
    libdrm_intel1-32bit-2.4.46-3.2.2.x86_64
    De output van Xorg.0.log, geeft volgens mij niet echt iets te zien (ik ben immers na het starten van xdm gewoon opgestart), maar hier is het:
    SUSE Paste

    Eigenlijk maakt dit probleem op mij de indruk dat xdm niet de tijd krijgt om te kunnen starten, door een iets te krappe timing. Maar dat zijn slechts mijn tien centjes. Als ik verder nog iets aan info moet geven, zal ik die graag verstrekken.
    How vivid is the letting go of knowledge, where experience ends.

    Desktop AMD A6-3650 APU with Radeon(tm) HD Graphics, Leap 42.1
    Laptop HP Compaq 6710b, 64-bit, openSUSE Tumbleweed

  2. #2
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    370

    Default Probleem opgelost met acceptabele workaround

    Hoi allen,

    Zoek ik weken naar een oplossing. Plaats een forumbericht. En krijg meteen daarna de heldere ingeving dat het kan liggen aan het proces van het opstarten van het loginvenster en niet aan de Intel Driver of Systemd, wat ik eerst dacht.

    Even gezocht: er blijken veel bugs te zijn gemeld over openSUSE 13.1 geinstalleerd met XFCE als interface en het niet kunnen opstarten van de GUI, zoals hier vermeld: https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/492295-13-1-xfce-fails-display-gui-login-2.html

    Hier worden precies dezelfde problemen gemeld, zoals ik hier ook deed.

    Oplossing:
    1 Open /etc/sysconfig/displaymanager in een teksteditor
    2 Pas de regel DISPLAYMANAGER=Lightdm aan door bijvoorbeeld xdm (afgrijselijk lelijk en primitief) of gdm te kiezen. Ik had KDE er al bij geinstalleerd en heb gekozen voor kdm.
    Je krijgt dan:
    DISPLAYMANAGER=gdm
    3 Opslaan en herstarten systeem
    Als het goed is, kun je nu gewoon opstarten.

    Is het dan toch waar dat iedere vraag die je stelt een antwoord heeft dat je zelf kent, omdat je anders de vraag niet had kunnen stellen? Stik, had ik maar filosoof moeten worden in plaats van hobby-nerd.
    Maar ik heb dit probleem nu naar tevredenheid omzeild.
    How vivid is the letting go of knowledge, where experience ends.

    Desktop AMD A6-3650 APU with Radeon(tm) HD Graphics, Leap 42.1
    Laptop HP Compaq 6710b, 64-bit, openSUSE Tumbleweed

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,834

    Default Re: Opstartprobleem Laptop HP Compaq 6710b, Intel graphics GM965/GL960 en openSUSE 13.1


    Inderdaad is het niet ongebruikelijk dat het moeten formuleren van je probleem er toe leidt dat je het "ineens ziet". Een stap die je voor jezelf zo logisch vond dat je er niet eens over dacht dat je hem nam , moet je dan beschrijven en ....... eureka.

    Ik ken dat ook van vroeger als mensen met dikke pakken papier (programma lijsten, link lijsten, geheugendumps) bij je kwamen en je gingen uitleggen hoe (zij dachten dat) het werkte. Vaak riepen ze dan: "Oh, ik zie het al" (let op "al", na drie dagen zuchten en steunen) en gingen blij weer weg: "Bedankt hè". Ik begreep dan zelfs nog niet wat het probleem was.

    Het is de belangrijkste reden waarom ik mensen in draden hier probeer te dwingen om dingen uit te leggen. Om te formuleren wacht je dacht dat er zou moeten gebeuren en te beschrijven wat er in werkelijkheid gebeurde. Zelfs als het onderwerp mij niets zegt, kun je vaak al zien dat de beschrijving onvoldoende is (kort gezegd: "hij doet het niet").

    Jouw geval is een beetje anders, maar volgens mij is het feit dat je het opschrijft voor een ander, voldoende aanleiding om daarna net een anders geformuleerde Google zoek te doen. En die geeft dan ineens de oplossing.
    Henk van Velden

  4. #4
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    370

    Cool Re: Opstartprobleem Laptop HP Compaq 6710b, Intel graphics GM965/GL960 en openSUSE 13.1

    Zo is het maar net. We zullen nooit meer klagen als je om het versienummers vraagt.
    How vivid is the letting go of knowledge, where experience ends.

    Desktop AMD A6-3650 APU with Radeon(tm) HD Graphics, Leap 42.1
    Laptop HP Compaq 6710b, 64-bit, openSUSE Tumbleweed

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Probleem opgelost met acceptabele workaround

    Quote Originally Posted by akaper View Post
    Is het dan toch waar dat iedere vraag die je stelt een antwoord heeft dat je zelf kent, omdat je anders de vraag niet had kunnen stellen?
    Ja, dat is toch waar .
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Dec 2008
    Location
    Rotterdam (NL)
    Posts
    814

    Default Re: Probleem opgelost met acceptabele workaround

    Quote Originally Posted by akaper View Post

    Is het dan toch waar dat iedere vraag die je stelt een antwoord heeft dat je zelf kent, omdat je anders de vraag niet had kunnen stellen? Stik, had ik maar filosoof moeten worden in plaats van hobby-nerd.

    Tjonge, eind van het jaar komt eraan en meneer wordt filosofisch.
    Voorzichtig daarmee hoor.
    HP Z420 Intel Xeon & Lenovo T440s Intel I7vPro
    openSUSE Tumbleweed KDE
    Raspberry PI3 met openSUSE TW en Raspbian
    Linux counter #241023

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •