Results 1 to 8 of 8

Thread: Font/Background issue in the search input field in the Kickoff

  1. #1
    Join Date
    Oct 2013
    Location
    Dortmund
    Posts
    32

    Default Font/Background issue in the search input field in the Kickoff

    Hi all,

    in the last time I've noticed some strange changes of the theme in the Kickoff menu as well as in the screen unlocking dialog. This change could have happened during the upgrade from openSuse 12.3 to 13.1, but I'm not sure about it.

    The problem is, that the background of the TextEdit for search string in the Kickoff menu as well as of the password input field became pretty dark color, so that the entered text (with the used black font) become barely readable. See the example on the screen short under link (by the way: I haven't found a possibility to attach the screen short directly to the post - no permissions to post attachments).
    https://drive.google.com/file/d/0B3p...it?usp=sharing

    I thought it could lay on some settings changes in the KDE system settings, but the attempt to restore the original settings didn't help.

    What do you think it could be and how to correct it?

    BR/Konstantin

  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Font/Background issue in the search input field in the Kickoff

    what colour is configure desktop > application appearance > colours > colours > view background set to?

    I guess you could also test by switching to a different colour scheme to see if that makes a difference.

    edit: to add pics you can use any hosting site and then just add [img] tags to link to it

    or alternatively use susepaste

    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  3. #3

    Default Re: Font/Background issue in the search input field in the Kickoff

    Quote Originally Posted by farcusnz View Post
    what colour is configure desktop > application appearance > colours > colours > view background set to?

    I guess you could also test by switching to a different colour scheme to see if that makes a difference.

    edit: to add pics you can use any hosting site and then just add [img] tags to link to it

    or alternatively use susepaste

    Good idea, but this can't really be the reason, since that color also influences the rest of Kickoff's background, which should be black then as well.

    But I could reproduce the OP's problem by setting KDE Style to "Gtk+ Style" in "Configure Desktop"->"Application Appearance"->"Style".
    So have a look there and try to select a different style.

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Font/Background issue in the search input field in the Kickoff

    there are some issues with dark colour schemes / themes in KDE

    e.g.

    I have a modified dark colour scheme but in some applications the colour scheme seems to be ignored.



    all of the backgrounds above should be white as per my settings but in Amarok and a couple of other apps it doesn't work.

    There is a bug report on it that I can't seem to locate just now
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  5. #5

    Default Re: Font/Background issue in the search input field in the Kickoff

    Quote Originally Posted by farcusnz View Post
    there are some issues with dark colour schemes / themes in KDE
    Possible, yes. Those are style/theme/application specific though.
    But kickoff does use the "view color" for its whole background and this is apparently white in the OP's screenshot, so this cannot be the cause for his problem.

    And the widget style can use a different background color if it wants to (oxygen does use that "view color" you suggested, Gtk+-Style apparently does not), so that's why I suggested that. (and again, I could reproduce the exact same problem as in the OP's screen shot...)

  6. #6
    Join Date
    Oct 2013
    Location
    Dortmund
    Posts
    32

    Default Re: Font/Background issue in the search input field in the Kickoff

    Hi all,

    I've tested the option proposed by farcusnz, but the colour under "configure desktop > application appearance > colours > colours > view background" was white. Playing with the colour themes has only shown, that some themes could deliver a "workaround", cause of the bright font (i.e. white).

    As I've tried the proposal of wolfi323, I've noticed the following: switching to GTK+ Style haven't changed anything, then I've tested all of the remaining themes, including the original one (Oxygen). I've tested CDE first and then MS Windows 9x and the effect were not present. After that I could only reproduce the effect by setting the style to "GTK+ Style". Restoring the default settings (to Oxygen) haven't restored an annoying effect also.

    So the issue is solved for me. (I don't need the GTK+ Style )

    Thanks a lot.

  7. #7
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Font/Background issue in the search input field in the Kickoff

    as the issue is easily reproducible with the gtk+ style perhaps you should file a bug report (if there isn't already one there)

    openSUSE:Submitting bug reports - openSUSE
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  8. #8
    Join Date
    Oct 2013
    Location
    Dortmund
    Posts
    32

    Default Re: Font/Background issue in the search input field in the Kickoff

    Quote Originally Posted by farcusnz View Post
    as the issue is easily reproducible with the gtk+ style perhaps you should file a bug report (if there isn't already one there)

    openSUSE:Submitting bug reports - openSUSE
    Link to the bug report:
    https://bugzilla.novell.com/show_bug.cgi?id=857129

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •