Results 1 to 2 of 2

Thread: nvidia driver install failure while trying to install bumblebee

  1. #1

    Default nvidia driver install failure while trying to install bumblebee

    I'm trying to re-install bumblebee after previously removing it. I'm following the instructions located here. The problem I am having is that I don't think zypper is downloading the nvidia driver. Here is the output from zypper I am receiving:
    Code:
    zypper in dkms dkms-nvidia dkms-bbswitch bumblebee primus x11-video-nvidia
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following NEW packages are going to be installed:
      bumblebee dkms dkms-bbswitch dkms-nvidia primus VirtualGL x11-video-nvidia 
    
    7 new packages to install.
    Overall download size: 1.1 MiB. After the operation, additional 3.6 MiB will be used.
    Continue? [y/n/? shows all options] (y): y
    Retrieving package dkms-2.2.0.3-14.1.noarch                                                          (1/7),  72.1 KiB (212.2 KiB unpacked)
    Retrieving: dkms-2.2.0.3-14.1.noarch.rpm ..............................................................................[done (74.5 KiB/s)]
    (1/7) Installing: bumblebee-3.2.1-14.1 .............................................................................................[done]
    (2/7) Installing: dkms-2.2.0.3-14.1 ................................................................................................[done]
    (3/7) Installing: x11-video-nvidia-331.20-2.1 .....................................................................................[error]
    Installation of x11-video-nvidia-331.20-2.1 failed:
    Error: Subprocess failed. Error: RPM failed: Error in checksums 3653315506 3635253084
    error: %pre(x11-video-nvidia-331.20-2.1.x86_64) scriptlet failed, exit status 254
    error: x11-video-nvidia-331.20-2.1.x86_64: install failed
    zypper doesn't appear to even attempt to download the nvidia driver and immediately returns a checksum error. This happens even if I try to only download the nvidia driver and nothing else. I did get this to work previously, but now I cannot retrieve this driver for some reason. Also, I attempted to download it from the nvidia repository, but there is a broken dependency problem there so that doesn't work either. Is there any way to "force" it to re-download the driver?

  2. #2

    Default Re: nvidia driver install failure while trying to install bumblebee

    Ok, nevermind. I looked again at the nVidia repo and their x11-video driver is only 495B and has a broken dependency. That must be what the problem is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •