Results 1 to 5 of 5

Thread: Why psmouse.proto=bare?

  1. #1
    Join Date
    Apr 2010
    Location
    Warsaw, Poland
    Posts
    202

    Question Why psmouse.proto=bare?

    Why do you specify psmouse.proto=bare in the boot loader settings?
    The net result is that I cannot paste in X Windows because the server thinks I have 3 buttons while I have only 2 (and it is a touch pad, not a mouse)

    Kernel command line: root=/dev/sda3 resume=/dev/disk/by-id/ata-FUJITSU_MHT2040AH_PL_NP0ST562MG70-part1 splash=silent quiet apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare irqpoll pci=nommconf vga=0x317
    Hardware name: ASUSTeK Computer Inc. A9Rp /A9Rp , BIOS 104 07/06/2006
    i8042: PNP: No PS/2 controller found. Probing ports directly.
    serio: i8042 AUX port at 0x60,0x64 irq 12
    mousedev: PS/2 mouse device common for all mice
    input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input1

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Why psmouse.proto=bare?

    On 2013-12-28 16:46, yecril71pl wrote:
    >
    > Why do you specify psmouse.proto=bare in the boot loader settings?
    > The net result is that I cannot paste in X Windows because the server
    > thinks I have 3 buttons while I have only 2 (and it is a touch pad, not
    > a mouse)


    Who is the 'you' in that paragraph?
    What openSUSE version are you using, and how did you install it?

    I have very little idea what you are talking about, because you start suddenly without explanations,
    no context. Please explain your problem better.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" (Elessar))

  3. #3
    Join Date
    Apr 2010
    Location
    Warsaw, Poland
    Posts
    202

    Post Re: Why psmouse.proto=bare?

    I use openSUSE 13.1 32-bit and I upgraded it from 12.3 using network installer CD.
    I am told it happened because I installed failsafe.
    I wanted the installer to run failsafe, not to install a failsafe system.
    How do I revert system parameters to normal?

  4. #4
    Join Date
    Apr 2010
    Location
    Warsaw, Poland
    Posts
    202

    Lightbulb Re: Why psmouse.proto=bare?

    I told YaST to generate a new boot loader configuration and it does not mention psmouse.proto, not even in failsafe. Hopefully it will work.
    Last edited by yecril71pl; 28-Dec-2013 at 09:46. Reason: details

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Why psmouse.proto=bare?

    On 2013-12-28 17:46, yecril71pl wrote:
    >
    > I told YaST to generate a new boot loader configuration. Hopefully it
    > will work.


    If not, assuming you have grub2, you have to edit "/etc/default/grub". There will be two entries
    similar to these of mine:

    Code:
    
    > # If you change this file, run 'grub2-mkconfig -o /boot/grub2/grub.cfg' afterwards to update
    ....
    > GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/disk/by-label/b_swap splash=verbose showopts"
    > # kernel command line options for failsafe mode
    > GRUB_CMDLINE_LINUX_RECOVERY="showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe"
    Your default line will have more entries. You have to remove entries one by one, apply the changes
    (using the command line the first comment says), and reboot to test. If it does not boot, then use
    the failsafe entry to boot, and add back the entry you removed.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" (Elessar))

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •