Results 1 to 7 of 7

Thread: xorg randomly crashes after update this morning

  1. #1

    Default xorg randomly crashes after update this morning

    I am running openSUSE 13.1 for a week now without any problems. This is a fresh install. This morning I installed an update for xorg, since then X randomly crashes, e.g. when using chrome to access facebook, google searches, ...
    Here is what I could find in the logs: https://dl.dropboxusercontent.com/u/6669000/Xorg.0.log

    UPDATE: below are the last updates that were applied:
    xorg-x11-server-7.6_1.14.3.901-4.1.x86_64 Sat 28 Dec 2013 06:44:42 AM CET
    openssl-1.0.1e-11.5.1.x86_64 Thu 26 Dec 2013 06:51:58 PM CET

    so the xorg update is the culprit

  2. #2

    Default Re: xorg randomly crashes after update this morning

    Just found a solution somewhere on the internet (https://bugzilla.redhat.com/show_bug.cgi?id=947527).
    Seems, as an NVIDIA user, you need to replace libglx.so from xorg with the one provide from NVIDIA. So:
    - goto: /usr/lib64/xorg/modules/extensions
    - create a backup: sudo mv libglx.so libglx.so_orig
    - symlink the NVIDIA library: sudo ln -s libglx.so.325.15 libglx.so
    - done

    Please note, the libglx.so.325.15 might be named differently, depending on the version of the NVIDIA driver you have installed.

    System seems stable for now.

  3. #3

    Default Re: xorg randomly crashes after update this morning

    Quote Originally Posted by kennywest View Post
    Just found a solution somewhere on the internet (https://bugzilla.redhat.com/show_bug.cgi?id=947527).
    Seems, as an NVIDIA user, you need to replace libglx.so from xorg with the one provide from NVIDIA. So:
    - goto: /usr/lib64/xorg/modules/extensions
    - create a backup: sudo mv libglx.so libglx.so_orig
    - symlink the NVIDIA library: sudo ln -s libglx.so.325.15 libglx.so
    - done
    Something similar can happen if you install a Mesa update, because the nvidia driver also overwrites Mesa's libGL.

    Or just install the driver using the RPMs from the official repo and you don't have to worry about such things.

  4. #4
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,127

    Default Re: xorg randomly crashes after update this morning

    I've had so much trouble with Nvidia that I freaked when Chrome crashed on me this morning. I saw that an xorg update got pulled in with some other update but everything seemed ok until the Chrome crashes began.

    I followed the procedure in this thread, substituting the driver number (304.88) that was in the directory for the number listed in the procedure. Chrome is working again but another annoyance surfaced. On the desktop, color transitions are not smooth. They jump in discrete steps with an outline between; sort of like a terrain map. I'll live with it until an update fixes the problem.

    Thanks for the tip.
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: xorg randomly crashes after update this morning

    An application crash is not autocratically a Video driver problem You may be chasing ghosts.

  6. #6

    Default Re: xorg randomly crashes after update this morning

    An application crash is not autocratically a Video driver problem You may be chasing ghosts.
    No. I never said it was a video problem. I think the problem is the xorg update overwrites the glx library. So after every xorg update, you should follow my procedure to make sure you're using NVIDIA's library again, or manually install the driver again. As already said by wolfi323 you will probably not have this problem if you use openSUSE's installer for the driver.
    And no, it is not a ghost, but perfectly reproducable:
    - open chrome
    - goto google.com
    - search "LEGO the movie"
    - bam, X crashes


    I followed the procedure in this thread, substituting the driver number (304.88) that was in the directory for the number listed in the procedure. Chrome is working again but another annoyance surfaced. On the desktop, color transitions are not smooth. They jump in discrete steps with an outline between; sort of like a terrain map. I'll live with it until an update fixes the problem.
    304.88 is quite old, you may have better luck with a newer version.

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: xorg randomly crashes after update this morning

    I was replying to Prexy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •