Results 1 to 4 of 4

Thread: Xserver is crashed!!

  1. #1

    Unhappy Xserver is crashed!!

    Hi I was trying to start x server in my OpenSuse system but it seems it's not starting 'coz of some error, as am a newbie to Suse am not able to find out what to do,even yast/yast2 is also not working. Errors are as follows:

    BXXXXXX1019:~ # startx
    xauth: file /root/.serverauth.17656 does not exist
    xauth: file /root/.Xauthority does not exist
    xauth: file /root/.Xauthority does not exist




    X.Org X Server 1.10.4
    Release Date: 2011-08-19
    X Protocol Version 11, Revision 0
    Build Operating System: openSUSE SUSE LINUX
    Current Operating System: Linux BG6HANA1019 3.1.10-1.29-desktop #1 SMP PREEMPT Fri May 31 20:10:04 UTC 2013 (2529847) x86_64
    Kernel command line: root=/dev/system/root resume=/dev/system/swap splash=silent quiet vga=0x31a
    Build Date: 01 May 2013 01:18:35AM


    Current version of pixman: 0.24.0
    Before reporting problems, check xorg
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec 26 21:49:50 2013
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) Using config directory: "/etc/X11/xorg.conf.d"
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    (EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/evdev
    (EE) XKB: Failed to load keymap. Loading default keymap instead.
    (EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/evdev
    XKB: Failed to compile keymap
    Keyboard initialization failed. This could be a missing or incorrect setup of xkeyboard-config.


    Fatal server error:
    Failed to activate core devices.


    Please consult the The X.Org Foundation support
    at xorg
    for help.
    Please also check the log file at "/var/log/Xorg.0.log" for additional information.


    xinit: giving up
    xinit: unable to connect to X server: Connection refused
    xinit: server error
    -------------------------------------------------------------------------------------------
    xinit failed. /usr/bin/Xorg is not setuid, maybe that's the reason?
    If so either use a display manager (strongly recommended) or adjust /etc/permissions.local
    BXXXXXX1019:~ #

    Error For Yast & Yast2 is :

    BXXXXXX1019:~ # yast
    No such client module menu
    The search path follows. It does not include the current directory.
    /y2update/clients
    /root/.yast2/clients
    /usr/share/YaST2/clients


    Run 'yast2 -h' for help on usage
    BG6HANA1019:~ # yast2
    No such client module menu
    The search path follows. It does not include the current directory.
    /y2update/clients
    /root/.yast2/clients
    /usr/share/YaST2/clients


    Run 'yast2 -h' for help on usage
    BXXXXXX1019:~ #

    Please help to rectify these two things. Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,779

    Default Re: Xserver is crashed!!

    Hello and welcome here.

    Please, bcause we are not clairvoyant, allways tell at least what version of openSUSE you use.

    Also, to get readable computer output in your posts here, please use CODE tags around the copied/pasted computer texts. You getthe CODE tags by cllicking on the # button in the tool bar of the post editor.

    And to get a bit of understanding what you are doing and why, it could be of interest to tell why you are trying to start X "manualy". In most installations, X and the display manager just start when the installation was correct.
    Henk van Velden

  3. #3

    Default Re: Xserver is crashed!!

    Thanks Henk for the tip, Next time onward will take care of the CODE tag, I'm trying to start - startx manually because it's not starting automatically. even though the system is running in run level 5.
    Code:
    BXXXXXXXX19:~ # yast2No such client module menu
    The search path follows. It does not include the current directory.
      /y2update/clients
      /root/.yast2/clients
      /usr/share/YaST2/clients
    
    
    Run 'yast2 -h' for help on usage
    BXXXXXXXX19:~ #
    Even yast is not starting, It's kind of latest version only, I'm using OpenSuse 12.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,779

    Default Re: Xserver is crashed!!

    This does not help your potential helpers to much, I am afraid.
    Saying version 12. is insufficient. When you forgot what it is then use
    Code:
    cat /etc/os-release
    Then you seem to have two problems (X not starting at runlevel 5 and yast giving eror messages).. Please one problem in a thread. else answers will be mixed and in no time it will be a confusing thread.

    And I have a strong idea that you are offering us a case of talking about the step, but not asking about the problem. The problem is: X does not start on my system when booting in runlevel 5. You are trying to circumvent this by doing some tinkering (it is realy years ago that I heard of people trying to use startx from the command line) and then asking about problems with the tinkering. My idea is that you (with help from the Forums) should try to corner the main problem.

    And for cornering the main problem a better thread title would have been more illuminating to get the best people reading your thread. Apart from your openSUSE version, they would like to know if this "X not starting" problem is there right after the intallation, or did it work earlier?
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •