Results 1 to 10 of 10

Thread: Help building Wine

  1. #1
    Join Date
    Dec 2013
    Location
    Portugal
    Posts
    7

    Default Help building Wine

    Hi everyone!

    I'm trying to build Wine in openSUSE 13.1 x86_64 but i cannot find some dependencies that i need. In the past i found all dependencies but for this version of openSUSE i can't found some packages. Here the list of packages that i cannot found (i found them in other repositories from other distros but i don't want to change some of my system packages version for install them):

    configure: OpenCL 32-bit development files not found, OpenCL won't be supported.
    configure: libhal 32-bit development files not found, no legacy dynamic device support.
    configure: libsane 32-bit development files not found, scanners won't be supported.
    configure: libv4l 32-bit development files not found.
    configure: libgphoto2 32-bit development files not found, digital cameras won't be supported.
    configure: libgphoto2_port 32-bit development files not found, digital cameras won't be auto-detected.
    configure: gstreamer-0.10 base plugins 32-bit development files not found, gstreamer support disabled
    configure: OSS sound system found but too old (OSSv4 needed), OSS won't be supported.
    configure: libcapi20 32-bit development files not found, ISDN won't be supported.

    I know that i can download the sources and install them my self but i'm afraid that i brick my OS.

    So if someone who compile Wine in this version of openSUSE give me the list of his repository's i will be eternally grateful.

    Thaks in advance! (PS. sorry for my English)

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: Help building Wine

    On Wed, 25 Dec 2013 23:16:01 +0000, cientista99 wrote:

    > I'm trying to build Wine in openSUSE 13.1 x86_64


    Why? There are plenty of builds in OBS - just go to http://
    software.opensuse.org, search for WINE, and install (if the one that's in
    the standard repos isn't new enough for you, that is).

    It's rare to *need* to build anything modern like this these days, unless
    there's some specific reason you want to build it.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: Help building Wine

    cientista99 wrote:

    >
    > Hi everyone!
    >
    > I'm trying to build Wine in openSUSE 13.1 x86_64 but i cannot find
    > some dependencies that i need. In the past i found all dependencies
    > but for this version of openSUSE i can't found some packages. Here the
    > list of packages that i cannot found (i found them in other
    > repositories from other distros but i don't want to change some of my
    > system packages version for install them):
    >
    > *configure: OpenCL 32-bit development files not found, OpenCL won't be
    > supported.
    > configure: libhal 32-bit development files not found, no legacy
    > dynamic device support.
    > configure: libsane 32-bit development files not found, scanners won't
    > be supported.
    > configure: libv4l 32-bit development files not found.
    > configure: libgphoto2 32-bit development files not found, digital
    > cameras won't be supported.
    > configure: libgphoto2_port 32-bit development files not found, digital
    > cameras won't be auto-detected.
    > configure: gstreamer-0.10 base plugins 32-bit development files not
    > found, gstreamer support disabled
    > configure: OSS sound system found but too old (OSSv4 needed), OSS
    > won't be supported.
    > configure: libcapi20 32-bit development files not found, ISDN won't be
    > supported.
    >
    > *I know that i can download the sources and install them my self but
    > i'm afraid that i brick my OS.
    >
    > So if someone who compile Wine in this version of openSUSE give me the
    > list of his repository's i will be eternally grateful.
    >
    > Thaks in advance! (PS. sorry for my English)
    >

    What repo's are you using for wine? I see no dependence problems when
    usin the normal 13.1 repo's with YaST.

    CODE
    ---------
    http://download.opensuse.org/debug/update/13.1-non-oss/
    http://download.opensuse.org/distrib...13.1/repo/oss/
    http://download.opensuse.org/update/13.1/
    http://download.opensuse.org/update/13.1-non-oss/
    ----------
    I selected both 64 bit and 32 bit versions of wine.

    Hope this relps.

    Russ
    --
    openSUSE 13.1 (3.11.6-4-desktop)| GIGABYTE Z87-D3HP (Intel(R)
    Quad Core(TM) i5-4440 CPU @ 3.10GHz)|8GB DDR3|GeForce 8400GS
    (NVIDIA-Linux-x86_64-331.20)|KDE 4.12.0


  4. #4
    Join Date
    Dec 2013
    Location
    Portugal
    Posts
    7

    Default Re: Help building Wine

    Quote Originally Posted by hendersj View Post
    On Wed, 25 Dec 2013 23:16:01 +0000, cientista99 wrote:

    > I'm trying to build Wine in openSUSE 13.1 x86_64


    Why? There are plenty of builds in OBS - just go to http://
    software.opensuse.org, search for WINE, and install (if the one that's in
    the standard repos isn't new enough for you, that is).

    It's rare to *need* to build anything modern like this these days, unless
    there's some specific reason you want to build it.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at openSUSE Forums FAQ
    Hi!

    i know there are plenty of builds in OBS and i'm using the latest Wine from openSUSE repository but i need to apply a patch and for that i need to compile it. In older versions of openSUSE e found every dependencies for that but in this version i can't find the ones i describe in our repositories. (I can compile without them but i want a full working build if possible.)

    I found them in other repositories from another distro but i just don't want to mix versions of packages in my system right now. So if someone who build Wine in openSUSE 13.1 can give me his list of repositories i will be very thankful...

  5. #5
    Join Date
    Dec 2013
    Location
    Portugal
    Posts
    7

    Default Re: Help building Wine

    Quote Originally Posted by upscope View Post
    cientista99 wrote:

    >
    > Hi everyone!
    >
    > I'm trying to build Wine in openSUSE 13.1 x86_64 but i cannot find
    > some dependencies that i need. In the past i found all dependencies
    > but for this version of openSUSE i can't found some packages. Here the
    > list of packages that i cannot found (i found them in other
    > repositories from other distros but i don't want to change some of my
    > system packages version for install them):
    >
    > *configure: OpenCL 32-bit development files not found, OpenCL won't be
    > supported.
    > configure: libhal 32-bit development files not found, no legacy
    > dynamic device support.
    > configure: libsane 32-bit development files not found, scanners won't
    > be supported.
    > configure: libv4l 32-bit development files not found.
    > configure: libgphoto2 32-bit development files not found, digital
    > cameras won't be supported.
    > configure: libgphoto2_port 32-bit development files not found, digital
    > cameras won't be auto-detected.
    > configure: gstreamer-0.10 base plugins 32-bit development files not
    > found, gstreamer support disabled
    > configure: OSS sound system found but too old (OSSv4 needed), OSS
    > won't be supported.
    > configure: libcapi20 32-bit development files not found, ISDN won't be
    > supported.
    >
    > *I know that i can download the sources and install them my self but
    > i'm afraid that i brick my OS.
    >
    > So if someone who compile Wine in this version of openSUSE give me the
    > list of his repository's i will be eternally grateful.
    >
    > Thaks in advance! (PS. sorry for my English)
    >

    What repo's are you using for wine? I see no dependence problems when
    usin the normal 13.1 repo's with YaST.

    CODE
    ---------
    Index of /debug/update/13.1-non-oss
    Index of /distribution/13.1/repo/oss
    Index of /update/13.1
    Index of /update/13.1-non-oss
    ----------
    I selected both 64 bit and 32 bit versions of wine.

    Hope this relps.

    Russ
    --
    openSUSE 13.1 (3.11.6-4-desktop)| GIGABYTE Z87-D3HP (Intel(R)
    Quad Core(TM) i5-4440 CPU @ 3.10GHz)|8GB DDR3|GeForce 8400GS
    (NVIDIA-Linux-x86_64-331.20)|KDE 4.12.0
    Hi again.

    Sorry to insist but i don't have any problem in using Wine. It works fine with the default repositories. But i want to build it myself and for that i can't find that dependencies...

    Thats why im asking to someone o build Wine in this version of openSUSE to give me his list of repositories if possible...

    Thanks

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Help building Wine

    You can get at least the dependencies for the actual wine version you
    use with
    Code:
    zypper si -d wine
    that installs the build dependencies used by the wine you installed from
    the repository.
    It will be sipmpler to figure out after that if there is still something
    missing for the version you want to patch and build after that than to
    start from scratch figuring out what you need.
    Or you can look at the spec file for the wine rpm in the build service
    which also lists the build dependencies.

    --
    PC: oS 13.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.11 | GTX 650 Ti
    ThinkPad E320: oS 13.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.11 | HD 3000
    HTPC: oS 13.1 x86_64 | Celeron@1.8GHz | 2GB | Gnome 3.10 | HD 2500

  7. #7
    Join Date
    Dec 2013
    Location
    Portugal
    Posts
    7

    Default Re: Help building Wine

    Quote Originally Posted by martin_helm View Post
    You can get at least the dependencies for the actual wine version you
    use with
    Code:
    zypper si -d wine
    that installs the build dependencies used by the wine you installed from
    the repository.
    It will be sipmpler to figure out after that if there is still something
    missing for the version you want to patch and build after that than to
    start from scratch figuring out what you need.
    Or you can look at the spec file for the wine rpm in the build service
    which also lists the build dependencies.

    --
    PC: oS 13.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.11 | GTX 650 Ti
    ThinkPad E320: oS 13.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.11 | HD 3000
    HTPC: oS 13.1 x86_64 | Celeron@1.8GHz | 2GB | Gnome 3.10 | HD 2500
    I hit that command and ii installed some dependencies but when i download the wine source form winehq and do configure it still complains about those dependencies:

    configure: OpenCL 32-bit development files not found, OpenCL won't be supported.
    configure: libhal 32-bit development files not found, no legacy dynamic device support.
    configure: libsane 32-bit development files not found, scanners won't be supported.
    configure: libv4l 32-bit development files not found.
    configure: libgphoto2 32-bit development files not found, digital cameras won't be supported.
    configure: libgphoto2_port 32-bit development files not found, digital cameras won't be auto-detected.
    configure: gstreamer-0.10 base plugins 32-bit development files not found, gstreamer support disabled
    configure: OSS sound system found but too old (OSSv4 needed), OSS won't be supported.
    configure: libcapi20 32-bit development files not found, ISDN won't be supported.

    When i search in repositories or software.opensuse.org for them i have no luck in founding that devel packages...

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Help building Wine

    Am 27.12.2013 20:46, schrieb cientista99:
    >
    > *When i search in repositories or software.opensuse.org for them i have
    > no luck in founding that devel packages...
    >

    Why do you think you need them?

    These are optional things, some of them so outdated that you probably
    will not even find it for openSUSE (hal for example, oss is also from
    stoneage).

    Some others are easy to find like libv4l-devel + the 32bit packages,
    gstreamer-0_10-plugins-base-devel + 32 bit packages and so on.
    But do you really need that functionality?
    It just will compile wine without that features.

    --
    PC: oS 13.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.11 | GTX 650 Ti
    ThinkPad E320: oS 13.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.11 | HD 3000
    HTPC: oS 13.1 x86_64 | Celeron@1.8GHz | 2GB | Gnome 3.10 | HD 2500

  9. #9
    Join Date
    Dec 2013
    Location
    Portugal
    Posts
    7

    Default Re: Help building Wine

    Quote Originally Posted by martin_helm View Post
    Am 27.12.2013 20:46, schrieb cientista99:
    >
    > *When i search in repositories or software.opensuse.org for them i have
    > no luck in founding that devel packages...
    >

    Why do you think you need them?

    These are optional things, some of them so outdated that you probably
    will not even find it for openSUSE (hal for example, oss is also from
    stoneage).

    Some others are easy to find like libv4l-devel + the 32bit packages,
    gstreamer-0_10-plugins-base-devel + 32 bit packages and so on.
    But do you really need that functionality?
    It just will compile wine without that features.

    --
    PC: oS 13.1 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.11 | GTX 650 Ti
    ThinkPad E320: oS 13.1 x86_64 | i3@2.30GHz | 8GB | KDE 4.11 | HD 3000
    HTPC: oS 13.1 x86_64 | Celeron@1.8GHz | 2GB | Gnome 3.10 | HD 2500
    Ok then...

    I will build without these packages. As you say some are very old and probably i will not need them.
    Thanks for your patience!

  10. #10
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: Help building Wine

    Post from the ignorant here but cant you just branch a package/repo from OBS to your home repo, apply the patches/additional features that you need there and then just add that repo in yast/zypper?
    openSUSE Leap (42.1) 64 bit
    Plasma 5.4

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •