Results 1 to 10 of 10

Thread: Samba, name resolution problem: file or folder not exist

  1. #1

    Default Samba, name resolution problem: file or folder not exist

    Opensuse 13.1
    Hi all,
    I have a problem with the names resolution after the hostname changing, old hostname Vaio in new hostname Netbook
    I can browse my shares only with IP or adding the shared folder after the server folder
    does anyone know to explain how to restore access to the folder Netbook

    cat /etc/HOSTNAME
    Netbook

    cat /etc/hosts
    127.0.0.1 localhost
    192.168.1.100 Netbook
    192.168.1.101 Pentium
    192.168.1.102 Tablet
    ....
    cat /etc/samba/lmhosts
    127.0.0.1 localhost
    192.168.1.100 Netbook
    192.168.1.101 Pentium
    192.168.1.102 Tablet

    Netbook:/home/ivan # ping netbook = OK
    Netbook:/home/ivan # ping 192.168.1.100 = OK


    Netbook:/home/ivan # smbtree
    interpret_interface: using netmask value 255.255.255.0 from config file on interface wlp1s0
    added interface wlp1s0 ip=192.168.1.100 bcast=192.168.1.255 netmask=255.255.255.0
    added interface lo ip=127.0.0.1 bcast=127.255.255.255 netmask=255.0.0.0
    Enter ivan's password:
    name_resolve_bcast: Attempting broadcast lookup for name WORKGROUP<0x1d>
    Got a positive name query response from 127.0.0.1 ( 192.168.1.100 )
    samba_tevent: EPOLL_CTL_DEL EBADF for fde[0xb7f7c298] mpx_fde[(nil)] fd[9] - disabling
    Connecting to 192.168.1.100 at port 445
    Doing spnego session setup (blob length=74)
    got OID=1.3.6.1.4.1.311.2.2.10
    got principal=not_defined_in_RFC4178@please_ignore
    Got challenge flags:
    Got NTLMSSP neg_flags=0x608a8215
    NTLMSSP: Set final flags:
    Got NTLMSSP neg_flags=0x60088215
    NTLMSSP Sign/Seal - Initialising with flags:
    Got NTLMSSP neg_flags=0x60088215
    WORKGROUP
    Connecting to 192.168.1.100 at port 445
    Doing spnego session setup (blob length=74)
    got OID=1.3.6.1.4.1.311.2.2.10
    got principal=not_defined_in_RFC4178@please_ignore
    Got challenge flags:
    Got NTLMSSP neg_flags=0x608a8215
    NTLMSSP: Set final flags:
    Got NTLMSSP neg_flags=0x60088215
    NTLMSSP Sign/Seal - Initialising with flags:
    Got NTLMSSP neg_flags=0x60088215
    \\XAVN2001-874601 NETGEAR XAVN2001
    name_resolve_bcast: Attempting broadcast lookup for name XAVN2001-874601<0x20>
    Got a positive name query response from 192.168.1.128 ( 192.168.1.128 )
    samba_tevent: EPOLL_CTL_DEL EBADF for fde[0xb7f7f658] mpx_fde[(nil)] fd[12] - disabling
    Connecting to 192.168.1.128 at port 445
    Connecting to 192.168.1.128 at port 139
    \\NETBOOK 0.0.0.0_smb_4.1.3-3.12.1-3127-SUSE-oS13.1-i386
    name_resolve_bcast: Attempting broadcast lookup for name NETBOOK<0x20>
    Got a positive name query response from 192.168.1.100 ( 192.168.1.100 )
    samba_tevent: EPOLL_CTL_DEL EBADF for fde[0xb7f7f748] mpx_fde[(nil)] fd[12] - disabling
    Connecting to 192.168.1.100 at port 445
    Doing spnego session setup (blob length=74)
    got OID=1.3.6.1.4.1.311.2.2.10
    got principal=not_defined_in_RFC4178@please_ignore
    Got challenge flags:
    Got NTLMSSP neg_flags=0x608a8215
    NTLMSSP: Set final flags:
    Got NTLMSSP neg_flags=0x60088215
    NTLMSSP Sign/Seal - Initialising with flags:
    Got NTLMSSP neg_flags=0x60088215
    \\NETBOOK\ivan netbook/ivan_on_192.168.1.100
    \\NETBOOK\CUPS-PDF CUPS-PDF
    \\NETBOOK\IPC$ IPC Service (192.168.1.100_smb_4.1.3-3.12.1-3127-SUSE-oS13.1-i386)
    \\NETBOOK\printer$ netbook/drivers_on_192.168.1.100
    \\NETBOOK\PrinterPDF netbook/PrinterPDF_on_192.168.1.100
    \\NETBOOK\PrinterHP PrinterHP
    \\NETBOOK\NetTrash netbook/NetTrash_on_192.168.1.100
    \\NETBOOK\Public netbook/Public_on_192.168.1.100
    \\NETBOOK\Shared netbook/Shared_on_192.168.1.100
    \\NETBOOK\Users netbook/users_on_192.168.1.100


    Using Dolphin I get:
    smb://netbook/ .....file or folder smb://netbook/ does not exist.
    smb://netbook/Shared/ ...I can see all the shared folders
    smb://192.168.1.100/ ...I can see all the shared folders


    Using Dolphin smbclient I gett:
    Netbook:/home/ivan # smbclient //netbook/ -U ivan
    Enter ivan's password:
    Netbook:/home/ivan # .....file or folder smb://netbook/ does not exist.

    Netbook:/home/ivan # smbclient //Netbook/Shared/ -U ivan ...I can see all the shared folders
    Enter ivan's password:
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 4.1.3-3.12.1-3127-SUSE-oS13.1-i386]
    smb: \> ls
    . D 0 Tue Dec 10 00:34:12 2013
    .. D 0 Thu Dec 12 19:06:12 2013
    Drivers D 0 Sat Mar 16 22:04:07 2013
    Music D 0 Sun Oct 20 15:27:56 2013
    Configurazioni D 0 Sun Nov 17 13:48:34 2013
    Games D 0 Sat Dec 15 10:10:14 2012
    Videos D 0 Sun Oct 20 16:31:19 2013
    Progetti D 0 Sun Mar 31 15:49:48 2013
    Bookmarks D 0 Mon Nov 18 18:23:10 2013
    Documents D 0 Sun Oct 20 13:09:13 2013
    Images D 0 Sun Jan 6 20:23:42 2013
    50331 blocks of size 2097152. 44769 blocks available
    smb: \>

    smb.conf:
    [global]
    ;============== identity ==============
    workgroup = WORKGROUP
    netbios name = Netbook
    server string = %i_smb_%v
    comment = SonyVaio netbook
    ;============== security ==============
    security = user
    ;=========== name resolution ==========
    include = /etc/samba/dhcp.conf
    preferred master = yes
    local master = yes
    os level = 65
    wins support = Yes
    dns proxy = no
    name resolve order = wins bcast lmhosts hosts
    domain master = Auto
    domain logons = No
    ;================ users ===============
    username map = /etc/samba/smbusers
    smb passwd file = /etc/samba/smbpasswd
    passdb backend = tdbsam
    encrypt passwords = Yes
    ; definire regole password
    ; password level = Yes
    ; password level = 2
    ; invalid users = root
    guest account = guest
    map to guest = Bad User
    usershare allow guests = Yes
    ; idmap gid = 10000-20000 ...deprecated
    ; idmap uid = 10000-20000 ...deprecated
    ;================ hosts ================
    hostname lookups = No
    hosts allow = 192.168.
    hosts deny = ALL EXCEPT 192.168.
    interfaces = 192.168.1.0/255.255.255.0 127.0.0.1
    ; interfaces = eth0 lo
    bind interfaces only = Yes
    ;=============== shares ================
    usershare max shares = 100
    ;============= permissions =============
    ; create mask = 0755
    ;================ debug ================
    log file = /var/log/samba/samba.%m.log
    log level = 3
    max log size = 50
    debug pid = no
    debug uid = no
    max log size = 200
    ;======= performance optimizations ======
    winbind enum users = No
    winbind enum groups = No
    socket options = TCP_NODELAY
    ;================ scripts ===============
    logon home = \\%L\%U\.profile
    logon path = \\%L\samba\profiles\%U
    logon drive = P:
    logon script = netlogon.bat
    add machine script = /usr/sbin/useradd -d /dev/null -g machines \-s /bin/false -M %U
    ; add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    ; add machine script = /usr/sbin/useradd -g nogroup -c "NT Machine Account" \-s /bin/false %m\$
    ;=============== printers ===============
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    load printers = yes
    ; display charset = ISO-8859-15
    unix charset = ISO-8859-15

    [Shared]
    comment = %L/Shared_on_%I
    path = /home/Shared
    valid users = @users
    write list = @users, guest
    force group = users
    read only = No
    acl group control = Yes
    create mask = 02774
    force create mode = 02774
    directory mask = 02774
    force directory mode = 02774
    inherit permissions = Yes
    inherit acls = Yes
    inherit owner = Yes
    map acl inherit = Yes
    case sensitive = No
    hide special files = Yes
    map archive = No
    strict locking = No
    follow symlinks = No

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,812

    Default Re: Samba, name resolution problem: file or folder not exist

    Hello and welcome here,

    I assume you have seen yourself that copy/paste of computer text directly in a post, does not produce a good readable result. The remedy is a feature on these forums that is not easy to find when you come here for the first time (like you). Please use the # button in the tool bar of the post editor. You will then get CODE tags in your post. When you then copy/paste your computer text (best is including prompt, command, output and next prompt) between those tags, the result will be much better.
    Henk van Velden

  3. #3

    Default Re: Samba, name resolution problem: file or folder not exist

    there is someone able to solve the problem? thanks 1k to everybody

  4. #4
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Samba, name resolution problem: file or folder not exist

    On 12/26/2013 1:56 PM, NeverGiveUp01 wrote:
    >
    > there is someone able to solve the problem? thanks 1k to everybody
    >
    >

    NeverGiveUp01;

    Is nmb running?
    Code:
    systemctl status nmb.service
    Is "netbios service" an allowed service through the firewall?

    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  5. #5
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Samba, name resolution problem: file or folder not exist

    On 12/26/2013 2:52 PM, PV wrote:

    >
    > Is "netbios service" an allowed service through the firewall?
    >


    Should read: "netbios server"
    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  6. #6

    Default Re: Samba, name resolution problem: file or folder not exist

    Quote Originally Posted by venzkep View Post
    On 12/26/2013 2:52 PM, PV wrote:

    >
    > Is "netbios service" an allowed service through the firewall?
    >


    Should read: "netbios server"
    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

    I thank you for your effort !!!

    Code:
     systemctl status nmb.service
    nmb.service - Samba NMB Daemon
       Loaded: loaded (/usr/lib/systemd/system/nmb.service; enabled)
       Active: active (running) since mer 2013-12-25 21:22:15 CET; 1 day 1h ago
     Main PID: 2006 (nmbd)
       CGroup: /system.slice/nmb.service
               └─2006 /usr/sbin/nmbd
    I also tried ping the netbios name
    with either Dolphin that with samba client
    Code:
    Netbook:/home/ivan # ping netbook
    PING Netbook (192.168.1.100) 56(84) bytes of data.
    64 bytes from Netbook (192.168.1.100): icmp_seq=1 ttl=64 time=0.114 ms
    64 bytes from Netbook (192.168.1.100): icmp_seq=2 ttl=64 time=0.080 ms
    64 bytes from Netbook (192.168.1.100): icmp_seq=3 ttl=64 time=0.080 ms
    I can explore all shares except the folder with the netbios name (Netbook), with either Dolphin that with samba client
    PS ...the firewall is temporarily disabled

  7. #7
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Samba, name resolution problem: file or folder not exist

    On 12/26/2013 4:46 PM, NeverGiveUp01 wrote:
    > Code:
    > --------------------
    >
    > Netbook:/home/ivan # ping netbook
    > PING Netbook (192.168.1.100) 56(84) bytes of data.
    > 64 bytes from Netbook (192.168.1.100): icmp_seq=1 ttl=64 time=0.114 ms
    > 64 bytes from Netbook (192.168.1.100): icmp_seq=2 ttl=64 time=0.080 ms
    > 64 bytes from Netbook (192.168.1.100): icmp_seq=3 ttl=64 time=0.080 ms
    >
    > --------------------
    >
    >
    > I can explore all shares except the folder with the netbios name
    > (Netbook), with either Dolphin that with samba client
    > PS ...the firewall is temporarily disabled

    NevergiveUp01;

    Ping will use the contents of /etc/hosts to resolve the name "netbook" (see your first post). To be clear, is "netbook"
    the name of a machine or a shared folder of some machine? I will assume for now it is the name of a machine. Is there a
    problem connecting to shares on any other machine? Has the firewall on "netbook" been properly configured? What
    operating system is on "netbook"? If it is only this one machine on which you cannot view shares, can other machines
    view its shares?

    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  8. #8

    Default Re: Samba, name resolution problem: file or folder not exist

    [QUOTE=venzkep;2611667]On 12/26/2013 4:46 PM, NeverGiveUp01 wrote:
    > Code:
    > --------------------
    >
    > Netbook:/home/ivan # ping netbook
    > PING Netbook (192.168.1.100) 56(84) bytes of data.
    > 64 bytes from Netbook (192.168.1.100): icmp_seq=1 ttl=64 time=0.114 ms
    > 64 bytes from Netbook (192.168.1.100): icmp_seq=2 ttl=64 time=0.080 ms
    > 64 bytes from Netbook (192.168.1.100): icmp_seq=3 ttl=64 time=0.080 ms
    >
    > --------------------
    >
    >
    > I can explore all shares except the folder with the netbios name
    > (Netbook), with either Dolphin that with samba client
    > PS ...the firewall is temporarily disabled

    NevergiveUp01;

    Ping will use the contents of /etc/hosts to resolve the name "netbook" (see your first post). To be clear, is "netbook"
    the name of a machine or a shared folder of some machine? I will assume for now it is the name of a machine. Is there a
    problem connecting to shares on any other machine? Has the firewall on "netbook" been properly configured? What
    operating system is on "netbook"? If it is only this one machine on which you cannot view shares, can other machines
    view its shares?

    --

    I have no shares with the name "netbook", days ago, as netbios name, I had "vaio" and everything worked properly, the only thing I did was change the netbios name and the host name with either "Netbook" (in / etc / HOSTNAME).
    The operating system that I use is openSUSE 13.1, installed on two computers and both the server and client have the same problem

    - Do I have to create a folder and rename it "Netbook"? (...file or folder smb://netbook not exist)
    - Do I have to create a machine name with "useradd" and call it a "netbook"?
    - In smb.conf (security = user) it is the correct ?

    eheheheh ... I have a lot of confusion

    Code:
    Netbook:/home/ivan # cat /var/lib/samba/browse.dat
    "WORKGROUP"               c0001000 "PENTIUM"                     "WORKGROUP"
    "NETBOOK"                    40819a03 "Samba3.6.12-2956-SUSE-SL12.3-i386(netbookWINS)" "WORKGROUP"
    "PENTIUM"                 40849a03 "Samba3.6.16-3033-SUSE-oS13.1-i386(pentiumWINS)" "WORKGROUP"
    Code:
    Netbook:/home/ivan # cat /var/lib/samba/wins.dat
    VERSION 1 0
    "WORKGROUP#1e" 1388384476 0.0.0.0 e4R
    "PENTIUM#00" 1388422277 192.168.1.130 64R
    "PENTIUM#20" 1388422277 192.168.1.130 64R
    "WORKGROUP#00" 1388384476 0.0.0.0 e4R
    "NETBOOK#20" 1388384476 192.168.1.100 66R
    "NETBOOK#00" 1388384476 192.168.1.100 66R
    "PENTIUM#03" 1388422277 192.168.1.130 64R
    "NETBOOK#03" 1388384476 192.168.1.100 66R

    Code:
            \\NETBOOK                       0.0.0.0_smb_4.1.3-3.12.1-3127-SUSE-oS13.1-i386
    name_resolve_bcast: Attempting broadcast lookup for name NETBOOK<0x20>
    Got a positive name query response from 127.0.0.1 ( 192.168.1.100 )
    samba_tevent: EPOLL_CTL_DEL EBADF for fde[0xb8656e68] mpx_fde[(nil)] fd[14] - disabling
    Connecting to 192.168.1.100 at port 445
    Doing spnego session setup (blob length=74)
    got OID=1.3.6.1.4.1.311.2.2.10
    got principal=not_defined_in_RFC4178@please_ignore         ----> ??????????
    Got challenge flags:
    Got NTLMSSP neg_flags=0x608a8215
    NTLMSSP: Set final flags:
    Got NTLMSSP neg_flags=0x60088215
    NTLMSSP Sign/Seal - Initialising with flags:
    Got NTLMSSP neg_flags=0x60088215
    SPNEGO login failed: Logon failure                           ----> ??????????
                    \\NETBOOK\CUPS-PDF              CUPS-PDF
                    \\NETBOOK\IPC$                  IPC Service (192.168.1.100_smb_4.1.3-3.12.1-3127-SUSE-oS13.1-i386)
                    \\NETBOOK\printer$           
                    \\NETBOOK\PrinterPDF           
                    \\NETBOOK\PrinterHP            
                    \\NETBOOK\NetTrash              
                    \\NETBOOK\Public               
                    \\NETBOOK\Shared              
                    \\NETBOOK\Users

  9. #9
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Samba, name resolution problem: file or folder not exist

    On 12/27/2013 12:56 AM, NeverGiveUp01 wrote:
    >

    <snip>
    >>
    >> --
    >>
    >> I have no shares with the name "netbook", days ago, as netbios name, I
    >> had "vaio" and everything worked properly, the only thing I did was
    >> change the netbios name and the host name with either "Netbook" (in /
    >> etc / HOSTNAME).


    Make any changes to your hostname in YaST>Network Settings, Hostname/DNS tab.

    >> The operating system that I use is openSUSE 13.1, installed on two
    >> computers and both the server and client have the same problem
    >>
    >> - Do I have to create a folder and rename it "Netbook"? (...file or
    >> folder smb://netbook not exist)

    No
    >> - Do I have to create a machine name with "useradd" and call it a
    >> "netbook"?

    No
    >> - In smb.conf (security = user) it is the correct ?

    Yes
    >>
    >> eheheheh ... I have a lot of confusion
    >>

    <snip>
    >


    NeverGiveUp01;

    Try reading the jdmcdaniel3's Blog S.A.C.T, here:

    https://forums.opensuse.org/blogs/jd...sion-1-02-124/

    Others have found this helpful. If Samba is still giving you difficulty after reading this blog, post the contents of
    /etc/samba/smb.conf from both machines.
    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  10. #10

    Default Re: Samba, name resolution problem: file or folder not exist

    Hi VenzKep

    with Yast I changed the hostname in"NetbookVaio" and than restarted the PC
    but, at the prompt I found the old hostname
    Therefore I tried again from "/etc/HOSTNAME"
    Code:
    # nano /etc/HOSTNAME
    I fixed it with:
    Code:
    # hostname-F /etc/HOSTNAME
    I updated the table "/etc /hosts" with "NetbokVaio"
    I updated the table "/etc/samba /lmhosts" with "NetbokVaio"

    I rebooted the PC and samba services updating
    Code:
    # systemctl restart nmb
    # systemctl restart smb
    # nmbd
    # hostname
    Woooow now everything works fine!!
    In conclusion, now I have:
    hostname = NetbookVaio and Netbios = Netbook
    I assume from this that they should be different ?

    Thanks 1K for your willingness to help me!!

    smbtree
    Code:
            \\NETBOOK                       0.0.0.0_smb_4.1.3-3.12.1-3127-SUSE-oS13.1-i386
    name_resolve_bcast: Attempting broadcast lookup for name NETBOOK<0x20>
    Got a positive name query response from 127.0.0.1 ( 192.168.1.100 )
    samba_tevent: EPOLL_CTL_DEL EBADF for fde[0xb8570748] mpx_fde[(nil)] fd[16] - disabling
    Connecting to 192.168.1.100 at port 445
    Doing spnego session setup (blob length=74)
    got OID=1.3.6.1.4.1.311.2.2.10
    got principal=not_defined_in_RFC4178@please_ignore
    Got challenge flags:
    Got NTLMSSP neg_flags=0x608a8215
    NTLMSSP: Set final flags:
    Got NTLMSSP neg_flags=0x60088215
    NTLMSSP Sign/Seal - Initialising with flags:
    Got NTLMSSP neg_flags=0x60088215
                    \\NETBOOK\CUPS-PDF              CUPS-PDF
                    \\NETBOOK\IPC$                  IPC Service (192.168.1.100_smb_4.1.3-3.12.1-3127-SUSE-oS13.1)
                    \\NETBOOK\printer$              
                    \\NETBOOK\PrinterPDF           
                    \\NETBOOK\PrinterHP            
                    \\NETBOOK\NetTrash              
                    \\NETBOOK\Public              
                    \\NETBOOK\Shared                
                    \\NETBOOK\Users

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •